Počítač se systémem Windows XP ukládá adresu IP proxy serveru namísto úplného názvu domény při konfiguraci aplikace Internet Explorer 6 pomocí funkce automatického zjišťování serveru Proxy

Překlady článku Překlady článku
ID článku: 903926
Důležité Tento článek obsahuje informace o úpravě registru. Ujistěte se, zda před úpravami je nutné registr zazálohovat. Ujistěte se, že víte, jak registr obnovit v případě, že dojde k potížím. Další informace o zálohování, obnovení a úpravách registru získáte článku znalostní báze Microsoft Knowledge Base:
256986 Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

V počítači se systémem Microsoft Windows XP nakonfigurujete aplikaci Microsoft Internet Explorer 6 pomocí funkce automatického zjišťování serveru Proxy. Pokud to uděláte, v registru jsou uloženy adresy IP serveru proxy, který hostí soubor Wpad.dat místo plně kvalifikovaný název domény (FQDN).

Příčina

Tomuto problému dochází, protože zdrojový kód pro soubor Wininet.dll je určena přeložit adresu IP proxy serveru, ze kterého byl stažen soubor Wpad.dat.

Řešení

Informace o opravě hotfix

Podporovaná oprava hotfix je k dispozici od společnosti Microsoft. Tato oprava hotfix je však určena pouze problém popsaný v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud není přísně tento problém, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix je k dispozici ke stažení, je sekce "Hotfix stažení k dispozici" v horní části tohoto článku. Pokud tento oddíl není uveden, obraťte se na podporu a služby zákazníkům společnosti, jak získat opravu hotfix.

Poznámka: Pokud nastanou další problémy nebo řešení potíží je vyžadován, pravděpodobně vytvořit samostatnou žádost. Výdaje na technickou podporu se bude u dalších otázek a problémů, které nelze vyřešit určitou konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu navštivte následující Web společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: "Hotfix stažení k dispozici" formulář zobrazí jazyky, pro které je oprava hotfix je k dispozici. Pokud váš jazyk není uveden, je to, protože oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Neexistují žádné požadavky.

Požadavek na restartování

Není nutné restartovat počítač po instalaci této opravy hotfix.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné další opravy hotfix.

Informace o souboru

Anglická verze této opravy hotfix má atributy souborů (nebo novější), jsou uvedeny v následující tabulce. Data a časy jednotlivých souborů jsou uvedeny v koordinovaný světový čas (UTC). Při zobrazení informací o souboru, je převeden na místní čas. Pomocí vyhledat rozdíl mezi místním časem a časem UTC naleznete Časové pásmo Karta v nástroji datum a čas v okně Ovládací panely.
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SP
Wininet.dll6.0.2800.1532586,75231. Ledna-200607: 13x 86AKTUALIZACE SP1
Wininet.dll6.0.2900.2838662,52801Únor 2006.06: 11x 86AKTUALIZACE SP2


Pokyny k instalaci

Upozornění Při nesprávných úpravách registru pomocí Editoru registru nebo jiným způsobem může dojít k vážným problémům. Tyto problémy mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nemůže zaručit, že tyto potíže lze vyřešit. Úpravy registru provádíte na vlastní nebezpečí.

Po instalaci této opravy hotfix je nutné povolit. Chcete-li to provést, postupujte takto:
  1. Klepněte na tlačítko Spustit, klepněte na tlačítko Spustit, typ regedita klepněte na tlačítko OK.
  2. Chcete-li povolit tuto opravu hotfix pro uživatele, vyhledejte následující podklíč registru:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
    Chcete-li povolit tuto opravu hotfix v počítači, vyhledejte následující podklíč registru:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Klepněte na klíč registru, který jste vyhledali v kroku 2.
  4. V Upravit příkaz Novýa klepněte na tlačítko Klíč.
  5. Typ FEATURE_WPAD_STORE_URL_AS_FQDN_KB903926, a pak stiskněte klávesu ENTER.
  6. Klepněte na tlačítko FEATURE_WPAD_STORE_URL_AS_FQDN_KB903926.
  7. V Upravit příkaz Novýa klepněte na tlačítko Hodnota DWORD.
  8. Typ Iexplore.exe, a pak stiskněte klávesu ENTER.
  9. Klepněte na tlačítko Iexplore.exe.
  10. V Upravit nabídky, klepněte na tlačítko Upravit.
  11. V Hodnota dat Typ pole 1a klepněte na tlačítko OK.
  12. V Upravit příkaz Novýa klepněte na tlačítko Hodnota DWORD.
  13. Typ Explorer.exe, a pak stiskněte klávesu ENTER.
  14. Klepněte na tlačítko Explorer.exe.
  15. V Upravit nabídky, klepněte na tlačítko Upravit.
  16. V Hodnota dat Typ pole 1a klepněte na tlačítko OK.

    Poznámka: Pro podklíč platné hodnoty jsou 0 a 1. Hodnota 1 povolí opravu hotfix. Hodnota 0 zakáže opravu hotfix.
  17. Ukončete Editor registru.
  18. Pokud jste aktualizovali HKEY_LOCAL_MACHINE registru podregistr, restartujte počítač. Pokud jste aktualizovali HKEY_CURRENT_USER podregistr registru odhlášení od počítače a potom znovu přihlásit se změny chování.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro".

Další informace

Další informace získáte klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 903926 - Poslední aktualizace: 22. května 2011 - Revize: 3.0
Klíčová slova: 
kbautohotfix kbqfe kbhotfixserver kbwinxpsp2fix kbwinxpsp1fix kbbug kbfix kbmt KB903926 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:903926

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com