A Windows XP-based computer stores the IP address of the proxy server instead of the FQDN when you configure Internet Explorer 6 to use the Automatic Proxy Discovery feature

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Article ID: 903926
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows registry
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SYMPTOMS

On a Microsoft Windows XP-based computer, you configure Microsoft Internet Explorer 6 to use the Automatic Proxy Discovery feature. When you do this, the registry stores the IP address of the proxy server that hosts the Wpad.dat file instead of the fully qualified domain name (FQDN).

CAUSE

This problem occurs because the source code for the Wininet.dll file is designed to use the resolved IP address of the proxy server from which the Wpad.dat file was downloaded.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
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File nameFile versionFile sizeDateTimePlatformSP requirement
Wininet.dll6.0.2800.1532586,75231-Jan-200607:13x86SP1
Wininet.dll6.0.2900.2838662,52801-Feb-200606:11x86SP2


Installation instructions

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install this hotfix, you must enable it. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. To enable this hotfix for a user, locate the following registry subkey:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
    To enable this hotfix for a computer, locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Click the registry key that you located in step 2.
  4. On the Edit menu, point to New, and then click Key.
  5. Type FEATURE_WPAD_STORE_URL_AS_FQDN_KB903926, and then press ENTER.
  6. Click FEATURE_WPAD_STORE_URL_AS_FQDN_KB903926.
  7. On the Edit menu, point to New, and then click DWORD value.
  8. Type Iexplore.exe, and then press ENTER.
  9. Click Iexplore.exe.
  10. On the Edit menu, click Modify.
  11. In the Value data box, type 1, and then click OK.
  12. On the Edit menu, point to New, and then click DWORD value.
  13. Type Explorer.exe, and then press ENTER.
  14. Click Explorer.exe.
  15. On the Edit menu, click Modify.
  16. In the Value data box, type 1, and then click OK.

    Note The valid values for the subkey are 0 and 1. A value of 1 enables the hotfix. A value of 0 disables the hotfix.
  17. Exit Registry Editor.
  18. If you updated the HKEY_LOCAL_MACHINE registry hive, restart the computer. If you updated the HKEY_CURRENT_USER registry hive, log off the computer, and then log on again to see the behavior changes.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 903926 - Last Review: October 9, 2011 - Revision: 2.0
Keywords: 
kbautohotfix kbqfe kbHotfixServer kbwinxpsp2fix kbwinxpsp1fix kbbug kbfix KB903926

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