การแก้ไข: คุณไม่สามารถใช้ Sysprep.exe เพื่อสร้างรูปภาพของเครื่องคอมพิวเตอร์ที่กำลังเรียกใช้การฝัง Windows Microsoft สำหรับจุดการใช้บริการ

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 903936 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

คุณไม่สามารถใช้เครื่องมือการเตรียมระบบ (Sysprep.exe) เพื่อสร้างรูปภาพของเครื่องคอมพิวเตอร์ที่กำลังเรียกใช้ Microsoft Windows ฝังสำหรับจุดของบริการ (WEPOS)

คุณอาจได้รับข้อความแสดงข้อผิดพลาดที่มีลักษณะดังต่อไปนี้::
ระบบไม่ติดตั้งอย่างสมบูรณ์ กรุณาเรียกใช้โปรแกรมติดตั้งอีกครั้ง

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากแฟ้มที่จำเป็นต้องเรียกใช้ Sysprep.exe ขาดหายไป

การแก้ไข

เมื่อต้องการแก้ไขปัญหานี้สำหรับ WEPOS โดยไม่มี Service Pack 3 ดำเนินการดังต่อไปนี้:
  1. ดาวน์โหลดแพคเกจการกระทำ KB903936.exe WePOS การขอรับการปรับปรุงซอฟต์แวร์นี้ แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
    http://www.microsoft.com/downloads/details.aspx?FamilyId=382E67CE-EBFD-43CC-AD83-B7953D49B5F4
  2. คัดลอกแฟ้ม KB903936.exe WePOS คอมพิวเตอร์ปลายทาง และจากนั้น คลิกสองครั้งที่แฟ้มเพื่อแยกการปรับปรุงซอฟต์แวร์
  3. หลังจากที่คุณได้ใช้การปรับปรุงซอฟต์แวร์ เพิ่มข้อมูลไปยังส่วน [แบบอัตโนมัติของแต่ละแฟ้ม Sysprep.inf ที่คุณสร้าง
    InstallFilesPath = c:\windows\fonts
    InstallFilesPath = c:\windows\system32
    หมายเหตุ:ถ้าคุณไม่ใส่ข้อมูลนี้ไปยังส่วน [แบบอัตโนมัติของแต่ละแฟ้ม Sysprep.inf ที่คุณสร้าง คุณอาจได้รับข้อความแสดงข้อผิดพลาดสองที่มีลักษณะข้อความต่อไปนี้:
    แฟ้มไม่พบ
    คุณได้รับข้อความแสดงข้อผิดพลาดเหล่านี้เมื่อคุณรัน Mini-Setup หรือ'ประสบการณ์ Microsoft ออกจากกล่อง เมื่อคุณได้รับข้อความแสดงข้อผิดพลาดเหล่านี้ แฟ้มที่หายไปจะอยู่ในเส้นทางของแฟ้มที่ระบุไว้ก่อนหน้านี้ในส่วนนี้

    หมายเหตุ:เมื่อต้องการรัน Mini-Setup หรือ Microsoft ออกจากกล่องประสบการณ์ โดยไม่มีข้อผิดพลาด คุณต้องติดตั้งคอมโพเนนต์ที่เป็นตัวเลือกต่อไปนี้เมื่อคุณติดตั้ง WEPOS:
    • การสนับสนุนโปรแกรมควบคุมเพิ่มเติม
    • เครื่องมือการจัดการในเครื่อง
    • บริการไคลเอ็นต์การจัดการ
    • แบบอักษรเพิ่มเติม
    • การสนับสนุนเพจรหัสเพิ่มเติม
    • อุปกรณ์ป้อนข้อมูลเพิ่มเติม
    นอกจากนี้ คัดลอกแฟ้มว่างที่ชื่อ 8514oemr.fon ไดเรกทอรี %SystemRoot%\Font (เป็นแฟ้มข้อความที่ว่างเปล่าที่สร้างขึ้นใน Notepad จะทำงาน)
เมื่อต้องการแก้ไขปัญหานี้สำหรับ WEPOS กับ Service Pack 3 สำหรับ WEPOS ที่ติดตั้ง ดำเนินการดังต่อไปนี้:
  1. เมื่อต้องการรัน Mini-Setup หรือ Microsoft ออกจากกล่องประสบการณ์ โดยไม่มีข้อผิดพลาด คุณต้องติดตั้งคอมโพเนนต์ที่เป็นตัวเลือกต่อไปนี้เมื่อคุณติดตั้ง WEPOS เริ่มต้นด้วย:
    • การสนับสนุนโปรแกรมควบคุมเพิ่มเติม
    • เครื่องมือการจัดการในเครื่อง
    • บริการไคลเอ็นต์การจัดการ
    • แบบอักษรเพิ่มเติม
    • การสนับสนุนเพจรหัสเพิ่มเติม
    • อุปกรณ์ป้อนข้อมูลเพิ่มเติม
  2. การติดตั้งการปรับปรุงนี้:
    http://www.microsoft.com/downloads/details.aspx?FamilyId=382E67CE-EBFD-43CC-AD83-B7953D49B5F4
    หมายเหตุ:ต้องถูกติดตั้งโปรแกรมปรับปรุงนี้ก่อนที่มีการติดตั้ง SP3
  3. การติดตั้งใด ๆ อื่น ๆ WEPOS เฉพาะการปรับปรุงที่จำเป็นสำหรับระบบ (การปรับปรุงเหล่านี้ต้องติดตั้งก่อนที่มีการติดตั้ง SP3)
  4. ติดตั้งการปรับปรุง Service Pack 3 สำหรับ Windows ฝังตัวสำหรับจุดการใช้บริการ
  5. การติดตั้งการปรับปรุงการรักษาความปลอดภัยของ SP3 การลงรายการบัญชีล่าสุด
  6. ติดตั้งโปรแกรมควบคุมที่จำเป็นทั้งหมด
  7. สร้างแฟ้มที่ชื่อ 8514oemr.fon และวางในไดเรกทอรี %SystemRoot%\Font (เป็นแฟ้มข้อความที่ว่างเปล่าที่สร้างขึ้นใน Notepad จะทำงาน)
  8. ถ้า kbdbhc.dll ไม่มีอยู่ สร้างแฟ้มที่ชื่อ kbdbhc.dll และวางในไดเรกทอรี %SystemRoot%\System32 (เป็นแฟ้มข้อความที่ว่างเปล่าที่สร้างขึ้นใน Notepad จะทำงาน)
  9. นอกเหนือจากการใช้ซอฟต์แวร์ KB903936 ปรับปรุง คุณต้องเพิ่มข้อมูลไปยังส่วน [แบบอัตโนมัติของแต่ละแฟ้ม Sysprep.inf ที่คุณสร้าง:
    InstallFilesPath = c:\windows\fonts
    InstallFilesPath = c:\windows\system32

    หมายเหตุ:ถ้าคุณไม่ใส่ข้อมูลนี้ไปยังส่วน [แบบอัตโนมัติของแต่ละแฟ้ม Sysprep.inf ที่คุณสร้าง คุณอาจได้รับข้อผิดพลาดสองที่มีลักษณะข้อความต่อไปนี้: "แฟ้มไม่พบ" เมื่อคุณรัน Mini-Setup หรือ'ประสบการณ์ Microsoft ออกจากกล่องได้

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับคำศัพท์ของการปรับปรุงซอฟต์แวร์ ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความใน Microsoft Knowledge Base::
824684คำอธิบายของคำศัพท์มาตรฐานที่ใช้เพื่ออธิบายปรับปรุงซอฟต์แวร์ของ Microsoft

คุณสมบัติ

หมายเลขบทความ (Article ID): 903936 - รีวิวครั้งสุดท้าย: 19 ตุลาคม 2553 - Revision: 2.0
ใช้กับ
  • Service Pack 3 for Windows Embedded for Point of Service and Windows Fundamentals for Legacy PCs
Keywords: 
kbprb kbbug kbfix kbqfe kbmt KB903936 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:903936

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com