An additional system drive letter appears in Windows Explorer after you apply Windows 2000 Update Rollup 1 for Service Pack 4

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Article ID: 904564
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SYMPTOMS

After you apply Microsoft Windows 2000 Update Rollup 1 for Service Pack 4 (SP4), an additional system drive letter appears in Windows Explorer.

Note This additional drive letter is also known as a ghost drive letter.

CAUSE

This problem occurs because of a change that is made to the Mountmgr.sys file when you apply Windows 2000 Update Rollup 1 for SP4. The hotfix that is described in the following Microsoft Knowledge Base article is included in this rollup:
832097 Drive letters are reassigned after you remove Dell OpenManage Array Manager
This hotfix helps retain non-sequential drive letters that are assigned to volumes. However, on some systems, this hotfix triggers the problem that is described in the "Symptoms" section.

RESOLUTION

Update rollup information

How to obtain the hotfix

This issue is fixed in the Update Rollup 1 for Microsoft Windows 2000 Service Pack 4 (SP4) Hotfix Package version 2. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
891861 Update Rollup 1 for Windows 2000 SP4 and known issues

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   15-Aug-2005  17:40  5.0.2195.7063      30,160  Mountmgr.sys
   07-Aug-2005  13:43  5.0.2195.7061      21,264  Mountmgrverchk.dll  

After you apply this hotfix

After you apply this hotfix, apply the Windows Update Rollup package. If you receive an error when you apply this hotfix, restart the computer.

Before you apply this hotfix, make sure that the following registry subkeys have the correct local paths for the system drive:
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows 2000\Sp5\KB832097\Filelist\0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows 2000\Sp5\KB832097\Filelist\7
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows 2000\Sp5\Update Rollup 1\Filelist\39
If you find a different drive letter from the drive letter in the SystemDrive environment variable, the installation process is unsuccessful. If you find the same drive letter, the installation process is successful.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 904564 - Last Review: October 9, 2011 - Revision: 2.0
Keywords: 
kbautohotfix kbfix kbbug kbHotfixServer kbqfe KB904564

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