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VPN connections time out when the “Requests appear to come from the ISA server computer” server publishing rule is applied in ISA Server 2004

Article ID:904825
Last Review:December 4, 2007
Revision:3.7
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SYMPTOMS

Consider the following scenario. You publish a virtual private network (VPN) server that uses Point-to-Point Tunneling Protocol (PPTP) in Microsoft Internet Security and Acceleration Server (ISA) 2004. You apply the Requests appear to come from the ISA server computer server publishing rule in ISA Server 2004 to enable server publishing even when the published server is not a Secure Network Address Translation (SNAT) client. In this scenario, VPN connections time out during the user-name and password verification stage. Therefore, VPN clients cannot connect to the PPTP VPN server.

Note You may not experience these symptoms if the published server is configured as a SecureNAT client of the ISA Server computer.

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CAUSE

PPTP connections use the Generic Route Encapsulation (GRE) protocol to encapsulate data. The encapsulated data is added to a GRE packet that carries the data between two tunnel end points.

When you apply the Requests appear to come from the ISA server computer server publishing rule, ISA Server 2004 must translate the IP address of these packets into the IP address of the ISA Server computer.

This problem occurs because the IP address of the GRE packets is not translated in compliance with the publishing rule. Therefore, the VPN connection times out.

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RESOLUTION

ISA Server 2004, Enterprise Edition and ISA Server 2004, Standard Edition

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Service pack information

To resolve this problem, obtain the latest service pack for Internet Security and Acceleration Server 2004. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
891024 (http://support.microsoft.com/kb/891024/) How to obtain the latest ISA Server 2004 service pack

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Hotfix Information

To resolve this problem, obtain the latest service pack for ISA Server 2004. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
891024 (http://support.microsoft.com/kb/891024/) How to obtain the latest ISA Server 2004 service pack

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ISA Server 2004, Standard Edition

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have ISA Server 2004, Standard Edition Service Pack 1 (SP1) installed on your computer.

Restart information

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Fweng.sys4.0.2163.277340,19208-Aug-200505:08Not Applicable
Pptpfltr.dll4.0.2163.27765,24808-Aug-200505:08x86
Wspsrv.exe4.0.2163.277935,13608-Aug-200505:08x86

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Internet Security and Acceleration Server 2004 Service Pack 2.

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MORE INFORMATION

For more information about how to install ISA Server 2004 hotfixes and updates, click the following article number to view the article in the Microsoft Knowledge Base:
885957 (http://support.microsoft.com/kb/885957/) How to install ISA Server hotfixes and updates
For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Microsoft Internet Security and Acceleration Server 2004 Enterprise Edition
Microsoft Internet Security and Acceleration Server 2004 Standard Edition
Microsoft Internet Security and Acceleration Server 2000 Service Pack 1, when used with:
  Microsoft Internet Security and Acceleration Server 2004 Standard Edition

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Keywords: 
kbautohotfix kbtshoot kbfix kbbug kbhotfixserver KB904825

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