คุณอาจได้รับการ "การดำเนินงานเสร็จสมบูรณ์" ข้อความก่อนที่จะประมวลผลการกำหนดค่าเสร็จสมบูรณ์เมื่อคุณเรียกใช้ตัวช่วยสร้างการตั้งค่าคอนฟิกใน BizTalk Server 2004

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 904849 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
สิ่งสำคัญบทความนี้ประกอบด้วยข้อมูลเกี่ยวกับวิธีการแก้ไขรีจิสทรี ควรตรวจสอบว่าได้สำรองรีจิสทรีก่อนที่จะปรับเปลี่ยน โปรดทำความเข้าใจกับวิธีการคืนค่ารีจิสทรีในกรณีที่เกิดปัญหา สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีสำรองข้อมูล คืนค่า และปรับเปลี่ยนรีจิสทรี โปรดคลิกที่หมายเลขบทความต่อไปนี้ เพื่อดูบทความใน Microsoft Knowledge Base::
256986คำอธิบายสำหรับ Microsoft Windows Registry
สิ่งสำคัญบทความนี้ประกอบด้วยข้อมูลที่แสดงวิธีการที่ช่วยให้การตั้งค่าการรักษาความปลอดภัยที่ต่ำหรือวิธีการปิดคุณลักษณะการรักษาความปลอดภัยบนเครื่องคอมพิวเตอร์ คุณสามารถเปลี่ยนแปลงการตั้งค่าเหล่านี้ เพื่อแก้ปัญหาเฉพาะแต่ละอย่างได้ ก่อนที่คุณจะเปลี่ยนแปลงการตั้งค่าเหล่านี้ เราขอแนะนำให้คุณประเมินความเสี่ยงที่เกี่ยวข้องกับการใช้วิธีแก้ปัญหานี้ในสภาพแวดล้อมของคุณ หากคุณดำเนินการนี้ โปรดดำเนินการตามขั้นตอนเสริม เพื่อช่วยป้องกันระบบของคุณ
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

เมื่อคุณเรียกใช้ตัวช่วยสร้างการตั้งค่าคอนฟิก (ConfigFramework.exe) ใน Microsoft BizTalk Server 2004 คุณอาจได้รับข้อความแสดงข้อความที่คล้ายกับข้อความต่อไปนี้:
การดำเนินการเสร็จสมบูรณ์
คุณได้รับข้อความนี้ก่อนที่แถบความคืบหน้าบ่งชี้ว่า กระบวนการกำหนดค่าเสร็จสมบูรณ์แล้ว

เมื่อคุณคลิกลองอีกครั้งปรากฏข้อความเดียวกัน เมื่อคุณคลิกยกเลิกตัวช่วยสร้างการตั้งค่าคอนฟิกย้อนกลับการกำหนดค่าเซิร์ฟเวอร์ BizTalk

สาเหตุ

ปัญหานี้อาจเกิดขึ้นเมื่อมีการรักษาความปลอดภัย (RPC) การเรียกขั้นตอนระยะไกลที่ใช้โดย Microsoft แจกจ่ายธุรกรรม Coordinator (MSDTC) ล้มเหลว มีการเกิดปัญหาด้านการรักษาความปลอดภัย RPC ระหว่างคอมพิวเตอร์ที่ใช้ BizTalk Server 2004 และคอมพิวเตอร์ที่รัน Microsoft SQL Server 2000

หมายเหตุ:ฐานข้อมูลเซิร์ฟเวอร์ BizTalk ที่อยู่บนคอมพิวเตอร์ที่ใช้ SQL Server 2000

โดยค่าเริ่มต้น เมื่อคอมพิวเตอร์ Coordinator ทรานแซคชันการแจกจ่าย (DTC) ไม่ได้ทำงานอยู่ในโดเมน Microsoft Windows ธุรกรรมที่วางจำหน่ายไม่ ลักษณะการทำงานนี้เกิดขึ้นเนื่องจากการรักษาความปลอดภัย RPC ที่ DTC ใช้ไม่ได้ทำงานในสภาพแวดล้อมการทำงานนี้ ดังนั้น ธุรกรรมที่มีการแจกจ่ายจะล้มเหลวหากคอมพิวเตอร์ DTC ไม่อยู่ในโดเมนที่เชื่อถือได้

โดยค่าเริ่มต้นใน Microsoft Windows Server 2003 ความปลอดภัย RPC เปิดอยู่ ดังนั้น ธุรกรรมการกระจายการดำเนินงานจะล้มเหลวหากคอมพิวเตอร์อยู่ ในสภาพแวดล้อมแบบเวิร์กกรุ๊ป หรือ ในโดเมนที่ไม่ใช่โดเมนที่เชื่อถือได้

การแก้ไข

เมื่อต้องการแก้ไขปัญหานี้ ย้ายคอมพิวเตอร์เข้ากับโดเมนที่เชื่อถือได้ เมื่อต้องการย้ายคอมพิวเตอร์เข้ากับโดเมนที่แตกต่างกัน ใช้ใน Active Directory โยกย้ายเครื่องมือ (ADMT) สำหรับข้อมูลเพิ่มเติมเกี่ยวกับการ ADMT แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyID=788975b1-5849-4707-9817-8c9773c25c6c

การหลีกเลี่ยงปัญหา

สิ่งสำคัญขั้นตอนเหล่านี้อาจเพิ่มความเสี่ยงด้านความปลอดภัยของคุณ คำเตือน ขั้นตอนเหล่านี้อาจทำให้เครื่องคอมพิวเตอร์หรือเครือข่ายของคุณมีความเสี่ยงที่จะถูกโจมตีจากผู้ใช้ที่ก่อให้เกิดความเสียหายหรือซอฟต์แวร์ที่เป็นอันตรายอย่างเช่นไวรัสได้ ขอแนะนำให้ใช้ขั้นตอนในบทความนี้เพื่อเปิดโปรแกรมเพื่อใช้งานตามที่ออกแบบมา หรือเพื่อใช้ความสามารถต่างๆ ของโปรแกรมตามที่กำหนดไว้ ก่อนที่คุณจะดำเนินการเปลี่ยนแปลง ขอแนะนำให้คุณประเมินความเสี่ยงที่เกี่ยวข้องกับการใช้ขั้นตอนนี้ในสภาพแวดล้อมของคุณ หากคุณเลือกที่จะใช้กระบวนการนี้ ให้ใช้ขั้นตอนเพิ่มเติมที่เหมาะสมเพื่อช่วยปกป้องระบบของคุณ ขอแนะนำให้คุณใช้ขั้นตอนนี้เมื่อคุณจำเป็นต้องใช้จริงๆ เท่านั้น

ถ้าคุณไม่สามารถย้ายคอมพิวเตอร์เข้ากับโดเมนที่เชื่อถือได้ คุณสามารถปิดการรักษาความปลอดภัย RPC

คำเตือนตรวจสอบว่า คอมพิวเตอร์อยู่ในสภาพแวดล้อม isolated ที่มีไฟร์วอลล์ก่อนที่คุณปิดการรักษาความปลอดภัย RPC

เมื่อต้องการปิดใช้งานการรักษาความปลอดภัย RPC ใช้รายการใดรายการหนึ่งในวิธีการต่อไปนี้:
  • สำหรับคอมพิวเตอร์ที่รัน Microsoft Windows Server 2003 Service Pack 1 (SP1)
    1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:Dcomcnfg.exeแล้ว คลิกตกลง.
    2. ขยายบริการคอมโพเนนต์ขยายคอมพิวเตอร์คลิกขวาMy Computerแล้ว คลิกคุณสมบัติ.
    3. ในการคุณสมบัติของคอมพิวเตอร์ของฉันกล่องโต้ตอบ คลิกการmsdtcแท็บ แล้วคลิกการกำหนดค่าการรักษาความปลอดภัย.
    4. ในการการกำหนดค่าการรักษาความปลอดภัยกล่องโต้ตอบ คลิกเพื่อเลือกนั้นการเข้าถึง DTC เครือข่ายกล่องกาเครื่องหมาย จากนั้น คลิกเพื่อเลือกรับรองความถูกต้องไม่จำเป็นภายใต้การติดต่อสื่อสารตัวจัดการธุรกรรม.
    5. คลิกตกลงแล้ว คลิกใช่เมื่อต้องการเริ่มต้นบริการ MSDTC
    6. หลังจากที่มีการเริ่มบริการใหม่ คลิกตกลง.
    7. คลิกตกลงเมื่อต้องการปิดการคุณสมบัติของคอมพิวเตอร์ของฉันกล่องโต้ตอบ
  • สำหรับคอมพิวเตอร์ที่ใช้ Windows Server 2003 โดยไม่มี SP1
    คำเตือนปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีอย่างไม่ถูกต้อง โดยใช้ตัวแก้ไขรีจิสทรี หรือ โดยใช้วิธีอื่น คุณอาจต้องติดตั้งระบบปฏิบัติการใหม่เพื่อแก้ไขปัญหาเหล่านี้ Microsoft ไม่รับประกันว่าจะสามารถแก้ไขปัญหาได้ คุณต้องยอมรับความเสี่ยงด้วยตนเองในการปรับเปลี่ยนรีจิสทรี

    เพิ่มรายการรีจิสทรี DWORD ต่อไปนี้ และตั้งค่าเป็น 1:
    TurnOffRpcSecurity
    โดยให้ทำตามขั้นตอนต่อไปนี้::
    1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:regeditแล้ว คลิกตกลง.
    2. ค้นหาและคลิกคีย์ย่อยดังต่อไปนี้:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSDTC
    3. ในการแก้ไขเมนู คลิกใหม่แล้ว คลิกค่า DWORD.
    4. ประเภท:TurnOffRpcSecurityแล้ว กดป้อน.
    5. คลิกขวาTurnOffRpcSecurityแล้ว คลิกปรับเปลี่ยน.
    6. ในการแก้ไขค่า DWORDกล่องโต้ตอบ คลิกฐานสิบประเภท:1การปิดใช้งานการรักษาความปลอดภัย RPC แล้ว คลิกตกลง.
    7. ในการแฟ้ม:เมนู คลิกexit.

คุณสมบัติ

หมายเลขบทความ (Article ID): 904849 - รีวิวครั้งสุดท้าย: 16 มกราคม 2554 - Revision: 2.0
ใช้กับ
  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Standard Edition
  • Microsoft BizTalk Server 2004 Developer Edition
  • Microsoft BizTalk Server 2004 Partner Edition
Keywords: 
kbcomservices kbauthentication kbconfig kbinfo kbtshoot kbprb kbmt KB904849 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:904849

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com