Exchange 2000 Server und Exchange Server 2003 die Leistung möglicherweise beeinträchtigt werden Desktopsuche-Modul Software auf Outlook oder anderen MAPI-Clientcomputer ausgeführt wird

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Zusammenfassung

Dieser Artikel beschreibt Probleme, die auftreten können, auf dem Outlook oder MAPI-Client-Computer und auf dem Exchange-Server beim Client Computerbenutzer eine Desktopsuche-Datenbankmodul verwenden. Dieser Artikel beschreibt die Benutzer zu identifizieren, die desktop Suchmaschinen verwenden. Dieser Artikel beschreibt außerdem die folgenden Methoden, mit denen Sie die Probleme verringern, die von desktop Suchmaschinen verursacht werden:
  • verwenden Exchange-Cachemodus in Microsoft Office Outlook 2003.
  • Plan für Desktopsuche-Modul verwenden, beim Planen Ihrer Exchange-Server-Umgebung.
  • Verwendung Client?side von Richtlinien, damit Benutzer über die Desktopsuche Module.
  • sollten Sie verwenden Exchange-Inhaltsindizierung.

Problembeschreibung

Wenn Sie einen Microsoft Outlook 2002 oder Microsoft Office Outlook 2003-Clientcomputer verwenden, können Verzögerungen auftreten. Darüber hinaus erhalten Sie die folgenden RPC-Verbindung Nachricht:
Outlook wird vom Exchange-Server Informationen anfordert.
Wenn Sie einem Clientcomputer mit eine frühere Version von Outlook oder ein anderes MAPI-Client-Computer verwenden, können Verzögerungen auftreten. Oder der Computer nur scheinbar nicht mehr reagieren (hängen). Auf einem Server, auf dem Microsoft Exchange 2000 Server ausgeführt wird oder Microsoft Exchange Server 2003 werden Sie höhere CPU in den Prozess "Store.exe" oder höher als erwartet Datenbank Datenträgeraktivität feststellen.

Ursache

Dieses Problem tritt auf, wenn der Outlook-Clientcomputer oder dem anderen MAPI-Clientcomputer desktop Suchmaschine ausgeführt, die mit Outlook index Postfach oder Daten auf dem Exchange Server für Öffentliche Ordner des Benutzers integriert.

Die Anzahl der desktop Suchmaschinen wie MSN Desktopsuche, verwenden Benutzer ist erhöhen. Das Vorhandensein des desktop Suchmaschinen einer Benutzer-Basis kann verdoppeln oder triple die Last auf einem Exchange Server. Die erhöhte oder ungünstig verlaufenden, Verwendung von Serverressourcen führt zu einer Wahrnehmung der Leistungseinbußen auf dem Clientcomputer. Verbesserte Verwendung von Serverressourcen führt auch zu spürbaren Server Leistung Zugriffe. Diese Probleme wurden mit mehreren verschiedenen desktop Suchmaschinen beobachtet, die in die Suchfunktion Postfach integriert.

Die folgenden Probleme auftreten, wenn Benutzer desktop Suchmaschinen verwenden:
  • Erhöhte CPU verwenden und Datenträger-e/A-Aktivitätsspitzen auf dem Exchange Server
  • RPC-Engpässe auf dem client
  • Erhöht die RPC-Vorgänge pro Sekunde auf dem Exchange Server
Diese Probleme möglicherweise zu erhöhten insgesamt RPC gemittelt führen Wartezeit Werte auf dem Exchange-Server. Erhöhte gemittelt RPC-Wartezeit Werte möglicherweise die Symptome, die im Abschnitt "Problembeschreibung" beschrieben werden. Auf dem Clientcomputer kann die desktop Suchmaschine viele RPC-Anforderungen an den Server senden. Dadurch wird einen Client-RPC-Engpass. Wenn ein Client-RPC-Engpass auftritt, eine verzögerte RPC-Antwort kann auftreten, obwohl der Server arbeitet wie erwartet und keine Netzwerkverbindungsprobleme auftreten.

Lösung

Wie Benutzer zu identifizieren, die Desktopsuche-Module arbeiten

Zum Identifizieren der Benutzer, die ein desktop Suchmodul für die Exchange-Server verwenden, können Sie das Microsoft Exchange Server User Monitor-Tool (exmon.exe) verwenden.

Die folgende Datei steht im Microsoft Download Center zum Download zur Verfügung:
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Download
Download the Exmon.exe package now.
Weitere Informationen zum Microsoft Support-Dateien herunterladen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
119591So erhalten Sie Dateien vom Microsoft Support im Internet
Microsoft hat diese Datei auf Viren überprüft. Microsoft hat dazu die neueste Software zur Virenerkennung verwendet, die zum Zeitpunkt der Bereitstellung verfügbar war. Die Datei wird auf Servern mit verstärkter Sicherheit gespeichert, nicht autorisierte Änderungen an der Datei verhindert.


Informationen, wie das Exchange Server User Monitor-Tool verwenden finden Sie in der Tool-Syntax-Dokumentation, die im Installationsordner verfügbar ist, nachdem Sie das Tool installiert.


Mit diesem Tool können Sie Ihnen, bestimmte MAPI-Clients erkennen, die für die höchste Aktivität auf dem Server verantwortlich sind.

Microsoft Exchange Server Performance Troubleshooting Analyzer Tool können Sie darüber hinaus können Sie Leistungsinformationen sammeln und Analysieren von Informationen, die das EXMON.EXE-Tool erstellt. Um Microsoft Exchange Server Performance Troubleshooting Analyzer Tool downloaden den folgenden Microsoft-Website:
http://www.microsoft.com/downloads/details.aspx?familyid=4BDC1D6B-DE34-4F1C-AEBA-FED1256CAF9A&displaylang=en

Wie die Anzahl der Probleme verringert, die mit einem desktop Suchmodul verknüpft sind

Verwenden Sie die Anzahl der Probleme zu reduzieren, die mit einem desktop Suchmodul verknüpft sind, eine oder mehrere der folgenden Methoden.

Methode 1: Verwenden des Exchange-Cachemodus-Features in Outlook 2003

Beim Konfigurieren von Outlook 2003 in Exchange-Cachemodus ausgeführt werden, sucht die desktop Suchmaschine die lokale Kopie anstelle des Postfach-Inhalts, der auf dem Server ist das Postfach.

Hinweis: Diese Methode nicht nützlich, wenn die desktop Suchmaschine eine Option zum Durchsuchen von öffentlicher Ordnern von Exchange enthält. Öffentliche Ordner werden nicht zwischengespeichert. Nicht alle Desktopsuche-Module enthalten jedoch eine Option zum Durchsuchen von öffentlicher Ordnern.

Methode 2: Planen für eine erhöhte Last beim Planen Ihrer Exchange Server-Umgebung

Wenn Sie erwarten, dass Benutzer desktop Suchmaschinen auf den Clientcomputern ausgeführt werden, Planen Sie für eine erhöhte Last beim Planen Ihrer Exchange Server-Umgebung, wenn folgenden Bedingungen erfüllt sind:
  • Benutzer werden nicht werden verwenden Outlook 2003 im Exchange-Cache-Modus.
  • Benutzer werden eine frühere Version von Outlook verwenden.
  • Benutzer werden eine andere MAPI-Client verwenden.
Die folgende Liste enthält einige allgemeinen Richtlinien zum Planen Ihrer Exchange Server-Umgebung:
  • Stellen Sie sicher, dass der Exchange-Server, verfügt genügend CPU-Kapazität und ausreichend Datenträger-e/a-Bandbreite die erwartete Belastung verarbeiten, die hinzugefügt wird, wenn Benutzer desktop Suchmaschinen verwenden. Die genaue Leistung Auswirkungen auf Ihre Umgebung sollte gemessen und mit der Leistungsbasislinie verglichen werden. Weitere Informationen darüber, wie Leistungsinformationen sammeln und einen Basisplan erstellen finden Sie unter den folgenden Microsoft-Websites:
    http://technet.microsoft.com/en-us/library/755d32d3-0894-4e77-bfb1-a0ff6bb97a4d.aspx

    http://technet.microsoft.com/en-us/library/10be5826-45b2-48e7-8450-4ec8dd63beb0.aspx
  • Da Indizierung Zeiten und Häufigkeit durch den Client und nicht durch den Server gesteuert werden, kann der Server auftreten, höhere CPU-Verwendung und Datenträger-e/A-Aktivitätsspitzen. Diese Spitzen können Sie in einer vorhandenen Exchange-Umgebung ungefähre Wenn Indizierung stattfindet. Sie können dann planen, dass die Exchange-Serverleistung entsprechend aktualisiert. Wenn Sie eine neue Exchange Server-Umgebung können Sie eine Übungseinheit So testen Sie die Auswirkungen von mehreren Clients, die Inhaltsindizierung Ihren Postfachspeicher erstellen. Die Ergebnisse dieser Tests können Sie um die Leistung Spezifikationen für den Exchange-Server zu planen. Wenn Sie eine neue Exchange Server-Umgebung erstellen, können Sie zum Planen von Gruppen von Clientcomputern auszuführenden Inhaltsindizierung um die Leistung auf dem Exchange Server Last möglicherweise.
  • Überwachen Sie die Speichernutzung auf dem Server. Weitere Informationen der folgenden Microsoft-Website:
    http://technet.microsoft.com/en-us/library/4b012bda-8711-4617-9239-f3527de884a3.aspx
  • Überwachen des Servers für die Fragmentierung des virtuellen Speichers.
  • Überwachen Sie den Server für Ereignis-ID 9646 Nachrichten. Ereignis ID 9646 Nachrichten möglicherweise protokolliert, wenn eine Suchmaschine auf dem Clientcomputer viele Objekte auf dem Server öffnet. Weitere Informationen über die-ID 9646 Ereignisnachricht finden Sie im folgenden Artikel der Microsoft Knowledge Base:
    830829Nachdem ein MAPI-Client mehr als den Standardwert bestimmter Serverobjekte geöffnet, reagiert Ihr Exchange Server 2003-Computer möglicherweise

Methode 3: Verhindern Sie, dass die Benutzer mithilfe von desktop Suchmaschinen

Client-Softwarerichtlinien können Sie verhindern, dass Benutzer desktop Suchmaschinen verwenden.

Methode 4: Prüfen Sie Exchange-Inhaltsindizierung aktivieren

Möglicherweise möchten Sie die Vorteile der Exchange-Inhaltsindizierung aktivieren auswerten. In einigen Fällen können Sie feststellen, dass wenn Sie die Exchange-Inhaltsindizierung aktivieren, Sie Suchergebnisse schneller beim Ausführen einer Suche anhand der Postfachinhalte als wenn Sie desktop Suchmaschine auf dem Clientcomputer.

Informationsquellen

Weitere Informationen zum Isolieren von Leistungsproblemen finden Sie im Exchange Server 2003 Performance Troubleshooting Guide. Problembehandlung bei Exchange Server 2003 Performance Handbuch anzeigen, die folgende Microsoft-Website:
http://technet.microsoft.com/en-us/library/aa997270.aspx

Eigenschaften

Artikel-ID: 905184 - Geändert am: Dienstag, 27. November 2007 - Version: 2.7
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Office Outlook 2003
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 2000
  • Microsoft Outlook 98 Standard Edition
  • Microsoft Outlook 97 Standard Edition
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 905184
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