Влияние работы программы поиска на рабочем столе на компьютерах с Outlook или другим клиентом MAPI на производительность Exchange 2000 Server и Exchange Server 2003

Переводы статьи Переводы статьи
Код статьи: 905184 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Аннотация

В данной статье описываются проблемы, которые могут возникнуть на клиентском компьютере с Outlook или MAPI и на сервере Exchange, когда на клиентском компьютере используется программа поиска на рабочем столе. В статье описывается, как определить пользователей, которые пользуются программой поиска. Также в ней рассматриваются следующие способы снижения влияния работы поисковых программ:
  • Использование режима кэширования Exchange в Microsoft Office Outlook 2003;
  • Планирование использования программ поиска на рабочем столе при организации среды сервера Exchange;
  • Применение политики ограничения использования программ на клиентских компьютерах во избежание использования программ поиска на рабочем столе;
  • Использование индексации содержимого в Exchange.

Проблема

При использовании клиентского компьютера с Microsoft Outlook 2002 или Microsoft Office Outlook 2003 могут возникать задержки. Кроме того, может появляться следующее сообщение подключения RPC:
Outlook запрашивает информацию с сервера Exchange.
Если используется клиентский компьютер с более ранней версией Outlook или другим MAPI-клиентом, также могут возникать задержки в работе. Может также создаться впечатление, что компьютер перестает отвечать (зависает). На сервере под управлением Microsoft Exchange 2000 Server или Microsoft Exchange Server 2003 можно заметить повышенную загрузку центрального процессора в процессе Store.exe или неожиданно высокую активность диска с базой данных.

Причина

Данная проблема возникает, если на клиентском компьютере с Outlook или другим MAPI-клиентом работает программа поиска на рабочем столе, которая использует Outlook для индексации данных почтового ящика пользователя или общей папки, расположенной на сервере Exchange.

Количество пользователей, использующих программы поиска на рабочем столе, такие как MSN Desktop Search, увеличивается. Наличие программ поиска на рабочем столе в базе пользователя может удвоить или утроить нагрузку на сервер Exchange. Повышенное или нерациональное использование серверных ресурсов приводит к тому, что складывается впечатление плохой производительности клиентского компьютера. Повышенное использование ресурсов сервера также приводит к заметным скачкам производительности сервера. Такие проблемы были замечены при применении нескольких различных программ поиска на рабочем столе, использующих функцию поиска по почтовым ящикам.

При использовании программ поиска на рабочем столе могут возникнуть следующие проблемы:
  • повышенная загрузка центрального процессора и активное обращение к диску на сервере Exchange;
  • снижение скорости вызова удаленных процедур (RPC) на стороне клиента;
  • увеличение числа вызовов удаленных процедур (RPC) в секунду на сервере Exchange.
Эти проблемы могут привести к общему повышению значений среднего запаздывания вызова удаленных процедур на сервере Exchange. Повышение значений среднего запаздывания вызова удаленных процедур может вызвать проблемы, описанные в разделе «Проблемы». На клиентском компьютере программа поиска на рабочем столе может посылать большое количество вызовов удаленных процедур на сервер. Это приводит к снижению скорости вызова процедур на стороне клиента. В этом случае могут происходить задержки ответа на вызов удаленных процедур, даже несмотря на то, что сервер работает в обычном режиме и отсутствуют проблемы подключения по сети.

Решение

Определение пользователей, которые пользуются программой поиска

Для выявления пользователей, использующих программу поиска на рабочем столе на сервере Exchange, можно воспользоваться компонентом Microsoft Exchange Server User Monitor (Exmon.exe).

Загрузите следующий файл с веб-узла центра загрузки Майкрософт:
Свернуть это изображениеРазвернуть это изображение
Загрузка
Загрузить пакет Exmon.exe.
Дополнительные сведения о загрузке файлов с узла технической поддержки корпорации Майкрософт см. в следующей статье базы знаний Майкрософт:
119591 Как загрузить файлы поддержки Microsoft из Интернета
Корпорация Майкрософт проверила этот файл на наличие вирусов. Корпорация Майкрософт использует последние версии антивирусного программного обеспечения на момент публикации файла для проверки его на наличие вирусов. Файл хранится на закрытом сервере, что предотвращает его несанкционированное изменение.


Дополнительные сведения об использовании компонента Exchange Server User Monitor см. в документации по использованию компонента в папке, в которую он был установлен.


Данный компонент можно использовать для идентификации отдельных MAPI-клиентов, вызывающих повышенную активность сервера.

Кроме того, можно воспользоваться компонентом Microsoft Exchange Server Performance Troubleshooting Analyzer для сбора сведений о производительности и анализа данных, полученных в результате использования компонента EXMON.EXE. Загрузить компонент Microsoft Exchange Server Performance Troubleshooting Analyzer можно со следующего веб-узла Майкрософт:
http://www.microsoft.com/downloads/details.aspx?familyid=4BDC1D6B-DE34-4F1C-AEBA-FED1256CAF9A&displaylang=en

Снижение числа проблем, связанных с работой поисковых программ

Снизить число проблем, связанных с работой программ поиска на рабочем столе, можно следующими способами.

Способ 1. Использование режима кэширования Exchange в Outlook 2003

Если настроить Outlook 2003 на работу в режиме кэширования Exchange, программа поиска на рабочем столе будет выполнять поиск только в локальной копии почтового ящика вместо того, чтобы искать в содержимом почтового ящика на сервере.

Примечание. Данный способ не будет эффективным, если программа поиска на рабочем столе может выполнять поиск в общих папках на сервере Exchange. Общие папки не кэшируются. Однако не во всех программах поиска на рабочем столе есть возможность поиска по общим папкам.

Способ 2. Планирование повышенной нагрузки при организации среды сервера Exchange

В случае если ожидается, что пользователи будут использовать программы поиска на рабочем столе на клиентских компьютерах, будет целесообразно запланировать повышенную нагрузку еще на этапе организации среды сервера Exchange. Это следует делать, если:
  • пользователи не будут использовать Outlook 2003 в режиме кэширования Exchange;
  • пользователи будут использовать более раннюю версию Outlook;
  • пользователи будут использовать другие MAPI-клиенты.
В следующем списке дается несколько общих указаний по организации среды сервера Exchange:
  • Убедитесь, что сервер Exchange обладает достаточной производительностью центрального процессора и достаточной пропускной способностью жесткого диска для работы с нагрузкой, ожидаемой при использовании программ поиска на рабочем столе. Следует точно измерить воздействие на производительность системы и сравнить его с базовым уровнем производительности сервера. Дополнительные сведения о сборе данных о производительности и создании базового уровня см. на следующих веб-узлах Майкрософт:
    http://www.microsoft.com/technet/prodtechnol/exchange/guides/E2k3Perf_ScalGuide/755d32d3-0894-4e77-bfb1-a0ff6bb97a4d.mspx

    http://technet.microsoft.com/en-us/library/10be5826-45b2-48e7-8450-4ec8dd63beb0.aspx
  • В связи с тем, что время и частота индексации устанавливаются не на сервере, а на клиентском компьютере, на сервере могут возникать превышения загрузки центрального процессора и скачки обращений к жесткому диску. В существующей среде Exchange данные по этим скачкам можно использовать для расчета времени, когда выполняется индексация. Имея эти данные, можно запланировать соответствующую модернизацию сервера Exchange. При создании новой среды сервера Exchange можно создать лабораторию для тестирования воздействия, которое оказывают несколько одновременно работающих на клиентских компьютерах программ, индексирующих содержимое почтовых ящиков. Результаты таких тестирований можно использовать для планирования требований к производительности сервера Exchange. При создании новой среды сервера Exchange можно также создать расписание, по которому группы клиентских компьютеров будут выполнять индексирование содержимого, чтобы сбалансировать нагрузку на сервер Exchange.
  • Отслеживайте использование памяти на сервере. Дополнительные сведения см. на веб-узле корпорации Майкрософт по адресу:
    http://www.microsoft.com/technet/prodtechnol/exchange/guides/TrblshtE2k3Perf/7a44b064-8872-4edf-aac7-36b2a17f662a.mspx
  • Следите за фрагментацией виртуальной памяти на сервере.
  • Следите, не появляются ли на сервере сообщения о событии с кодом 9646. Сообщения о событии с кодом 9646 регистрируются в журнале, когда поисковая программа на клиентском компьютере открывает слишком много объектов на сервере. Дополнительные сведения о сообщении о событии с кодом 9646 см. в следующей статье базы знаний Майкрософт:
    830829 Компьютер под управлением Exchange Server 2003 может перестать отвечать после того, как MAPI-клиент открывает больше серверных объектов, чем установлено по умолчанию

Способ 3. Запретите пользователям запускать программы поиска на рабочем столе

Можно применить политику ограничения использования программ на клиентских компьютерах во избежание использования программ поиска на рабочем столе.

Способ 4. Используйте индексацию содержимого в Exchange

Попробуйте включить функцию индексации содержимого в Exchange. В некоторых случаях, если включена функция индексации содержимого в Exchange, результаты поиска могут быть получены быстрее, если поиск выполняется по содержимому почтового ящика, чем при использовании программы поиска на рабочем столе на клиентском компьютере.

Ссылки

Дополнительные сведения об устранении проблем с производительностью см. в руководстве «Troubleshooting Exchange Server 2003 Performance». Для просмотра этого руководства обратитесь на следующий веб-узел Майкрософт:
http://www.microsoft.com/technet/prodtechnol/exchange/2003/library/e2k3perf.mspx

Свойства

Код статьи: 905184 - Последний отзыв: 26 ноября 2007 г. - Revision: 2.5
Информация в данной статье относится к следующим продуктам.
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Office Outlook 2003
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft Outlook 98 Standard Edition
  • Microsoft Outlook 97 Standard Edition
Ключевые слова: 
kbexchtechbulletin KB905184

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com