Article ID: 905205 - Last Review: October 11, 2007 - Revision: 3.5

You may receive a "STOP: 0x000000D1" error message, the computer may stop responding, and data may become corrupted after you install the hotfix that is described in Microsoft Knowledge Base article 835166 on a computer that is running Windows Server 2003

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SYMPTOMS

After you install the hotfix that is described in Microsoft Knowledge Base article 835166 on a computer that is running Microsoft Windows Server 2003 or on a computer that is running Windows 2000 Server, you may experience all the following symptoms:
  • You may receive the following error message:
    STOP: 0x000000D1
    .
  • The computer may stop responding (hang).
  • Data on the hard disk may become corrupted.

CAUSE

This problem occurs because of a problem in the SCSIPORT driver. This problem causes data to be written to incorrect addresses in the memory or to be read from incorrect addresses in the memory.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003

Hotfix information

Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart requirement
You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions
Date         Time   Version            Size    File name     Service Pack
--------------------------------------------------------------------------
14-Sep-2005  00:01  5.2.3790.409      127,488  Scsiport.sys    
14-Sep-2005  01:04  5.2.3790.2529     104,960  Scsiport.sys  SP1
14-Sep-2005  00:37  5.2.3790.2529      32,256  Arpidfix.exe  SP1

Windows Server 2003, x64-based versions
Date         Time   Version            Size    File name
-----------------------------------------------------------
13-Sep-2005  13:48  5.2.3790.2529     170,496  Scsiport.sys
13-Sep-2005  13:48  5.2.3790.2529      43,008  Arpidfix.exe   

Windows Server 2003, Itanium-based versions
Date         Time   Version            Size    File name      Service Pack
--------------------------------------------------------------------------
13-Sep-2005  13:48  5.2.3790.409      292,352  Scsiport.sys  
13-Sep-2005  13:48  5.2.3790.2529     317,440  Scsiport.sys   SP1 
13-Sep-2005  13:48  5.2.3790.2529      74,752  Arpidfix.exe   SP1 

Windows 2000 Server

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows 2000 Server
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Scsiport.sys5.0.2195.707074,38419-Sep-200513:46x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003 Service Pack 1, when used with:
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows 2000 Server
Keywords: 
kbautohotfix kbwinserv2003sp2fix kbqfe kbhotfixserver kbwinserv2003sp1fix kbbug kbfix kbwinserv2003presp1fix kbpubtypekc KB905205
 

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