Artigo: 905539 - Última revisão: segunda-feira, 3 de Dezembro de 2007 - Revisão: 2.7

Poderá receber uma mensagem de erro "Stop 0 x 00000020" num computador com o Windows Small Business Server 2003 ou Windows Server 2003

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

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Sintomas

Num computador com o Microsoft Windows Small Business Server 2003 ou Microsoft Windows Server 2003, poderá detectar qualquer um dos seguintes sintomas:
  • O computador é reiniciado automaticamente.
  • Depois de iniciar sessão, receberá a seguinte mensagem de erro:
    Microsoft Windows
    O sistema recuperou de um erro grave.
    Foi criado um registo deste erro.
    Informe A Microsoft sobre este problema.
    Criámos um relatório de erros que pode enviar para ajudar-na melhorar o Microsoft Windows. A Microsoft irá tratar este relatório confidencial e anónimo.
    Para ver os dados que contém este relatório de erros, clique aqui.
    Se clicar na hiperligação clique aqui na parte inferior da caixa da mensagem, receberá um erro Stop semelhante dos exemplos seguintes dados:

    Exemplo de dados 1

    BCCode: 00000020 BCP1: 0x00000000 BCP2: 0x0000ffff BCP3: 0x00000000 
    BCP4: 0x00000001 OSVer: 5_1_2600 SP : 0_0 Product: 256_1

    Exemplo de dados 2

    BCCode: 00000020 BCP1: 0x00000000 BCP2: 0x0000fffe BCP3: 0x00000000 
    BCP4: 0x00000001 OSVer: 5_1_2600 SP: 0_0 Product	: 256_1
  • Recebe as mensagens de erro Stop seguintes:

    Mensagem 1

    Foi detectado um problema e o Windows foi encerrado para evitar danificar ao computador...
    Informações técnicas:

    *** STOP: 0 x 00000020 (0 x 0 x 00000000, 0x0x0000ffff, 0 x 0 x 00000000, 0 x 0 x 00000001)
    KERNEL_APC_PENDING_DURING_EXIT

    Mensagem 2

    Foi detectado um problema e o Windows foi encerrado para evitar danificar ao computador...
    Informações técnicas:

    *** STOP: 0 x 00000020 (0 x 0 x 00000000, 0x0x0000fffe, 0 x 0 x 00000000, 0 x 0 x 00000001)
    KERNEL_APC_PENDING_DURING_EXIT
  • Um erro semelhante à seguinte é registado no registo de eventos do sistema:
    Data: date
    Origem: sistema
    Hora do erro: time
    Categoria: (102 teclas)
    Tipo: erro
    ID do evento: 1003
    Utilizador: N/d
    Computador: COMPUTER
    Descrição: Código de erro 00000020, parâmetro1 0 x 00000000, parâmetro2 0x0000ffff, parâmetro3 0 x 00000000, parâmetro4 0 x 00000001. Para mais informações, consulte o Centro de ajuda e suporte em http://support.microsoft.com. Dados: 0000: 53 79 73 74 65 d 6 20 45 sistema E 0008: 72 72 6f 20 72 45 20 72 rror ER 0010: 72 6f 20 72 63 6f 64 65 ror código 0018: 20 30 30 30 30 30 30 35 0000020 0020: 30 20 50 20 72 61 61 6 d 0 Param 0028: 65 74 65 72 73 20 66 66 eters ff 0030: 66 66 66 66 64 31 2c

Notas

  • Erros Stop podem ocorrer intermitentemente, desde que o servidor está a ser utilizado. Erros fatais também poderão ocorrer durante o arranque. Se ocorrer um erro fatal durante o arranque, é possível iniciar normalmente o servidor no modo de segurança. No entanto, se desactivar todos os itens de arranque e serviços de terceiros utilizando o utilitário de configuração do sistema (Msconfig.exe), o erro ocorre ainda quando tenta iniciar o servidor como faria normalmente.
  • Os sintomas de um erro Stop variam de acordo com opções de falha do sistema do computador. Para obter mais informações sobre como configurar opções de falha de sistema, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    307973  (http://support.microsoft.com/kb/307973/ ) Como configurar técnicas de recuperação no Windows
  • Os quatro parâmetros dentro dos parênteses de um erro fatal variam de acordo com a configuração do computador.
  • Erros de nem todos os "Stop 0 x 00000020" são causados pelo problema descrito neste artigo.

Causa

Este problema costuma ocorrer em servidores com o Symantec pcAnywhere 11.5 com o Symantec AntiVirus 8.x ou com o Symantec AntiVirus 9.0. Uma versão actualizada do controlador de processador de eventos do Symantec (symevent.sys) faz com que este problema. O controlador symevent.sys é instalado com pcAnywhere 11.5. O controlador symevent.sys faz com que os controladores de protecção em tempo real do Symantec gerar o erro "Stop 0 x 00000020".

Resolução

Para resolver este problema, transfira e instale o controlador symevent.sys mais recente. Para mais informações, visite os seguintes Web sites da Symantec:
Error: "STOP 0x00000020 KERNEL_APC_PENDING_DURING_EXIT" on Windows 2003 (Document ID:2005030816000512) (http://service1.symantec.com/SUPPORT/pca.nsf/8d67bc594d5802c288256d2e006abd37/ed81a9e1b83b02f388256fbe0083c1ac?OpenDocument&src=bar_sch_nam)
Updating the Symevent files (Document ID:1998092408260848) (http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/1998092408260848?Open&src=bar_sch_nam&docid=2005011413594848&nsf=ent-security.nsf&view=d04e6f2f2dfad5de88256c910079502c&dtype=&prod=&ver=&osv=&osv_lvl=)
Microsoft fornece informações de contactos outros fabricantes para ajudar a encontrar suporte técnico. Poderá ser alterado estas informações de contacto sem aviso prévio. Microsoft não garante a precisão destas informações de contacto outros fabricantes.

Como contornar

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar uma cópia de segurança e restaurar o registo no Windows

Para contornar este problema, desactive o Symantec controladores de protecção em tempo real. Se não conseguir iniciar o servidor como faria normalmente, iniciar o servidor no modo de segurança e, em seguida, desactive temporariamente os controladores de protecção em tempo real.

Nota Siga estes passos apenas se o servidor não for iniciado tal como acontece normalmente. Depois de desactivar os controladores de protecção em tempo real e iniciar o servidor como faria normalmente, recomendamos que instale imediatamente o controlador symevent.sys actualizado. Em seguida, reactive os controladores de protecção em tempo real.

Para desactivar os controladores de protecção em tempo real, utilize os passos adequados para a versão do Symantec AntiVirus que esteja a executar.

atenção O servidor estar vulnerável a vírus e outro software malicioso, desde que os controladores de protecção em tempo real são desactivados. Por conseguinte, recomendamos que desligar o servidor da rede até que os controladores reactivados.

Para desactivar os controladores de protecção em tempo real do Symantec AntiVirus 8.x, siga estes passos:
  1. Clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
  3. Clique na chave Navap .
  4. No painel de para a direita, faça duplo clique na entrada Iniciar .
  5. Na caixa dados do valor , altere o valor para 4 e, em seguida, clique em OK .
  6. Chave Services , clique na chave Navapel .
  7. No painel de para a direita, faça duplo clique Iniciar entrada.
  8. Na caixa dados do valor , altere o valor para 4 e, em seguida, clique em OK .
  9. Saia do Editor de registo.
  10. Desligar o servidor da rede.
  11. Reinicie o servidor.
Para desactivar os controladores de protecção em tempo real do Symantec AntiVirus 9.0, siga estes passos:
  1. Clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
  3. Clique na chave Savrt .
  4. No painel de para a direita, faça duplo clique na entrada Iniciar .
  5. Na caixa dados do valor , altere o valor para 4 e, em seguida, clique em OK .
  6. Chave Services , clique em Savrtpel .
  7. No painel de para a direita, faça duplo clique Iniciar entrada.
  8. Na caixa dados do valor , altere o valor para 4 e, em seguida, clique em OK .
  9. Saia do Editor de registo.
  10. Desligar o servidor da rede.
  11. Reinicie o servidor.
Para obter informações sobre como reactivar controladores de protecção em tempo real do Symantec AntiVirus, contacte a Symantec.

Os produtos de outros fabricantes explicado neste artigo são fabricados por empresas independentes da Microsoft. A Microsoft não oferece nenhuma garantia, expressa ou implícita, relativamente ao desempenho ou fiabilidade destes produtos.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Web Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Palavras-chave: 
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