ID do artigo: 905539 - Última revisão: segunda-feira, 3 de dezembro de 2007 - Revisão: 2.7

Você pode receber uma mensagem de erro "Stop 0 x 00000020" em um computador que esteja executando o Windows Small Business Server 2003 ou Windows Server 2003

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

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Sintomas

Em um computador que esteja executando o Microsoft Windows Small Business Server 2003 ou Microsoft Windows Server 2003, você pode enfrentar qualquer um dos seguintes sintomas:
  • O computador reinicia automaticamente.
  • Depois de fazer logon, você receber a seguinte mensagem de erro:
    Microsoft Windows
    O sistema se recuperou de um erro grave.
    Foi criado um log deste erro.
    Informe a Microsoft sobre este problema.
    Nós criamos um relatório de erro que você pode enviar para nos ajudar a melhorar Microsoft Windows. Esse relatório será considerado confidencial e anônimo.
    Para ver quais dados esse relatório de erros contém, clique aqui.
    Se você clicar no link Clique aqui na parte inferior da caixa de mensagem, você pode receber um erro de interrupção é semelhante a um dos exemplos de dados:

    Exemplo de dados 1

    BCCode: 00000020 BCP1: 0x00000000 BCP2: 0x0000ffff BCP3: 0x00000000 
    BCP4: 0x00000001 OSVer: 5_1_2600 SP : 0_0 Product: 256_1

    Exemplo de dados 2

    BCCode: 00000020 BCP1: 0x00000000 BCP2: 0x0000fffe BCP3: 0x00000000 
    BCP4: 0x00000001 OSVer: 5_1_2600 SP: 0_0 Product	: 256_1
  • Você recebe as seguintes mensagens de erro Stop:

    Mensagem 1

    Foi detectado um problema e o Windows foi desligado para evitar danos ao seu computador...
    Informações técnicas:

    *** STOP: 0 x 00000020 (0 x 0 x 00000000, 0x0x0000ffff, 0 x 0 x 00000000, 0 x 0 x 00000001)
    KERNEL_APC_PENDING_DURING_EXIT

    Mensagem 2

    Foi detectado um problema e o Windows foi desligado para evitar danos ao seu computador...
    Informações técnicas:

    *** STOP: 0 x 00000020 (0 x 0 x 00000000, 0x0x0000fffe, 0 x 0 x 00000000, 0 x 0 x 00000001)
    KERNEL_APC_PENDING_DURING_EXIT
  • Um erro semelhante à seguinte é registrado no log de eventos do sistema:
    Data: date
    Fonte: sistema
    Hora do erro: time
    Categoria: (102)
    Tipo: erro
    IDENTIFICAÇÃO de evento: 1003
    Usuário: N/d
    Computador: COMPUTER
    Descrição: Código de erro 00000020, parâmetro1 0 x 00000000, parâmetro2 0x0000ffff, parâmetro3 0 x 00000000, parâmetro4 0 x 00000001. Para obter mais informações, consulte o Centro de Ajuda e suporte em http://support.microsoft.com. Dados: 0000: 53 79 73 74 65 d 6 20 45 sistema E 0008: 72 72 6f 72 20 45 20 72 rror ER 0010: 72 6f 20 72 63 6f 64 65 ror código 0018: 20 30 30 30 30 30 30 35 0000020 0020: 30 20 50 20 72 61 61 6 d 0 parâmetros 0028: 65 74 65 72 73 20 66 66 parâmetros ff 0030: 66 66 66 66 64 31 2C

Anotações

  • Os erros de parada podem ocorrer intermitentemente, desde que o servidor está sendo usado. Os erros de parada também podem ocorrer durante a inicialização. Se ocorrer um erro de parada durante a inicialização, você normalmente pode iniciar o servidor no modo de segurança. No entanto, se você desabilitar todos os itens de inicialização e os serviços de terceiros usando o utilitário de configuração do sistema (Msconfig.exe), o erro ainda ocorre ao tentar iniciar o servidor como faria normalmente.
  • Os sintomas de um erro Stop variam de acordo com opções de falha do sistema do seu computador. Para obter mais informações sobre como configurar as opções de falha do sistema, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    307973  (http://support.microsoft.com/kb/307973/ ) Como configurar opções de falha e recuperação do sistema no Windows
  • Os quatro parâmetros dentro dos parênteses de um erro Stop variam de acordo com a configuração do computador.
  • Nem todos os "Stop 0 x 00000020" erros são causados pelo problema descrito neste artigo.

Causa

Esse problema é conhecido por ocorrer em servidores que executam Symantec pcAnywhere 11,5 com 8.x Symantec AntiVirus ou com Symantec antivírus 9.0. Uma versão atualizada do manipulador de eventos do Symantec driver (symevent.sys) faz com que esse problema. O driver symevent.sys é instalado com o pcAnywhere 11,5. O driver symevent.sys faz com que os drivers de proteção em tempo real do Symantec gerar o erro "Stop 0 x 00000020".

Resolução

Para resolver esse problema, baixe e instale o driver symevent.sys mais recente. Para obter mais informações, visite os seguintes sites da Symantec:
Error: "STOP 0x00000020 KERNEL_APC_PENDING_DURING_EXIT" on Windows 2003 (Document ID:2005030816000512) (http://service1.symantec.com/SUPPORT/pca.nsf/8d67bc594d5802c288256d2e006abd37/ed81a9e1b83b02f388256fbe0083c1ac?OpenDocument&src=bar_sch_nam)
Updating the Symevent files (Document ID:1998092408260848) (http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/1998092408260848?Open&src=bar_sch_nam&docid=2005011413594848&nsf=ent-security.nsf&view=d04e6f2f2dfad5de88256c910079502c&dtype=&prod=&ver=&osv=&osv_lvl=)
A Microsoft fornece terceiros informações de contatos para ajudá-lo a encontrar suporte técnico. Essa informações de contatos podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações contatos de terceiros.

Como Contornar

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows

Para contornar este problema, desative o Symantec drivers de proteção em tempo real. Se você não pode iniciar o servidor como faria normalmente, iniciar o servidor no modo de segurança e desative temporariamente os drivers de proteção em tempo real.

Observação Siga estas etapas somente se o servidor não for iniciado como faz normalmente. Depois de desativar os drivers de proteção em tempo real e iniciar o servidor como faria normalmente, é recomendável que você instale imediatamente o driver symevent.sys atualizado. Em seguida, reative os drivers de proteção em tempo real.

Para desativar os drivers de proteção em tempo real, use as etapas apropriadas para a versão do Symantec AntiVirus que está executando.

cuidado O servidor ficará vulnerável a vírus e outros softwares mal-intencionados, desde que os drivers de proteção em tempo real são desativados. Portanto, é recomendável desconectar o servidor da rede até que os drivers são reativados.

Para desativar os drivers de proteção em tempo real do Symantec AntiVirus 8.x, execute estas etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
  3. Clique na chave Navap .
  4. No painel de direito, clique duas vezes na entrada Iniciar .
  5. Na caixa dados do valor , altere o valor para 4 e, em seguida, clique em OK .
  6. Sob a chave serviços , clique na chave Navapel .
  7. No painel direito, clique duas vezes em Iniciar entrada.
  8. Na caixa dados do valor , altere o valor para 4 e, em seguida, clique em OK .
  9. Feche o Editor do Registro.
  10. Desconectar-se o servidor da rede.
  11. Reinicie o servidor.
Para desativar os drivers de proteção em tempo real do Symantec antivírus 9.0, execute estas etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
  3. Clique na chave Savrt .
  4. No painel de direito, clique duas vezes na entrada Iniciar .
  5. Na caixa dados do valor , altere o valor para 4 e, em seguida, clique em OK .
  6. Sob a chave serviços , clique em Savrtpel .
  7. No painel direito, clique duas vezes em Iniciar entrada.
  8. Na caixa dados do valor , altere o valor para 4 e, em seguida, clique em OK .
  9. Feche o Editor do Registro.
  10. Desconectar-se o servidor da rede.
  11. Reinicie o servidor.
Para obter informações sobre como reativar drivers de proteção em tempo real do Symantec AntiVirus, entre em contato com Symantec.

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A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
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