Description of some of the differences between Excel 2004 for Mac and Excel 2003

Article translations Article translations
Article ID: 905677 - View products that this article applies to.
Expand all | Collapse all

On This Page

SUMMARY

Microsoft Excel 2004 for Mac and Microsoft Office Excel 2003 are similar in many ways. For example, the programs share a common file format and share most of the same features. However, there are some important differences that you should consider when you work with both Excel 2004 for Mac and Excel 2003.


INTRODUCTION

This article contains general information about the difference between Excel 2004 for Mac and Excel 2003.

MORE INFORMATION

ActiveX controls

Excel 2004 for Mac does not support the use of ActiveX controls, also known as OCX files or OCXs. You cannot insert or use ActiveX controls in worksheets, in custom dialog boxes, or in custom UserForms.

Because ActiveX controls are not supported in Excel 2004 for Mac, the Control Toolbox toolbar is not available in Excel 2004 for Mac workbooks. Although the Toolbox in the Microsoft Visual Basic Editor is available, you cannot add ActiveX controls to the Toolbox in the Microsoft Visual Basic Editor.

If you use Excel 2004 for Mac to open an Excel 2003 workbook that contains one or more ActiveX controls, one of the following problems may occur:
  • Each control appears as a red "X."
  • You receive one or more "Graphics Filter Converting" messages.
When the controls appear, they do not work when you click them. Additionally, you cannot delete the controls. If you copy and paste a control or if you run a Microsoft Visual Basic for Applications (VBA) macro, you receive one of the following error messages:
The application "unknown" has unexpectedly quit, because an error of type 3 occurred.
Run-time error '57121': Can't exit design mode because Control 'CheckBox1' can not be created.
Run-time error '32809': Application-defined or object-defined error.
Run-time error '1004': Cannot start the source application for this object. There may not be enough memory available.
If you modify an Excel 2003 workbook that contains ActiveX controls, save the workbook, and then reopen the workbook in Excel 2003, the ActiveX controls work correctly. However, the ActiveX controls do not work correctly if you open the workbook in Excel 2004 for Mac. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
274222 Error when you paste ActiveX controls or run a macro in Excel for Mac

The 1904 date system and the 1900 date system

The default date system in Excel 2004 for Mac is the 1904 date system. The default date system in Excel 2003 is the 1900 date system. Typically, the use of different date systems does not cause a problem.

However, if you transfer a workbook from Excel 2003 to Excel 2004 for Mac, or vice versa, and then copy a date from one workbook to the other, the date may increase or decrease by four years and one day. This issue occurs if the two workbooks use different date systems.

For example, if you copy the date 1/1/1998 from a workbook that uses the 1900 date system and then paste the date into a workbook that uses the 1904 date system, the date appears as 1/2/2002. Alternatively, if you copy the date 1/1/1998 from a workbook that uses the 1904 date system and then paste the date into a workbook that uses the 1900 date system, the date appears as 12/31/1993.

As long as you know about the date systems that your workbooks use, the different date systems should not cause a problem. For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
214330 Description of the differences between the 1900 date system and the 1904 date system in Excel
274238 Date returned in a macro is four years too early
274277 Chart axis may be four years early after you format scale in Excel for Mac

The Quattro Pro file format

Excel 2004 for Mac does not support the Quattro Pro file format. If you try to open a file that is saved in any Quattro Pro file format (WQ1, WQ2, WB1, or WB2), you receive the following error message:
This file is not in a recognizable format.
If you must open a Quattro Pro file in Excel 2004 for Mac, use one of the following methods:
  • Open the file in Quattro Pro. Then, save the file in the Lotus 1-2-3 file format (WK4, WK3, WK1, or WKS). You can open the Lotus 1-2-3 file in Excel 2004 for Mac.
  • Open the Quattro Pro DOS (*.wq1) file in Excel 2003. Then, save the file as a Microsoft Excel workbook. You can open the Excel workbook in Excel 2004 for Mac.

    Note Only Quattro Pro DOS (*.wq1) is supported in Excel 2003.
Because Excel 2004 for Mac cannot save files in the Quattro Pro file format, save the files in a different file format. Then, use another program, such as Excel 2003, to convert the files to the Quattro Pro file format.

Visual Basic Editor

The Visual Basic for Applications editing environment (the Visual Basic Editor) in Excel 2004 for Mac is similar to the Visual Basic Editor in Excel 2003. However, consider the following differences in the Visual Basic Editor in Excel 2004 for Mac:
  • The Locals Window and Watch Window menu commands are not available on the View menu. You cannot display these menu commands in the Visual Basic Editor.
  • You cannot customize any one of the toolbars (Standard, Edit, or Debug toolbar) or the menu bar in the Visual Basic Editor.
  • You cannot customize the Toolbox toolbar that contains the controls that are used in UserForms.
  • You cannot export a Visual Basic module or a UserForm. If you want to export a module or a UserForm, use Excel 2003 to open the workbook that contains the module or the UserForm. Then, export the module or the UserForm.
  • List box controls and combo box controls do not have the ControlSource and RowSource properties. Therefore, these controls cannot be linked to cells in a worksheet.

ADO, DAO, and ODBCDirect

ActiveX Data Objects (ADO), Data Access Objects (DAO), and ODBCDirect are not available in Excel 2004 for Mac. Therefore, you cannot run VBA macros that use ADO, DAO, or ODBCDirect to import external data into Excel. However, you can run macros that use standard Open Database Connectivity (ODBC) to import external data.

Embedded objects

In Excel 2003, if you insert a document from another program into an Excel worksheet, you can modify the embedded document by double-clicking it. When you do this, the document is edited in place. That is, you continue to work in Excel 2003, but the menus and the toolbars change to those of the other program so that you can modify the embedded document.

In-place editing is not available in Excel 2004 for Mac. If you double-click a document that is inserted in an Excel worksheet, the program for the embedded document starts separately. Then, you can modify the document in the other program. After you modify the document, you close the other program and then return to Excel 2004 for Mac.

Templates

If you want to modify a template in Excel 2003, you just open and then modify template. Any changes that you make to the template are saved when you save the template.

If you want to modify a template in Excel 2004 for Mac, you must hold down the SHIFT key when you open the template. After the template is open, release the SHIFT key. Then, you can modify and then save the template.

Menu bars

The steps to modify the Worksheet or Chart menu bar are slightly different in Excel 2004 for Mac than in Excel 2003. To modify the Worksheet or Chart menu bar in Excel for Mac 2004, follow these steps:
  1. On the Tools menu, point to Customize, and then click Customize Toolbars/Menus.
  2. If you want to modify the Worksheet menu bar, click to select the Worksheet Menu Bar check box. If you want to modify the Chart menu bar, click to select the Chart Menu Bar check box.

    Note You can modify menus, menu commands, and submenus on the two menu bars. You cannot modify the menu bar at the top of the screen.
  3. When you are finished, click OK.
When you click OK, the two menu bars disappear from the screen. However, any changes that you made to menus, menu commands, or submenus appear on the menu bar at the top of the screen.

Menu icons

In Excel 2004 for Mac, icons do not appear to the left of menu commands even though the icons appear when you customize menus, menu commands, and submenus. This behavior is by design.

REFERENCES

For the latest Microsoft Knowledge Base articles and other support information about Excel 2004 for Mac, visit the following Microsoft Web site:
http://support.microsoft.com/ph/2513/

Properties

Article ID: 905677 - Last Review: October 6, 2011 - Revision: 4.0
APPLIES TO
  • Microsoft Excel 2004 for Mac
Keywords: 
KB905677

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com