Se le pide inesperadamente que reinicie el equipo después de instalar un Service Pack o una actualización de Office

Seleccione idioma Seleccione idioma
Id. de artículo: 905726 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Después de instalar un Service Pack de Microsoft Office o una actualización de Office, se le pide inesperadamente que reinicie el equipo.

Causa

Este problema puede producirse si el Service Pack o la actualización debe modificar un archivo que está siendo utilizado actualmente. El archivo puede estar en uso por un programa que se está ejecutando cuando instala el Service Pack o la actualización. A veces, el programa que está utilizando el archivo no es un programa de Office.

Este problema puede producirse cuando se cumple una o varias de las condiciones siguientes:
  • Un dispositivo que se sincroniza con Microsoft Outlook está acoplado al equipo cliente. Además, se está ejecutando ActiveSync.
  • Se está ejecutando un programa de Office.
  • Microsoft Office Communicator 2005 o Microsoft Office Communicator 2007 está en ejecución.
Nota: esta lista no es completa. Puede haber otros programas instalados que sean la causa de este problema.

Solución

Antes de instalar el Service Pack o la actualización, cierre cualquier programa o servicio que se esté ejecutando y que pueda interferir en la instalación del Service Pack o de la actualización.

Los métodos siguientes proporcionan información acerca de cómo cerrar algunos de los programas y servicios más frecuentes que pueden causar este problema. Utilice los métodos siguientes según su situación.

Cómo cerrar ActiveSync

Para salir de ActiveSync, termine el proceso Wcescomm.exe. Para terminar el proceso Wcescomm.exe, vea la sección "Cómo terminar un proceso para un programa que se está ejecutando en segundo plano".

Nota: un usuario o un dispositivo que está conectado al servicio se desconectará cuando termine el proceso.

Cómo salir de un programa de Office

Para salir de un programa de Offcie, haga clic en Salir en el menú Archivo. Si el programa de Office no es visible en la pantalla, presione Alt+Tab para cambiar al programa. O bien, haga clic en el botón de la barra de tareas del programa de Office.

Nota: un proceso de un programa de Office puede seguir ejecutándose en segundo plano si un problema hace que el programa se cierre de forma anormal. Si sospecha que un proceso de un programa de Office se está ejecutando en segundo plano, termine el proceso. Para ello, vea la sección "Cómo terminar un proceso para un programa que se está ejecutando en segundo plano".

Cómo cerrar Communicator 2005 o Communicator 2007

Para cerrar Communicator 2005 o Communicator 2007, cierre la sesión de Communicator, cierre el programa y salga de él. Para ello, siga estos pasos:
  1. En el menú Conectar, haga clic en Cerrar sesión.
  2. En el menú Conectar, haga clic en Cerrar.

    Nota: cuando cierra Communicator 2005 o Communicator 2007, el programa se minimiza en el área de notificación.
  3. Haga clic con el botón secundario en el icono de Communicator 2005 o Communicator 2007 del área de notificación y, después, haga clic en Salir.

Cómo terminar un proceso para un programa que se está ejecutando en segundo plano

Importante: la terminación de un proceso puede producir resultados no deseados. Ello incluye la inestabilidad del sistema y pérdida de datos. Cuando termina un proceso, no se le ofrece la posibilidad de guardar su estado u otros datos antes de que el proceso termine.

Para terminar un proceso de un programa que se está ejecutando en segundo plano, use uno de los métodos siguientes.

Método 1: utilizar el Administrador de tareas

Para utilizar el Administrador de tareas con el fin de terminar un proceso, siga estos pasos:
  1. Presione Ctrl+Alt+Supr.
  2. En la ficha Procesos, haga clic en nombreArchivoProceso y, a continuación, haga clic en Terminar proceso.

    Nota: en este método, nombreArchivoProceso representa el nombre de archivo del proceso que desea terminar.

Método 2: utilizar el comando Taskkill

Para utilizar el comando Taskkill con el fin de terminar un proceso, siga estos pasos:
  1. Haga clic en Inicio y en Ejecutar, escriba cmd y haga clic en Aceptar.
  2. En el símbolo del sistema, escriba taskkill /im nombreArchivoProceso y presione Entrar.

    Notas
    • En este método, nombreArchivoProceso representa el nombre de archivo del proceso que desea terminar.
    • Para obtener más información acerca del comando Taskkill, escriba taskkill /? en el símbolo del sistema y presione Entrar.
  3. En el símbolo del sistema, escriba exit para cerrar la ventana del símbolo del sistema.

Cómo impedir que el equipo se reinicie inesperadamente cuando implementa un Service Pack o una actualización de Office

Si es un administrador que está implementando un Service Pack o una actualización de Office, puede usar una secuencia de comandos para cerrar programas o servicios que puedan interferir en la instalación del Service Pack o la actualización.

Microsoft proporciona ejemplos de programación solamente como ilustración, sin ninguna garantía ya sea expresa o implícita. Esto incluye, entre otras, las garantías implícitas de comerciabilidad e idoneidad para un fin determinado. En este artículo se da por supuesto que ya conoce el lenguaje de programación que se muestra, así como las herramientas empleadas para crear y depurar procedimientos. Los ingenieros de soporte técnico de Microsoft pueden ayudar a explicar la funcionalidad de un procedimiento en particular. Sin embargo, no modificarán estos ejemplos para proporcionar una funcionalidad adicional ni crearán procedimientos que cumplan sus requisitos específicos.

Para usar una secuencia de comandos con el fin de cerrar programas o servicios, cree una secuencia de comandos similar a la siguiente.
; TechNet Sample 2005
; http://www.microsoft.com/technet/scriptcenter/resources/qanda/sept04/hey0927.mspx
; For more information about how to use scripts to manage processes, visit the following Microsoft Web site:
; http://www.microsoft.com/technet/scriptcenter/guide/sas_prc_overview.mspx

strComputer = "."
Set objWMIService = GetObject _
    ("winmgmts:\\" & strComputer & "\root\cimv2")
Set colProcessList = objWMIService.ExecQuery _
    ("Select * from Win32_Process Where Name = 'Communicator.exe'")
For Each objProcess in colProcessList
    objProcess.Terminate()
Next

Más información

Con frecuencia, la instalación de un Service Pack o una actualización de Office no requiere que reinicie el equipo. Sin embargo, hay situaciones en las que debe reiniciar el equipo.

Si debe reiniciar el equipo después de instalar un Service Pack o una actualización de Office, la información de reinicio se incluirá en la documentación que acompaña al Service Pack o la actualización de Office.

Propiedades

Id. de artículo: 905726 - Última revisión: jueves, 27 de diciembre de 2007 - Versión: 4.7
La información de este artículo se refiere a:
  • Microsoft Office Basic Edition 2003
  • Microsoft Office XP Developer Edition
  • Microsoft Office 2000 Developer Edition
  • Microsoft Office 2000 Premium Edition
  • Microsoft Office Professional Edition 2003
  • Microsoft Office 2000 Professional Edition
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office XP Small Business Edition
  • Microsoft Office 2000 Small Business Edition
  • Microsoft Office Standard Edition 2003
  • Microsoft Office XP Standard Edition
  • Microsoft Office 2000 Standard Edition
  • Microsoft Office Students and Teachers Edition 2003
  • Microsoft Office XP Students and Teachers
  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Office FrontPage 2003
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Office InfoPath 2003
  • Microsoft Office OneNote 2003
  • Microsoft Office Outlook 2003
  • Microsoft Outlook 2002 Standard
  • Microsoft Outlook 2000 Standard
  • Microsoft Office PowerPoint 2003
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Office Project Professional 2003
  • Microsoft Project 2002 Professional
  • Microsoft Office Project Standard 2003
  • Microsoft Project Standard 2002
  • Microsoft Project 2000 Standard
  • Microsoft Office Project Server 2003
  • Microsoft Project Server 2002
  • Microsoft Office Publisher 2003
  • Microsoft Publisher 2002 Standard
  • Microsoft Publisher 2000 Standard
  • Microsoft Office Visio Professional 2003
  • Microsoft Visio 2002 Professional Edition
  • Microsoft Visio 2000 Professional Edition
  • Microsoft Office Visio Standard 2003
  • Microsoft Visio 2002 Standard Edition
  • Microsoft Visio 2000 Standard Edition
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
Palabras clave: 
kbsetup kbtshoot kbprb KB905726

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com