При низкой скорости подключения к личной папке в Windows Server 2003 или Windows XP работа программы может сильно замедляться

Переводы статьи Переводы статьи
Код статьи: 905890 - Vizualiza?i produsele pentru care se aplic? acest articol.


Версия данной статьи для Microsoft Windows 2000:306850.
Развернуть все | Свернуть все

В этой статье

Проблема

При запуске программы в Microsoft Windows Server 2003 или Microsoft Windows XP она может работать очень медленно в следующих условиях.
  • Запускается программа, не имеющая свойства Start in.
  • Низкая скорость подключения к сетевому диску с домашней папкой.
Кроме того, процесс входа в систему может выполняться медленнее, чем ожидалось, в следующих условиях.
  • Клиентскому компьютеру приходится искать системные файлы DLL в домашней папке.
  • Низкая скорость подключения к сетевому диску с домашней папкой.
Для получения дополнительных сведений о другой возможной причине подобной проблемы щелкните следующий номер статьи базы знаний Майкрософт:
306850 При низкой скорости подключения к домашней папке программы могут запускаться медленно, или может замедляться процесс входа в систему (Эта ссылка может указывать на содержимое полностью или частично на английском языке)

Причина

Эта проблема возникает из-за того, что большие задержки снижают скорость работы программы. Программа, не имеющая свойства Start in, сначала выполняет поиск файлов DLL в текущей рабочей папке, а затем в папках, указанных в системном пути. Текущей рабочей папкой обычно является домашняя папка. Если домашняя папка находится на подключенном сетевом диске и сетевое подключение к этому диску имеет большие задержки, например глобальная сеть (WAN) или виртуальная частная сеть (VPN), производительность может снизиться.

Решение

Windows Server 2003

Сведения о пакете обновления

Чтобы решить эту проблему, установите последний пакет обновления для Windows Server 2003. Дополнительные сведения см. в следующей статье базы знаний Майкрософт:
889100 Получение последнего пакета обновления для Windows Server 2003

Предварительные условия

Предварительные условия
Для установки исправления не требуется соблюдения дополнительных условий.
Необходимость перезагрузки
После установки данного исправления компьютер необходимо перезагрузить.
Сведения о замене исправлений
Это исправление не заменяет другие исправления.
Сведения о файлах
Английская версия исправления содержит файлы с атрибутами, указанными в приведенной ниже таблице или более поздними. Дата и время для файлов указаны в формате UTC. При просмотре сведений о файлах выполняется перевод соответствующих значений в местное время. Чтобы узнать разницу между временем в формате UTC и местным временем, откройте вкладку Часовой пояс элемента "Дата и время" на панели управления.
Версии Windows Server 2003 для архитектуры x86
Свернуть эту таблицуРазвернуть эту таблицу
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Kernel32.dll5.2.3790.425989,18414-Oct-200504:20x86NoneRTMQFE
Termsrv.dll5.2.3790.425222,20814-Oct-200504:20x86NoneRTMQFE
Winsta.dll5.2.3790.42552,22414-Oct-200504:20x86NoneRTMQFE
Kernel32.dll5.2.3790.25481,038,33614-Oct-200505:29x86SP1SP1QFE

Версии Windows Server 2003 для платформы Itanium
Свернуть эту таблицуРазвернуть эту таблицу
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Kernel32.dll5.2.3790.4251,851,90414-Oct-200507:18IA-64NoneRTMQFE
Termsrv.dll5.2.3790.425621,56814-Oct-200507:18IA-64NoneRTMQFE
Winsta.dll5.2.3790.425141,82414-Oct-200507:18IA-64NoneRTMQFE
Wkernel32.dll5.2.3790.425935,42414-Oct-200507:18x86NoneWOW
Wwinsta.dll5.2.3790.42552,22414-Oct-200507:18x86NoneWOW
Kernel32.dll5.2.3790.25481,966,08014-Oct-200507:18IA-64SP1SP1QFE
Wkernel32.dll5.2.3790.25481,007,61614-Oct-200507:18x86SP1WOW

Windows Server 2003, 64-разрядные версии
Свернуть эту таблицуРазвернуть эту таблицу
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Kernel32.dll5.2.3790.25481,500,16014-Oct-200507:18x64SP1SP1QFE
Wkernel32.dll5.2.3790.25481,007,61614-Oct-200507:18x86SP1WOW

Windows XP

Сведения об исправлении

Корпорация Майкрософт выпустила исправление, однако оно предназначено исключительно для устранения проблемы, описанной в этой статье. Это исправление необходимо применять только в тех системах, в которых наблюдается данная проблема. Исправление может проходить дополнительное тестирование. По этой причине корпорация Майкрософт рекомендует во всех случаях, когда проблема не представляет особой важности, отложить ее решение до выхода ближайшего пакета обновления, содержащего это исправление.

Если исправление доступно для загрузки, в начале статьи базы знаний имеется раздел "Исправление доступно для загрузки". Если этого раздела нет, отправьте запрос на получение исправления в службу поддержки клиентов корпорации Майкрософт.

Примечание. Если возникли другие проблемы или необходимо устранить неполадки, возможно, потребуется создать отдельный запрос. Дополнительные услуги технической поддержки, не связанные с данным исправлением, оплачиваются на стандартных условиях. Чтобы просмотреть полный список телефонных номеров службы поддержки пользователей Майкрософт или создать отдельный запрос, посетите веб-сайт корпорации Майкрософт по адресу:
http://support.microsoft.com/contactus/?ws=support
Примечание. В форме "Исправление доступно для загрузки" отображаются языки, для которых доступно исправление. Если нужный язык не отображается, это означает, что исправление для данного языка отсутствует.
Необходимые условия
Данное исправление предназначено для установки на компьютерах под управлением Windows XP с пакетом обновления 1 (SP1).
Необходимость перезагрузки
После установки исправления компьютер необходимо перезагрузить.
Сведения о замене исправлений
Это исправление не заменяет другие исправления.
Сведения о файлах
Английская версия исправления содержит файлы с атрибутами, указанными в приведенной ниже таблице или более поздними. Дата и время для файлов указаны в формате UTC. При просмотре сведений о файлах выполняется перевод соответствующих значений в местное время. Чтобы узнать разницу между временем в формате UTC и местным временем, откройте вкладку Часовой пояс элемента "Дата и время" на панели управления.
Свернуть эту таблицуРазвернуть эту таблицу
File nameFile versionFile sizeDateTimePlatform
Kernel32.dll5.1.2600.2737984,06412-Aug-200510:45x86
Arpidfix.exe5.1.2600.273730,72012-Aug-200502:26x86

Windows XP, версии на базе x86 с пакетом обновления 1 (SP1)
Свернуть эту таблицуРазвернуть эту таблицу
File nameFile versionFile sizeDateTimePlatform
Kernel32.dll5.1.2600.1784927,74417-Dec-200503:18x86

Windows XP, версии на базе x86 с пакетом обновления 2 (SP2)
Свернуть эту таблицуРазвернуть эту таблицу
File nameFile versionFile sizeDateTimePlatform
Kernel32.dll5.1.2600.2813984,57617-Dec-200503:23x86

Временное решение

Для решения проблемы необходимо изменить свойство Start in ярлыка программы на папку на локальном диске или компьютер, доступный по подключению с небольшими задержками.

Статус

Данное поведение является подтвержденной ошибкой продуктов Майкрософт, перечисленных в разделе "Информация в данной статье применима к". Первое исправление этой проблемы появилось в пакете обновления 2 (SP2) для Windows Server 2003.

Дополнительная информация

После установки исправления необходимо настроить реестр вручную, чтобы включить поиск приоритетного пути:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\SafeProcessSearchMode
Если для данной записи реестра установлено значение "1", компьютер сначала ищет папки, указанные в системном пути, а затем ищет текущую рабочую папку. Если для данной записи реестра установлено значение "0", компьютер сначала ищет текущую рабочую папку, а затем папки, указанные в системном пути. Для получения дополнительных сведений щелкните следующий номер статьи базы знаний Майкрософт:
824684 Стандартные термины, используемые при описании обновлений программных продуктов Майкрософт

Техническая поддержка 64-разрядных операционных систем Windows

Поскольку 64-разрядная операционная система Windows поставляется в составе приобретенного оборудования, то обязанности по предоставлению соответствующей технической поддержки несет изготовитель оборудования. Для повышения производительности оборудования изготовитель может устанавливать дополнительные компоненты, например специальные драйверы устройств, и настраивать определенные параметры операционной системы. Корпорация Майкрософт предоставляет ограниченную техническую поддержку пользователям 64-разрядных версий Windows. Однако в первую очередь следует обращаться непосредственно к изготовителю оборудования. Изготовитель обладает наилучшими возможностями по поддержке установленного им программного обеспечения.

Дополнительные сведения о 64-разрядной версии Windows XP Professional см. на веб-узле корпорации Майкрософт по следующему адресу:
http://www.microsoft.com/rus/windowsxp/64bit/default.mspx
Дополнительные сведения о 64-разрядной версии Microsoft Windows Server 2003 см. на веб-узле корпорации Майкрософт по следующему адресу:
http://www.microsoft.com/rus/windowsserver2003/64bit/x64/editions.mspx

Свойства

Код статьи: 905890 - Последний отзыв: 29 июня 2009 г. - Revision: 5.5
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Service Pack 1 на следующих платформах
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
  • Microsoft Windows XP Service Pack 2 на следующих платформах
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
Ключевые слова: 
kbautohotfix kbwinserv2003sp2fix kbqfe kbhotfixserver kbexpertiseadvanced KB905890

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com