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The Dhtmled.ocx ActiveX control does not work as expected after a program changes the Visible property of the Dhtmled.ocx control

Article ID:906216
Last Review:August 29, 2007
Revision:3.3
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SYMPTOMS

The Dhtmled.ocx ActiveX control does not work as expected after a program changes the Visible property of the Dhtmled.ocx control to FALSE and then back to TRUE. This problem only occurs after you install security update 891781 on the computer.

Note Security update 891781 is described in security bulletin MS05-013. For more information about security bulletin MS05-013, click the following article number to view the article in the Microsoft Knowledge Base:
891781 (http://support.microsoft.com/kb/891781/) MS05-013: Vulnerability in the DHTML editing component ActiveX control could allow code execution

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CAUSE

This problem occurs because the security update that is described in security bulletin MS05-013 makes changes to the Dhtmled.ocx control.

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RESOLUTION

Windows Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 (http://support.microsoft.com/kb/889100/) How to obtain the latest service pack for Windows Server 2003

Hotfix information

Prerequisites
To install this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer.
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhtmled.ocx6.1.0.9234120,83209-Sep-200519:29x86NoneRTMQFE

Windows Server 2003, x86-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhtmled.ocx6.1.0.9242132,60809-Sep-200519:37x86SP1SP1QFE

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Windows XP

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP with Service Pack 1
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhtmled.ocx6.1.0.9234118,27201-Sep-200501:48x86SP1SP1QFE


Windows XP with Service Pack 2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhtmled.ocx6.1.0.9234128,51201-Sep-200501:40x86SP2SP2QFE

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows Server 2003 Service Pack 2.

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MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Microsoft Windows Server 2003 Service Pack 1, when used with:
  Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  Microsoft Windows Server 2003, Web Edition
Microsoft Windows XP Service Pack 2, when used with:
  Microsoft Windows XP Professional
  Microsoft Windows XP Home Edition
  Microsoft Windows XP Media Center Edition
  Microsoft Windows XP Tablet PC Edition
  Microsoft Windows XP Professional
  Microsoft Windows XP Home Edition
  Microsoft Windows XP Media Center Edition
  Microsoft Windows XP Tablet PC Edition

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Keywords: 
kbautohotfix kbwinserv2003sp2fix kbqfe kbhotfixserver kbwinserv2003presp2fix kbwinxpsp3fix kbwinxppresp3fix kbfix kbbug kbpubtypekc KB906216

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