The Gpresult.exe tool stops responding or displays incorrect results when you run the Gpresult.exe tool together with the "/v" or "/z" switch on a Windows XP-based computer

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Article ID: 906450 - View products that this article applies to.
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Symptoms

When you run the Gpresult.exe command-line tool together with the /v or /z switch on a Microsoft Windows XP-based computer, you may experience one or more of the following symptoms:
  • The Gpresult.exe tool stops responding and an access violation error occurs.
  • The Gpresult.exe tool displays incorrect results.
Note This problem occurs only if the data to be displayed contains a "%" character.

Cause

This problem occurs because the Gpresult.exe tool does not correctly handle the "%" character.

When the data to be displayed contains a "%" character, the Gpresult.exe tool passes path strings to a printf() function. The printf() function scans the path strings for substitution strings such as "%S." Then, the printf() function tries to make character substitutions by using random data.

Resolution

Service pack information

For more information about how to obtain the latest Windows XP service pack, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 (SP2) installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Gprslt.exe5.1.2600.2781120,83221-Oct-200501:48x86

Workaround

To work around this problem, use the Microsoft Windows Server 2003 version of the Gpresult.exe tool.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 906450 - Last Review: June 20, 2014 - Revision: 3.0
Applies to
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbtshoot kbprb kbhotfixserver kbqfe KB906450

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