Error message when you try to connect to a remote share by using NTLM authentication on a Windows XP-based computer: "Logon failure: unknown user name or bad password"

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Article ID: 906524 - View products that this article applies to.
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SYMPTOMS

When you try to connect to a remote share by using NTLM authentication on a Microsoft Windows XP-based computer, you may receive the following error message:
Logon failure: unknown user name or bad password.
For example, you may experience this problem when you try to connect to a remote share by using the IP address as the server name.

Note This problem does not occur if you use Kerberos authentication.

CAUSE

This problem occurs because Windows XP does not cache the user credential correctly. Therefore, you cannot be authenticated by the remote computer when you try to connect to the remote share.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 1 (SP1) or Windows XP Service Pack 2 (SP2) installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP with Service Pack 1
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File nameFile versionFile sizeDateTimePlatform
Kerberos.dll5.1.2600.1735285,18424-Aug-200509:47x86

Windows XP with Service Pack 2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Kerberos.dll5.1.2600.2745297,98424-Aug-200509:17x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 906524 - Last Review: August 29, 2007 - Revision: 2.1
APPLIES TO
  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Service Pack 1a, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Service Pack 1, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kberrmsg kbtshoot kbprb kbhotfixserver kbqfe KB906524

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