Article ID: 906884 - Last Review: October 25, 2007 - Revision: 2.4

A duplicate message is delivered to a public folder in Exchange Server 2003 SP2

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SYMPTOMS

Consider the following scenario. A message exists in the public folder. Then, a message rule or another program sends a duplicate message to the public folder. In this scenario, the duplicate message is delivered to the public folder. You do not expect a duplicate message to be delivered to a public folder. A duplicate message is not delivered to a mailbox.

Note When this behavior occurs more than one time, you receive multiple duplicate messages.

CAUSE

This problem occurs because the duplicate detection functionality in Microsoft Exchange Server 2003 Service Pack 2 (SP2) does not work for public folders. In this scenario, the table that tracks delivered messages is not correctly updated with the correct folder ID (FID).

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must install Microsoft Exchange Server 2003 Service Pack 2 (SP2) before you install the hotfix.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993  (http://support.microsoft.com/kb/836993/ ) How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply the hotfix. However, the Microsoft Exchange Information Store service and all dependent services will be restarted.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Store.exe6.5.7650.195,249,02404-Jan-200618:54x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about a hotfix for a similar issue in Microsoft Exchange 2000 Server, click the following article number to view the article in the Microsoft Knowledge Base:
823290  (http://support.microsoft.com/kb/823290/ ) Duplicate messages are not detected when they are sent to public folders
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
817903  (http://support.microsoft.com/kb/817903/ ) New naming schema for Exchange Server software update packages

APPLIES TO
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbbug kbpubtypekc KB906884
 

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