ID do artigo: 906952 - Última revisão: segunda-feira, 16 de junho de 2008 - Revisão: 5.0

Evento 2020 ID e identificação de evento 1000 são registradas e o limite de tamanho do registro é excedido em um computador que está executando os serviços de terminal no modo servidor de aplicativos e Windows Server 2003 ou Windows 2000

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Sintomas

Considere o seguinte cenário:
  • Seu computador está executando o Microsoft Windows Server 2003 ou Microsoft Windows 2000.
  • O computador está executando serviços de terminal no modo servidor de aplicativos.
  • Redirecionamento de impressora está habilitado.
  • A função SetPrinter é definida como nível 2.
Nesse cenário, você os seguintes sintomas:
  • O limite de tamanho do registro é excedido. Além disso, a seguinte mensagem de evento é registrada no log do sistema:

    Tipo de evento: erro
    Origem do evento: SRV
    Categoria do evento: nenhum
    IDENTIFICAÇÃO de evento: 2020
    Data: Date
    Tempo: Time
    Usuário: N/d
    Server Name do computador:
    Descrição: O servidor não pôde alocar memória o paginável do sistema porque estava vazia.

  • Os usuários talvez não possa fazer logon no servidor que tem serviços de terminal habilitado. Nesse caso, a seguinte mensagem de evento é registrada no log do sistema:

    Tipo de evento: erro
    Origem do evento: Userenv
    Categoria do evento: nenhum
    IDENTIFICAÇÃO de evento: 1000
    Data: Date
    Tempo: Time
    Usuário: NT AUTHORITY\SYSTEM
    ComputerName do computador:
    Descrição: RegLoadKey falhou. Existem valor de retorno recursos de sistema insuficientes para concluir o serviço solicitado para C:\Documents and Settings\ntuser.dat.

  • O arquivo de hive de registro padrão que está localizado na pasta %SystemRoot% \System32\Config pode aumentar. Por exemplo, o tamanho pode ultrapassar mais de 5 megabytes (MB).
  • Os usuários conectados através de sessões de serviços de terminal podem enfrentar resposta lenta ou o cliente pode parecer que parar de responder (travar) ao executar programas no computador do Terminal Server. Além disso, os usuários podem receber mensagens de erro que estão relacionadas à memória do sistema.

Causa

Esse problema ocorre porque entradas do registro temporário que contêm informações sobre a impressora não são excluídas quando um usuário faz logoff. Essas entradas do Registro undeleted se acumulam até que o arquivo de hive do registro padrão excede o limite de tamanho do Registro.

Em um servidor de terminal, as impressoras redirecionadas são instaladas quando um usuário faz logon. A função SetPrinter armazena informações detalhadas sobre a impressora no buffer. Quando o usuário efetua logoff, a impressora é desinstalada e os valores do Registro correspondentes que contêm informações sobre impressora são excluídos.

Para oferecer suporte à compatibilidade com versões anteriores, as convenções de nomeação para os valores do registro que armazenam informações de impressora para os usuários conectados no momento são diferentes quando a função SetPrinter é definida como nível 2. Por exemplo, quando um usuário configura manualmente as configurações da impressora, os valores do registro que são armazenados na subchave do Registro
HKEY_USERS\.DEFAULT\Printers\DevModes2
são semelhantes à seguinte:
% ClientName % \ PrinterName % (de % ClientName %) na sessão SessionName
O valor do registro é criado usando a convenção de nomenclatura anteriormente é semelhante à seguinte:
\\ % ClientName % \ PrinterName % (de % ClientName %) na sessão SessionName, localspl
Quando a função SetPrinter é definida como nível 2, as entradas do registro que contêm informações sobre a impressora aparecem seja criada automaticamente. Como o processo de remoção somente procura e exclui valores do registro que são criados manualmente, essas entradas de registro temporário não são excluídas quando um usuário faz logoff.

Resolução

Windows 2000

Informações sobre o hotfix

importante Esse hotfix impede que novos valores sendo gravadas no registro, mas esse hotfix não exclui valores do registro existente. Portanto, você deve concluir as etapas que são incluídas na seção "Solução" antes de aplicar esse hotfix. Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibido, envie uma solicitação para suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos
Para aplicar esse hotfix, você deve ter o Windows 2000 Service Pack 4 (SP4) instalado no computador.
Requisitos de reinicialização
Reinicie o computador após aplicar esse hotfix.
Informações sobre a substituição do hotfix
Esse hotfix não substitui outros hotfixes.
Informações sobre o arquivo
A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
   Date         Time   Version           Size  File name
   --------------------------------------------------------
   09-Sep-2005  00:27  5.0.2195.7070  115,472  Winspool.drv
   25-Feb-2005  05:13  6.1.22.4       371,936  Updspapi.dll

Informações sobre a instalação do hotfix

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows


Para habilitar esse hotfix, você deve criar a subchave de registro
PrinterMaskKey
. Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize a seguinte subchave do Registro:
    HKEY_USERS\.default\printers
  3. Com o botão direito do mouse na subchave do registro localizado na etapa 2, aponte para novo , clique em chave , digite PrinterMaskKey e, em seguida, pressione ENTER.
  4. Feche o Editor do Registro.

Windows Server 2003

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Server 2003. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente para o Windows Server 2003

Informações sobre o hotfix

importante Esse hotfix impede que novos valores sendo gravadas no registro, mas esse hotfix não exclui valores do registro existente. Portanto, você deve concluir as etapas que são incluídas na seção "Solução" antes de aplicar esse hotfix.
Pré-requisitos
Não pré-requisitos são necessários.
Requisitos de reinicialização
Reinicie o computador após aplicar esse hotfix.
Informações sobre a substituição do hotfix
Esse hotfix não substitui outros hotfixes.
Informações sobre o arquivo
Windows Server 2003, versões de 32 bits
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Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Winspool.DRV5.2.3790.2740150,52805 De julho de 200616: 30Não aplicável
Windows Server 2003, versões com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação do serviço
Winspool.DRV5.2.3790.2740252,92805 De julho de 200617: 03Não aplicávelSP1SP1QFE
Wwinspool.DRV5.2.3790.2740150,52805 De julho de 200617: 03Não aplicávelSP1UAU
Windows Server 2003, versões com base em Itanium
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação do serviço
Winspool.DRV5.2.3790.2740410,11205 De julho de 200617: 02Não aplicávelSP1SP1QFE
Wwinspool.DRV5.2.3790.2740150,52805 De julho de 200617: 02Não aplicávelSP1UAU

Informações sobre a instalação do hotfix

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows


Para habilitar esse hotfix, você deve criar a subchave de registro
PrinterMaskKey
. Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize a seguinte subchave do Registro:
    HKEY_USERS\.default\printers
  3. Com o botão direito do mouse na subchave do registro localizado na etapa 2, aponte para novo , clique em chave , digite PrinterMaskKey e, em seguida, pressione ENTER.
  4. Feche o Editor do Registro.

Como Contornar

Para contornar esse problema, execute estas etapas:
  1. Certifique-se de que todos os usuários fizeram logoff do servidor e, em seguida, remova o servidor do ambiente de produção.
  2. Reinicie o servidor.
  3. Se o vazamento de memória não excedeu o limite de tamanho do Registro, vá para a etapa 4. Se o vazamento de memória excedeu o limite de tamanho do Registro, execute estas etapas:
    1. Fazer uma instalação paralela do Windows na mesma partição que a instalação não for iniciado. Para obter mais informações sobre como instalar uma instalação paralela do Windows, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
      266465  (http://support.microsoft.com/kb/266465/ ) Como executar uma instalação paralela do Windows 2000 ou Windows Server 2003
    2. Reinicie o computador usando a instalação paralela do Windows que você instalou na etapa 3a.
    3. Renomeie a seção de registro padrão da instalação problema do Windows para DEFAULT.BAK.

      O caminho da seção para renomear é % Systemroot%\System32\Config\DEFAULT.
    4. Carregar hive do Registro default.bak. Para fazer isso, execute as seguintes etapas:
      1. Clique em Iniciar , clique em Executar, digite regedit e, em seguida, clique em OK .
      2. Clique em HKEY_LOCAL_MACHINE , clique em Carregar seção no menu arquivo e selecione o arquivo de hive do registro que você tiver feito backup na etapa 3C.
      3. Nome de seção do registro recém-carregada. Por exemplo, nomeie o novo hive do registro padrão TEMP.
    5. Localize e exclua a seguinte subchave:
      HKEY_LOCAL_MACHINE\TEMP-DEFAULT\printers\Devmodes2
      Observação TEMP padrão é o nome da seção do registro que você carregou na etapa 3d.
    6. Recrie uma subchave
      Devmodes2
      em branco em
      HKEY_LOCAL_MACHINE\TEMP-DEFAULT\printers
      .
    7. Clique na seção HKEY_LOCAL_MACHINE\TEMP padrão e clique em Salvar chave no menu Arquivo.
    8. Salve a seção como padrão na pasta %Systemroot%\System32\Config.
    9. Clique no Editor do Registro, em Descarregar seção no menu arquivo .
    10. Reinicie o computador.
  4. Se o vazamento de memória não excedeu o limite de tamanho do Registro, exclua e recrie a seguinte subchave do Registro:
    HKEY_USERS\.default\printers\Devmodes2
  5. Monitore o tamanho do arquivo de seção padrão do registro que está localizado na pasta %Systemroot%\system32\config. Se o tamanho do arquivo de hive do registro padrão exceder o limite de tamanho do Registro, repita a etapa 3.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a". Esse problema foi corrigido primeiro no Microsoft Windows Server 2003 Service Pack 2.

Mais Informações

Para obter mais informações sobre como os pacotes de hotfix são nomeados, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
816915  (http://support.microsoft.com/kb/816915/ ) Novo esquema de nomeação de arquivo para pacotes de atualização de software do Microsoft Windows
Para obter mais informações sobre a terminologia padrão que é usada para descrever as atualizações de software da Microsoft, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Palavras-chave: 
kbmt kbautohotfix kbwinserv2003sp2fix kbhotfixserver kbtshoot kbbug kbfix kbqfe kbpubtypekc KB906952 KbMtpt
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