Makale numarası: 906952 - Son Gözden Geçirme: 16 Haziran 2008 Pazartesi - Gözden geçirme: 5.0

Olay KIMLIĞI 2020 ve olay KIMLIĞI 1000 kaydediliyor ve Terminal Hizmetleri uygulama sunucusu modunda ve Windows Server 2003 veya Windows 2000 çalıştıran bir bilgisayarda kayıt defteri boyut sınırı aşıldığından

Hotfix Download is availableHotfiks Yüklemesi Mevcut
Hotfiks taleplerini görüntüle ve indir
Sistem İpucuBu makale, kullandığınızdan farklı bir işletim sistemine yöneliktir. Sizinle ilgili olmayabilecek makale içeriği devre dışı bırakıldı.

Bu Sayfada

Hepsini aç | Hepsini kapa

Belirtiler

Şu senaryoyu inceleyin:
  • Bilgisayarınızı Microsoft Windows Server 2003 veya Microsoft Windows 2000 çalışıyor.
  • Bilgisayarı, Terminal Hizmetleri uygulama sunucusu modunda çalışıyor.
  • Yazıcı yeniden yönlendirmesi etkinleştirilir.
  • SetPrinter işlevi, Düzey 2 olarak ayarlanır.
Bu senaryoda, aşağıdaki belirtilerle karşılaşırsınız:
  • Kayıt defteri boyut sınırını aştı. Ayrıca, sistem günlüğüne aşağıdaki olay iletisi günlüğe kaydedilir:

    Olay türü: hata
    Olay kaynağı: sunucusu
    Olay kategorisi: yok
    Olay KIMLIĞI: 2020
    Tarihi: Date
    Time saati:
    Kullanı.: Yok
    Bilgisayar: Server Name
    Açıklama: Sunucu havuzu boş olduğundan Sistem disk belleğine alınmayan havuzdan ayıramadı.

  • Kullanıcılar Terminal Hizmetleri etkinleştirilmiş olan sunucuya oturum açamayabilirsiniz. Bu durumda, sistem günlüğüne aşağıdaki olay iletisi günlüğe kaydedilir:

    Olay türü: hata
    Olay Kaynağı: Userenv
    Olay kategorisi: yok
    Olay KIMLIĞI: 1000
    Tarihi: Date
    Time saati:
    Kullanıcı: NT authorıty\system
    Bilgisayar: ComputerName
    Açıklama: RegLoadKey başarısız oldu. C:\Documents and Settings\ntuser.dat için istenen hizmeti tamamlamak için yetersiz sistem kaynakları dönüş değeri yok.

  • Varsayılan kayıt defteri kovanı dosyası %SystemRoot% \System32\Config klasöründe artabilir. Örneğin, boyut 5 megabayttan (MB) fazla aşabilir.
  • Istemci programları Terminal Sunucu bilgisayarında çalıştığında (askıda kalabilir) yanıt vermiyor gibi görünebilir veya Terminal Hizmetleri oturumu bağlı olan kullanıcıların, yavaş yanıt karşılaşabilirsiniz. Ayrıca, kullanıcılar, sistem belleğinin ilgili hata iletileri alabilirsiniz.

Neden

Bu sorun, kullanıcı oturumu kapattığında yazıcı bilgilerini içeren geçici bir kayıt defteri girdileri silinmez nedeniyle oluşur. Varsayılan kayıt defteri yığın dosyasına kayıt defteri boyut sınırı aşıyor kadar bu silinmemiş olan kayıt defteri girdileri birikebilecek.

Bir kullanıcı oturum açtığında, terminal sunucusuna yeniden yönlendirilen yazıcılar yüklenir. Yazıcı hakkında ayrıntılı bilgi, SetPrinter işlevi arabellekte saklar. Kullanıcı oturumu kapattığında yazıcı kaldırılır ve yazıcı bilgilerini içeren ilgili kayıt defteri değerleri silinir.

SetPrinter işlevi düzey 2 olarak ayarlandığında, geriye dönük uyumluluk için destek için <a0></a0>, adlandırma kuralları şu anda oturum açmış kullanıcı, yazıcı bilgilerini saklayan kayıt defteri değerleri farklı olur. Bir kullanıcı, el ile yazıcı ayarlarını yapılandırır, örneğin
HKEY_USERS\.DEFAULT\Printers\DevModes2
kayıt defteri alt anahtarının altında depolanan bir kayıt defteri değerlerini aşağıdakine benzer:
% ClientName % \ % PrinterName % (% ClientName %) oturumunda SessionName
Önceki adlandırma kuralı'nı kullanarak oluşturduğunuz kayıt defteri değeri, aşağıdakine benzer:
\\ % ClientName % \ % PrinterName % (% ClientName %) oturumunda SessionName, localspl
SetPrinter işlevi düzey 2 olarak ayarlandığında, yazıcı bilgilerini içeren kayıt defteri girdilerini otomatik olarak oluşturulacak görünür. Kaldırma işlemi yalnızca arar ve el ile oluşturulan bir kayıt defteri değerlerini siler çünkü kullanıcı oturumu kapattığında bu geçici kayıt defteri girdileri silinmez.

Çözüm

WINDOWS 2000

Düzeltme bilgileri

Önemli Bu düzeltme, yeni değerleri kayıt defterine yazılır engeller, ancak bu düzeltmenin varolan kayıt defteri değerlerini silin. Bu nedenle, bu düzeltmeyi uygulamadan önce "Geçici çözüm" bölümünde bulunan adımları tamamlamalısınız. Desteklenen bir düzeltme Microsoft'tan edinilebilir. Ancak bu düzeltmenin, yalnızca bu makalede anlatılan sorunu gidermesi amaçlanmıştır. Bu düzeltmeyi yalnızca bu sorunla karşılaşan sistemlere uygulayın.

Düzeltme karşıdan yüklenebilir ise bu Bilgi Bankası makalesinin başında "Düzeltme karşıdan yüklenebilir" bölümü bulunur. Bu bölüm görünmüyorsa, düzeltmeyi edinmek üzere Microsoft Müşteri Hizmetleri ve Destek ekibine bir istekte bulunun.

Not Ek sorunlar oluşursa veya tüm sorun giderme işlemi gerekmiyorsa, ayrı bir hizmet isteği oluşturmanız gerekebilir. Ek destek sorularına ve bu düzeltme için geçerli olmayan sorunlara normal destek ücretleri uygulanır. Microsoft Müşteri Hizmetleri ve Destek telefon numaralarının tam listesi veya ayrı bir hizmet isteği oluşturmak için, aşağıdaki Microsoft Web sitesini ziyaret edin:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Not "Düzeltme karşıdan yüklenebilir" formunda, düzeltmenin kullanılabilir olduğu diller görüntülenir. Kendi dilinizi görmüyorsanız, bunun nedeni bu düzeltme, seçtiğiniz dil için kullanılamaz.
ÖNKOŞULLAR
Bu düzeltmenin uygulanabilmesi için bilgisayarda Windows 2000 Service Pack 4 (SP4) olmalıdır.
Yeniden başlatma gereksinimi
Bu düzeltmeyi yükledikten sonra bilgisayarı yeniden başlatmanız gerekir.
Düzeltme Değiştirme Bilgileri
Bu düzeltme başka bir düzeltmenin yerini almaz.
DOSYA BİLGİLERİ
Bu düzeltmenin İngilizce sürümü, aşağıdaki tabloda listelenen dosya özniteliklerine (veya daha yeni dosya özniteliklerine) sahiptir. Bu dosyaların tarihleri ve saatleri Koordinatlı Evrensel Saat'e (UTC) göre listelenir. Dosya bilgilerini görüntülediğinizde yerel saate dönüştürülür. UTC ve yerel saat arasındaki farkı bulmak için <a0></a0>, Denetim Masası'ndaki tarih ve saat öğesinde saat dilimi sekmesini kullanın.
   Date         Time   Version           Size  File name
   --------------------------------------------------------
   09-Sep-2005  00:27  5.0.2195.7070  115,472  Winspool.drv
   25-Feb-2005  05:13  6.1.22.4       371,936  Updspapi.dll

Düzeltme yükleme bilgileri

Önemli Bu bölüm, yöntem veya görev kayıt defterini nasıl söyleyin adımları içerir. Ancak kayıt defterini hatalı olarak değiştirirseniz önemli sorunlar oluşabilir. Bu nedenle, bu adımları dikkatlice uyguladığınızdan emin olun. Ek koruma için, kayıt defterini değiştirmeden önce yedeklemeyi unutmayın. Bir sorun oluşursa kayıt defterini daha sonra geri yükleyebilirsiniz. Kayıt defterini yedekleme ve geri yükleme hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
322756  (http://support.microsoft.com/kb/322756/ ) Windows'da kayıt defterini yedekleme ve geri yükleme


Bu düzeltmeyi etkinleştirmek için <a0></a0>,
PrinterMaskKey
kayıt defteri alt anahtarını oluşturmanız gerekir. Bunu yapmak için şu adımları izleyin:
  1. Başlat ' ı tıklatın, Çalıştır ' ı tıklatın, regedit yazın ve Tamam ' ı tıklatın.
  2. Aşağıdaki kayıt defteri alt anahtarını bulun:
    HKEY_USERS\.default\printers
  3. 2. Adımda bulduğunuz kayıt defteri alt anahtarını sağ tıklatın, Yeni ' nin üzerine gelin, anahtar ' ı tıklatın, PrinterMaskKey yazın ve ENTER tuşuna basın.
  4. Kayıt Defteri Düzenleyicisi'nden çıkın.

Windows Server 2003

Hizmet paketi bilgileri

Bu sorunu gidermek için <a0></a0>, Windows Server 2003 için en son hizmet paketini edinin. Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
889100  (http://support.microsoft.com/kb/889100/ ) En son Windows Server 2003 hizmet paketi nasıl elde edilir

Düzeltme bilgileri

Önemli Bu düzeltme, yeni değerleri kayıt defterine yazılır engeller, ancak bu düzeltmenin varolan kayıt defteri değerlerini silin. Bu nedenle, bu düzeltmeyi uygulamadan önce "Geçici çözüm" bölümünde bulunan adımları tamamlamalısınız.
ÖNKOŞULLAR
Herhangi bir önkoşul bulunmamaktadır.
Yeniden başlatma gereksinimi
Bu düzeltmeyi yükledikten sonra bilgisayarı yeniden başlatmanız gerekir.
Düzeltme Değiştirme Bilgileri
Bu düzeltme başka bir düzeltmenin yerini almaz.
DOSYA BİLGİLERİ
Windows Server 2003'ün 32-bit sürümleri
Bu tabloyu kapaBu tabloyu aç
Dosya AdıDosya SürümüDosya BoyutuTARİHSAATPlatform
Winspool.drv5.2.3790.2740150,52805 Tem 200616: 30Uygulanamaz
Windows Server 2003, x 64 tabanlı sürümleri
Bu tabloyu kapaBu tabloyu aç
Dosya AdıDosya SürümüDosya BoyutuTARİHSAATPlatformSP gereksinimiHizmet Dalı
Winspool.drv5.2.3790.2740252,92805 Tem 200617: 03UygulanamazSP1SP1QFE
Wwinspool.drv5.2.3790.2740150,52805 Tem 200617: 03UygulanamazSP1WOW
Windows Server 2003, ıtanium tabanlı sürümleri
Bu tabloyu kapaBu tabloyu aç
Dosya AdıDosya SürümüDosya BoyutuTARİHSAATPlatformSP gereksinimiHizmet Dalı
Winspool.drv5.2.3790.2740410,11205 Tem 200617: 02UygulanamazSP1SP1QFE
Wwinspool.drv5.2.3790.2740150,52805 Tem 200617: 02UygulanamazSP1WOW

Düzeltme yükleme bilgileri

Önemli Bu bölüm, yöntem veya görev kayıt defterini nasıl söyleyin adımları içerir. Ancak kayıt defterini hatalı olarak değiştirirseniz önemli sorunlar oluşabilir. Bu nedenle, bu adımları dikkatlice uyguladığınızdan emin olun. Ek koruma için, kayıt defterini değiştirmeden önce yedeklemeyi unutmayın. Bir sorun oluşursa kayıt defterini daha sonra geri yükleyebilirsiniz. Kayıt defterini yedekleme ve geri yükleme hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
322756  (http://support.microsoft.com/kb/322756/ ) Windows'da kayıt defterini yedekleme ve geri yükleme


Bu düzeltmeyi etkinleştirmek için <a0></a0>,
PrinterMaskKey
kayıt defteri alt anahtarını oluşturmanız gerekir. Bunu yapmak için şu adımları izleyin:
  1. Başlat ' ı tıklatın, Çalıştır ' ı tıklatın, regedit yazın ve Tamam ' ı tıklatın.
  2. Aşağıdaki kayıt defteri alt anahtarını bulun:
    HKEY_USERS\.default\printers
  3. 2. Adımda bulduğunuz kayıt defteri alt anahtarını sağ tıklatın, Yeni ' nin üzerine gelin, anahtar ' ı tıklatın, PrinterMaskKey yazın ve ENTER tuşuna basın.
  4. Kayıt Defteri Düzenleyicisi'nden çıkın.

Pratik Çözüm

Bu soruna geçici bir çözüm için aşağıdaki adımları izleyin:
  1. Tüm kullanıcıların sunucu oturum olduğundan emin olun ve sonra sunucu, üretim ortamından kaldırın.
  2. Sunucuyu yeniden başlatın.
  3. Bellek sızıntısı kayıt defteri boyut sınırını aştı, adım 4'e gidin. Bellek sızıntısı kayıt defteri boyut sınırını aştı, şu adımları izleyin:
    1. Windows'un paralel bir kurulumunu başlatılamayan bir yükleme ile aynı bölüme yükleyin. Paralel bir Windows yüklemesi'ni yükleme hakkında daha fazla bilgi için Microsoft Knowledge Base'deki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
      266465  (http://support.microsoft.com/kb/266465/ ) Windows 2000 veya Windows Server 2003'ün paralel kurulumu nasıl gerçekleştirilir (Bu bağlantı, bir kısmı veya tamamı İngilizce olan içeriğe işaret edebilir.)
    2. Adım 3a yüklenmiş olan paralel yüklemesini kullanarak, bilgisayarı yeniden başlatın.
    3. Windows sorun yüklemesinden DEFAULT.BAK için VARSAYıLAN kayıt defteri kovanını yeniden adlandırın.

      Kovan, yeniden adlandırmak için <a1>%</a1> Systemroot%\System32\Config\DEFAULT yoludur.
    4. Default.bak kayıt defteri kovanını yükleyin. Bunu yapmak için şu adımları izleyin:
      1. Başlat ' ı tıklatın, Çalıştır'ı tıklatın, regedit yazın ve Tamam ' ı tıklatın.
      2. Hkey_local_machıne ANAHTARıNı tıklatın Yük kovanıDosya menüsünden'ı ve sonra da adım 3 c yedeklediğiniz kayıt defteri kovanı dosyasını seçin.
      3. Yeni yüklenen kayıt defteri kovanının adını. Örneğin, yeni kayıt defteri kovanını TEMP VARSAYıLAN adı.
    5. Bulun ve aşağıdaki alt anahtarını silin:
      HKEY_LOCAL_MACHINE\TEMP-DEFAULT\printers\Devmodes2
      Not TEMP DEFAULT adımda yüklenen kayıt defteri kovanını adıdır 3d.
    6. Boş bir
      Devmodes2
      alt anahtarının altında
      HKEY_LOCAL_MACHINE\TEMP-DEFAULT\printers
      yeniden oluşturun.
    7. HKEY_LOCAL_MACHINE\TEMP VARSAYıLAN kovanını'ı tıklatın ve sonra da <a2>Dosya</a2> menüsünde anahtarı Kaydet ' i tıklatın.
    8. VARSAYıLAN olarak %Systemroot%\System32\Config klasöründe kovanını kaydedin.
    9. Kayıt Defteri Düzenleyicisi'nde, Dosya menüsünden Yığını Kaldır'ı tıklatın.
    10. Bilgisayarı yeniden başlatın.
  4. Bellek sızıntısı kayıt defteri boyut sınırını aştı, silin ve sonra da aşağıdaki kayıt defteri alt anahtarını yeniden oluşturun:
    HKEY_USERS\.default\printers\Devmodes2
  5. %Systemroot%\system32\config klasöründe bulunan varsayılan kayıt defteri kovanı dosyasının boyutunu izleyin. Varsayılan kayıt defteri kovanı dosyasının boyutu, kayıt defteri boyut sınırı aşarsa, adım 3'yi yineleyin.

Durum

Microsoft, "Geçerli Olduğu Ürünler" bölümünde listelenen Microsoft ürünlerinde bu sorunun olduğunu onaylamıştır. Bu sorun ilk olarak Microsoft Windows Server 2003 Service Pack 2'de giderilmiştir.

Daha fazla bilgi

Düzeltme paketlerinin adlandırılması hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
816915  (http://support.microsoft.com/kb/816915/ ) Microsoft Windows Yazılım Güncelleştirme Paketleri için Yeni Dosya Adlandırma Şeması
Microsoft yazılım güncelleştirmelerini tanımlamak için kullanılan standart terminoloji hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
824684  (http://support.microsoft.com/kb/824684/ ) Microsoft yazılım güncelleştirmelerini açıklamak için kullanılan standart terminolojinin açıklaması

Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Anahtar Kelimeler: 
kbmt kbautohotfix kbwinserv2003sp2fix kbhotfixserver kbtshoot kbbug kbfix kbqfe kbpubtypekc KB906952 KbMttr
Otomatik TercümeOtomatik Tercüme
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:906952  (http://support.microsoft.com/kb/906952/en-us/ )