How to back up accounts and workspaces in Groove

Article translations Article translations
Article ID: 907230 - View products that this article applies to.
Expand all | Collapse all

On This Page

INTRODUCTION

To prevent data loss from hardware failure or from accidental deletions, we recommend that you back up vulnerable accounts and workspaces. This article describes how to back up accounts and workspaces in Microsoft Office Groove 2007, in Groove Virtual Office 3.x and in Groove Workspace 2.x. Additionally, this article describes how to back up messages in Groove 3.x.

MORE INFORMATION

How to back up an account

If you use an account on multiple computers, or if you are part of a managed Groove domain that performs automated backups, you already have other copies of your account. You can use one of these copies to restore your account if something occurs to the local Groove installation. However, if you use your Groove account on one computer, and if you do not belong to a managed domain that performs automated backups, you should help protect the account by manually saving the account to a file at least every 59 days. After 60 days, the account file expires, and you will not be able to use it.

In Groove 2007, you can avoid this 60-day limitation by requesting and applying hotfix 935874. For more information about hotfix 935874, click the following article number to view the article in the Microsoft Knowledge Base:
935874 Description of the Groove 2007 hotfix package: April 11, 2007
Older account files may be difficult to reconcile with more recent Groove Relay information. Therefore, we still recommend that you back up your account at least every 60 days.

To save your Groove account data in Groove 2007, follow these steps:
  1. On the Options menu, click Preferences.
  2. Click the Account tab, and then click Save under Save Account As File to create an account file.
To save your Groove account data in Groove 3.x, follow these steps:
  1. On the Options menu, click Preferences.
  2. Click the Account tab, and then click Save Account As File to create an account file.
To save your Groove account data in Groove 2.x, follow these steps:
  1. Click Go To, and then click My Account.
  2. Click Backup Account.

How to back up a workspace

Your Groove account contains your preferences, settings, and contacts. Additionally, the account contains a list of your Groove workspaces and the members of those workspaces. However, the account does not contain the actual workspace data. Therefore, when you save a Groove account file, you save only pointers to your workspaces. You do not save any data that is stored in those workspaces. If you import a Groove account file into Groove, you will see all your old shared workspaces listed in your workspace list. However, you will not be able to enter those workspaces until you fetch them from another member.

Groove has two kinds of workspaces. Standard workspaces store data in Groove in an encrypted format. File sharing workspaces synchronize a Windows folder. If you have standard workspaces that contain only a few members or that contain critical data that is frequently edited, you may want to regularly archive those workspaces. Therefore, if the workspace is lost, or if critical data is overwritten by mistake, you can restore a copy of the workspace from a file.

You cannot archive a Groove file sharing workspace. To save workspace data from a Groove file sharing workspace, use your preferred file system backup tool to back up the Windows folder synchronized by the workspace. Groove does not encrypt the contents of Groove synchronized folders except when the contents are sent over the network. Therefore, a file system backup is sufficient to preserve your data.

If you lose files in a synchronized folder and then go online in Groove, Groove will send delete messages to synchronize the workspace. If you have lost files from a synchronized folder, do not restart Groove until all files are restored. Any file that is added while Groove is active or that is restored with a changed name will be seen as new. Therefore, the file is propagated to other workspace members according to the folder download properties. Although resending these files will not cause data loss, it will consume network resources and computer resources.

To save workspace data from any other workspace, you must save the workspace as an archive. To do this in Groove 2007 or in Groove 3.x, use one of the following methods:
  • Right-click the workspace in any list of your workspaces, click Save As, and then click Archive. When you are prompted, provide a file name and, if you want, a password.
  • In the Launchbar, click the Workspaces tab, and then click the workspace. On the File menu, point to Save Workspace As, and then click Archive. When you are prompted, provide a file name and, if you want, a password.
To save a workspace as an archive in Groove 2.x, use one of the following methods:
  • Right-click the workspace in any list of your workspaces, click Save As, and then click Archive. When you are prompted, provide a file name and, if you want, a passphrase.
  • Click Go To, click My Spaces, and then click the workspace. On the File menu, click Save Shared Space As, and then click Archive. When you are prompted, provide a file name and, if you want, a passphrase.
To restore the workspace in Groove 2007 or in Groove 3.x, follow these steps:
  1. Open the list of workspaces in Workspace Manager or in the Launchbar.
  2. On the File menu, point to New, point to Workspace From, and then click Archive.
  3. When you are prompted, provide the location, file name, and password that you used to save the workspace.
To restore the workspace in Groove 2.x, follow these steps:
  1. Click Go To, and then click My Spaces.
  2. On the File menu, click Open Shared Space Archive.
  3. When you are prompted, provide the location, file name, and passphrase that you used to save the workspace.
When you restore a workspace, you create a copy of that workspace. Additionally, you are the only member of that copy of the workspace. You must still be reinvited to the original workspace to return to being an active member or to invite others to your copy to make it an active workspace. Workspace archive files do not explicitly time out. However, as with any backup, workspace archive files become less useful as the active information diverges.

How to back up messages in Groove Virtual Office 3.1 and in earlier versions of Groove 

Groove does not have a backup function for your message history. However, in Groove Virtual Office 3.1 and earlier versions of Groove, you can export all or some of your messages to a workspace. To archive instant messages, select the messages in the Message History window, click Send To, and then click New Workspace. After you create the workspace, follow the workspace backup procedure that is described in the "How to back up a workspace" section to archive the workspace. This feature is not available in Groove 2007.

Automated backup options

For additional, automated data protection, consider a backup product that is designed to work with Groove. For a partial list of tools that are available from Microsoft partners, see the "Third Party Tools" section in the Groove Backup Options white paper on the Microsoft download center. Note that this list is no longer being updated. Groove-compatible backup tools may also be available from other sources.

REFERENCES

For more information about how to save and restore workspace data, see the "Managing Workspaces" section in Groove Help. 

Properties

Article ID: 907230 - Last Review: April 13, 2012 - Revision: 1.1
APPLIES TO
  • Groove Virtual Office 3.0 File Sharing Edition
  • Groove Virtual Office 3.0 Professional Edition
  • Groove Virtual Office 3.0 Project Edition
  • Groove Virtual Office 3.1 File Sharing Edition
  • Groove Virtual Office 3.1 Professional Edition
  • Groove Virtual Office 3.1 Project Edition
  • Groove Workspace 2.5 Preview Edition
  • Groove Workspace 2.5 Professional Edition
  • Groove Workspace 2.5 Project Edition
  • Groove Workspace 2.5 Standard Edition
  • Microsoft Office Groove 2007
Keywords: 
kbexpertiseinter kbinfo KB907230

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com