You may receive a "The application or DLL C:\Windows\System32\win32k.sys is not a valid Windows image" error in MPSReport on a computer that is running Windows Server 2003 or Windows 2000

Article translations Article translations
Article ID: 907300 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

You are using the Microsoft Product Support Reporting Tool (MPSReport) on a computer that is running Microsoft Windows Server 2003 or Microsoft Windows 2000. You may receive the following error message in MPSReport:
The application or DLL C:\Windows\System32\win32k.sys is not a valid Windows image. Please check this against your installation diskette.
The following event may also be logged in the System event log:

Event Type: Information
Event Source: Application Popup
Event Category: None
Event ID: 26
Date: <date>
Time: <time>
User: N/A
Computer: computername
Description: Application popup: DUMPEL.EXE - Bad Image : The application or DLL C:\WINDOWS\System32\win32k.sys is not a valid Windows image. Please check this against your installation diskette.

CAUSE

This problem occurs when an error message that is similar to the following is logged in the System event log:
Event ID 243
A desktop heap allocation failed
This event is logged when Windows experiences desktop heap exhaustion. You receive the error message that is mentioned in the "Symptoms" section every time this event is logged.

RESOLUTION

You can safely ignore this error message. The error message is displayed by an incorrect operation in the Dumpel.exe program. This program is contained in MPSReport.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

184802 PRB: User32.dll or Kernel32.dll fails to initialize

Properties

Article ID: 907300 - Last Review: January 30, 2007 - Revision: 2.3
APPLIES TO
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Keywords: 
kbwinservsetup kbtshoot kbinfo kbbug kbprb KB907300

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com