FIX: You receive a "System.OutOfMemoryException" error message when you import a very large Site Deployment Object package in Content Management Server 2002

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Article ID: 907649 - View products that this article applies to.
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SYMPTOMS

When you import a very large Site Deployment Object (SDO) package in Microsoft Content Management Server (MCMS) 2002, you receive a "System.OutOfMemoryException" error message. This problem occurs regardless of whether you run the import from a client computer or from the server.

When you import the package through Site Manager, you receive the following error message:
Error: 0
Description: Exception of type System.OutOfMemoryException was thrown.
Severity: 5
Source: (ISOK File nrxmlproxy.cpp, Line 669)
Debug info: N/A
Extra info: N/A
Client Source: CImProgress::ProcessPackage
Recommended Action: N/A
Additionally, the following error messages may be logged in the MCMS 2002 Application log and in the Microsoft SQL Server Application log:
  • MCMS 2002 Application log
    MCMS Site Deployment - Error occurred.
    System.Data.SqlClient.
    SqlError: A severe error occurred on the current command.
    The results, if any, should be discarded.
  • SQL Server Application log
    Error: 17803, Severity: 20, State: 12
    Insufficient memory available.

CAUSE

MCMS 2002 tries to import all the data from the SDO package in one transaction. This behavior causes SQL Server to consume too much memory.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Content Management Server 2002. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
906142 How to obtain the latest Microsoft Content Management Server 2002 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Content Management Server 2002 Service Pack 1a (SP1a) installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size       File name
   -----------------------------------------------------------------
   02-Sep-2005  21:27  5.0.4547.0  2,050,560  Nrsitedeployserver.dll
Note Because of file dependencies, the most recent hotfix or feature that contains these files may contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Content Management Server 2002 Service Pack 2.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about MCMS 2002, visit the following Microsoft Web site:
http://www.microsoft.com/cmserver/default.mspx

Properties

Article ID: 907649 - Last Review: November 15, 2007 - Revision: 1.3
APPLIES TO
  • Microsoft Content Management Server 2002
Keywords: 
kbautohotfix kbcontentmgtserv2002sp2fix kbfix kbbug kbcontentmgtserv2002presp2fix kbhotfixserver kbqfe KB907649

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