You cannot draw an exact polygon when you use the FillPolygon method and the PathGradientBrush class in the .NET Framework 1.1 on a Windows XP-based computer

Article translations Article translations
Article ID: 907803 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

On a Microsoft Windows XP-based computer, you cannot draw an exact polygon that has gradient fill effects when you use the FillPolygon method and the PathGradientBrush class in the Microsoft .NET Framework 1.1. Additionally, rounding errors may distort the adjoining edges of the polygon.

This problem also occurs when you use the GDI+ API to draw a polygon in Windows XP.

Note This problem does not occur when you draw a polygon in a single color.

CAUSE

This problem occurs because the calculation method for polygons that have gradient fill effects differs from the calculation method for polygons that have solid fill effects.

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Gdiplus.dll5.1.3102.27581,720,32013-Sep-200503:45x86
Gdiplus.manNot Applicable39713-Sep-200503:56Not Applicable
Gdiplus.manNot Applicable60513-Sep-200503:56Not Applicable
Arpidfix.exe5.1.2600.275830,72013-Sep-200501:14x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that Microsoft uses when software is updated, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 907803 - Last Review: October 9, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbexpertiseinter kbfix kbHotfixServer kbqfe KB907803

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com