Artigo: 907971 - Última revisão: sexta-feira, 27 de Outubro de 2006 - Revisão: 1.3

Apesar do serviço SMTP é iniciado, o servidor virtual de SMTP não é iniciado no Exchange 2000 Server

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

O serviço SMTP (Simple Mail Transfer Protocol) é iniciado, mas o SMTP servidor virtual não é iniciado no Microsoft Exchange 2000 Server. Além disso, é registado um evento semelhante à seguinte evento no registo de aplicações:

Event ID: 115Source: SMTPSVCDescription:
The service could not bind instance 1. The data is the error code.

Causa

Este problema ocorre se um programa de terceiros é utilizar a porta TCP 25. Por predefinição, a porta TCP 25 é a porta que está atribuída para correio SMTP. Alguns antivírus de outros fabricantes e programas de filtragem de conteúdos monitorizam porta TCP 25. Estes programas reencaminhar correio SMTP de porta 25 para outra porta.

Resolução

Para resolver este problema tem de identificar a porta à qual o programa de filtragem terceiros anti-vírus ou conteúdo reencaminha correio SMTP. Em seguida, tem de alterar a porta para o serviço SMTP.

Para identificar e alterar a porta, siga estes passos:
  1. Verifique se se quaisquer programas de outros fabricantes estão em execução no servidor do Exchange 2000 Server para protecção contra vírus em forma de SMTP ou de filtragem de conteúdos.
  2. Desactivar estes programas e reinicie o servidor virtual de SMTP. Para iniciar o servidor virtual de SMTP, siga estes passos:
    1. Inicie o Exchange System Manager.
    2. Expanda Administrative Groups , expanda Your_Administrative_Group e, em seguida, expanda Servers .
    3. Expanda Your_Exchange_Server_Name e, em seguida, expanda Protocols .
    4. Clique em servidor virtual de SMTP predefinido e, em seguida, clique em Iniciar .

      Nota Se o servidor virtual de SMTP for iniciado, o programa de terceiros que desactivou está a bloquear a porta do SMTP predefinido. Neste caso, saia do Exchange System Manager e, em seguida, conclua os restantes passos descritos nesta secção.

      Se o servidor virtual de SMTP não for iniciado, terá de seguir outros métodos de resolução de problemas para resolver este problema.
  3. Consulte a documentação do programa de terceiros ou o ficheiro de ajuda para identificar a porta à qual o programa reencaminha correio SMTP. Poderá ter de contactar o fabricante do produto para obter estas informações.
  4. Localize o ficheiro de serviços.
    • No Windows Server 2003, o ficheiro de serviços é armazenado na seguinte pasta:
      %Systemroot%\WINDOWS\System32\Drivers\etc\Services
    • No Windows 2000 Server, o ficheiro de serviços é armazenado na seguinte pasta:
      %Systemroot%\WINNT\System32\Drivers\Etc\Services
  5. Utilize o bloco de notas para abrir o ficheiro de serviços e localize as informações do serviço SMTP.

    Num ficheiro de serviços típico, entradas predefinidas aparecem no topo do ficheiro. Em seguida, as entradas para cada serviço aparecem abaixo as entradas predefinidas. O texto seguinte é um exemplo de um ficheiro de serviços que inclui a entrada predefinida para o serviço SMTP:
    # Copyright (c) 1993-1999 Microsoft Corp.
    #
    # This file contains port numbers for well-known services defined by IANA
    #
    # Format:
    #
    #<service name><port number>/<protocol> [aliases...] [#<comment>]
    #
    
    smtp 25/tcp mail #Simple Mail Transfer Protocol
  6. Altere a entrada de serviço SMTP como necessário. Por exemplo, se o programa de terceiros requerer o serviço SMTP para escutar na porta 2525, altere a entrada SMTP para o seguinte:

    SMTP 2525/tcp correio #Simple Mail Transfer Protocol
  7. Guardar o ficheiro e saia do bloco de notas.
  8. Utilize um dos seguintes métodos para reiniciar o serviço SMTP:
    • Reinicie o serviço SMTP a partir do snap-in Serviços:
      1. Clique em Iniciar , clique em Executar , escreva services.msc e, em seguida, clique em OK .
      2. Clique com o botão direito do rato no serviço SMTP e, em seguida, clique em reiniciar .
    • Reinicie o serviço SMTP na linha de comandos:
      1. Abra uma linha de comandos.
      2. Escreva o seguinte comando e, em seguida, prima ENTER:
        net stop smtpsvc && net start smtpsvc
      3. Escreva exit e, em seguida, prima ENTER.
    .
  9. Active os programas de outros fabricantes que desactivou no passo 2.

Mais Informação

Para obter informações sobre o fabricante do hardware, visite o seguinte Web site:
http://support.microsoft.com/gp/vendors/en-us (http://support.microsoft.com/gp/vendors/en-us)
Microsoft fornece informações de contactos outros fabricantes para ajudar a encontrar suporte técnico. Poderá ser alterado estas informações de contacto sem aviso prévio. Microsoft não garante a precisão destas informações de contacto outros fabricantes.

Referências

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
173903  (http://support.microsoft.com/kb/173903/ ) Alterar a porta TCP é utilizada para correio SMTP

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange 2000 Server Standard Edition
Palavras-chave: 
kbmt kbtshoot kbprb KB907971 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 907971  (http://support.microsoft.com/kb/907971/en-us/ )