ID do artigo: 907971 - Última revisão: sexta-feira, 27 de outubro de 2006 - Revisão: 1.3

Embora o serviço SMTP é iniciado, o servidor virtual SMTP não inicia no Exchange 2000 Server

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Recolher tudo

Sintomas

O serviço SMTP (Simple Mail Transfer Protocol) é iniciado, mas o SMTP servidor virtual não inicia no Microsoft Exchange 2000 Server. Além disso, um evento semelhante ao seguinte evento é registrado no log do aplicativo:

Event ID: 115Source: SMTPSVCDescription:
The service could not bind instance 1. The data is the error code.

Causa

Esse problema ocorre se um programa de terceiros estiver usando a porta TCP 25. Por padrão, porta 25 TCP é a porta que está atribuída a email SMTP. Alguns antivírus de terceiros e programas de filtragem de conteúdo monitoram a porta TCP 25. Esses programas encaminhar emails SMTP da porta 25 a outra porta.

Resolução

Para resolver esse problema, você deve identificar a porta para o qual o programa de terceiros antivírus ou conteúdo filtragem encaminha email SMTP. Em seguida, você deve alterar a porta para o serviço SMTP.

Para identificar e alterar a porta, execute estas etapas:
  1. Verifique se os programas de terceiros estão sendo executados no servidor Exchange 2000 Server para proteção contra vírus de SMTP ou para filtragem de conteúdo.
  2. Desativar esses programas e inicie o servidor virtual SMTP. Para iniciar o servidor virtual SMTP, execute estas etapas:
    1. Inicie o Exchange System Manager.
    2. Expanda Administrative Groups , expanda Your_Administrative_Group e, em seguida, expanda Servers .
    3. Expanda Your_Exchange_Server_Name e, em seguida, expanda Protocols .
    4. Clique em servidor virtual SMTP padrão e, em seguida, clique em Iniciar .

      Observação Se o servidor virtual SMTP for iniciado, o programa de terceiros que foram desabilitados está bloqueando a porta padrão do SMTP. Nesse caso, feche o Exchange System Manager e conclua as etapas restantes descritas nesta seção.

      Se o servidor virtual SMTP não for iniciado, você deve seguir outros métodos de solução de problemas para resolver esse problema.
  3. Consulte a documentação do programa de terceiros ou o arquivo de Ajuda para identificar a porta à qual o programa encaminha email SMTP. Talvez seja necessário contactar o fabricante do produto para obter essas informações.
  4. Localize o arquivo de serviços.
    • No Microsoft Windows Server 2003, o arquivo de serviços é armazenado na seguinte pasta:
      %Systemroot%\WINDOWS\System32\Drivers\etc\Services
    • No Microsoft Windows 2000 Server, o arquivo de serviços é armazenado na seguinte pasta:
      %Systemroot%\WINNT\System32\Drivers\Etc\Services
  5. Use o bloco de notas para abrir o arquivo de serviços e, em seguida, localize as informações do serviço SMTP.

    Em um arquivo típico de serviços, entradas padrão aparecem na parte superior do arquivo. Em seguida, as entradas para cada serviço aparecem abaixo as entradas padrão. O seguinte texto é um exemplo de um arquivo serviços que inclui a entrada padrão para o serviço SMTP:
    # Copyright (c) 1993-1999 Microsoft Corp.
    #
    # This file contains port numbers for well-known services defined by IANA
    #
    # Format:
    #
    #<service name><port number>/<protocol> [aliases...] [#<comment>]
    #
    
    smtp 25/tcp mail #Simple Mail Transfer Protocol
  6. Altere a entrada do serviço SMTP conforme necessário. Por exemplo, se o programa de terceiros requer o serviço SMTP para escutar na porta 2525, altere a entrada de SMTP para o seguinte:

    email do SMTP 2525/tcp #Simple Mail Transfer Protocol
  7. Salve o arquivo e, em seguida, feche o Notepad.
  8. Use um dos seguintes métodos para reiniciar o serviço SMTP:
    • Reinicie o serviço SMTP do snap-in Serviços:
      1. Clique em Iniciar , clique em Executar , digite services.msc e, em seguida, clique em OK .
      2. Clique o serviço SMTP com o botão direito do mouse e clique em Reiniciar .
    • Reinicie o serviço SMTP em um prompt de comando:
      1. Abra um prompt de comando.
      2. Digite o seguinte comando e pressione ENTER:
        net stop smtpsvc && net start smtpsvc
      3. Digite exit e pressione ENTER.
    .
  9. Habilite os programas de terceiros que foram desabilitados na etapa 2.

Mais Informações

Para obter informações sobre o fabricante do hardware, visite o seguinte site:
http://support.microsoft.com/gp/vendors/en-us (http://support.microsoft.com/gp/vendors/en-us)
A Microsoft fornece terceiros informações de contatos para ajudá-lo a encontrar suporte técnico. Essa informações de contatos podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações contatos de terceiros.

Referências

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
173903  (http://support.microsoft.com/kb/173903/ ) Alterar a porta TCP que é usada para email SMTP

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange 2000 Server Standard Edition
Palavras-chave: 
kbmt kbtshoot kbprb KB907971 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 907971  (http://support.microsoft.com/kb/907971/en-us/ )