Oprava: Doplňky, inteligentní dokumenty nebo inteligentní značky, které lze vytvořit pomocí aplikace Microsoft Visual Studio 2005 nepracují v sadě Office

Překlady článku Překlady článku
ID článku: 908002 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Použijete-li vytvořit doplňky, inteligentní dokumenty nebo inteligentní značky Microsoft Visual Studio 2005, můžete zaznamenat následující příznaky:
  • Doplňky, inteligentní dokumenty nebo inteligentní značky Nelze načíst v libovolné aplikaci sady Microsoft Office.
  • Doplňky, inteligentní dokumenty nebo inteligentní značky Nespouštějte v libovolné verzi sady Microsoft Office.
K tomuto problému dochází, vytvoříte-li doplňky, inteligentní dokumenty nebo inteligentní značky v počítači, který má Microsoft.NET Framework 2.0 nainstalována.

Poznámka: K tomuto problému nedochází při přihlášení pomocí uživatelského účtu systému Microsoft Windows, s omezenými oprávněními.

Řešení

Aktualizace pro aplikaci Visual Studio 2005, která je popsána v tomto článku vám umožňuje distribuovat požadované opravy sady Office a.NET Framework řešení, které lze zadat v aplikaci Visual Studio 2005. Tato aktualizace přidává nové Sdílené Doplněk podpory aktualizace pro Microsoft.Rozhraní .NET Framework 2.0 (KB908002) možnost v seznamu požadavky sady Visual Studio 2005. Při vytváření nastavení projektu spravované doplněk, inteligentní dokument, nebo inteligentní značky je třeba povolit tuto možnost v nastavení projektu, který bude obsahovat požadované aktualizace redistributable Office a.Rozhraní .NET Framework.

Chcete-li vyřešit tento problém pro vývojáře sady Visual Studio 2005, je k dispozici Redistribuovatelná verze aktualizace pro aplikaci Visual Studio 2005.

Následující soubor je k dispozici pro stáhnout z centra pro stahování Microsoft Download Center:
Zmenšit tento obrázekZvětšit tento obrázek
Stáhnout
Stáhněte balíček VS2005-KB908002-ENU-x86.EXE.

Další informace o tom, jak stahovat soubory podpory společnosti Microsoft klepněte na následující číslo článku databáze Microsoft Knowledge Base:
119591 Jak získat soubory podpory společnosti Microsoft ze serverů služeb online
Byl zkontrolován na tento soubor neobsahuje viry. Společnost Microsoft použila aktuální antivirový software, který byl k dispozici na datum, kdy byla zaúčtována v souboru. Soubor je uložen na zabezpečených serverech neumožňujících neoprávněné změny souboru.

K instalaci této aktualizace pro aplikaci Visual Studio 2005 Doporučujeme tyto kroky:
  1. Balíček ke stažení lze uložte v počítači.
  2. Poklepejte na balíček ke stažení a spuštění balíčku.
  3. Čtení a poté přijměte licenční podmínky pro Software společnosti Microsoft.
Po instalaci této aktualizace je nutné zahrnout Sdílené Doplněk podpory aktualizace pro Microsoft.Rozhraní .NET Framework 2.0 (KB908002) Volba mezi požadavky v nastavení projektu řešení vždy, když vytvoříte sdílenou Přidat do projektu v aplikaci Visual Studio 2005. Chcete-li to provést, postupujte takto:
  1. V aplikaci Solution Explorer klepněte pravým tlačítkem myši na instalační projekt řešení a klepněte na tlačítko Vlastnosti.
  2. Klepněte na tlačítko Požadavky.
  3. Klepnutím vyberte Podpora doplňku Sdílené Aktualizace pro Microsoft.Rozhraní .NET Framework 2.0 (KB908002) Zaškrtávací políčko.
Poznámka: Je nutné povolit tento předpoklad odděleně pro obě ladění a Verze sestavení.

Poznámka: Tato aktualizace je nainstalována na jednotlivé uživatele. Tedy nainstalujte aktualizaci pro každý uživatelský účet, který vyžaduje aktualizaci.

Při vytváření projektu instalace sady Visual Studio 2005 bude redistributable aktualizace s projektu zahrňte do složky s názvem KB908002. Tato složka je umístěna v instalaci aplikace složka. Obsah složky KB908002, které jsou požadovány pro řešení instalace logiky pracovat správně. Soubor Setup.exe, který vytváří sady Visual Studio 2005 s nastavením Projekt bude instalace aktualizace do cílového počítače při řešení je nainstalován.

Poznámka: Na.NET Framework 2.0 a Instalační služba Microsoft Windows Installer 2.0 pro opravy správně nainstalována na cíl počítač.

Poznámka: Tento soubor MSI nemá žádné určení ALLUSERS. Proto po instalaci této soubor MSI je nainstalován soubor v uživatelský kontext uživatelská namísto jednotlivých počítačů.

Prohlášení

Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro".

Další informace

Kroky pro reprodukci problému

  1. Spusťte aplikaci Visual Studio 2005.
  2. Vytvoření sdílené doplněk. Chcete-li to provést, postupujte takto:
    1. V Soubor nabídky, klepněte na tlačítko Novýa klepněte na tlačítko Projekt.
    2. V Nový projekt Dialogové okno, klepněte na tlačítko Ostatní typy projektůa klepněte na tlačítko Rozšiřitelnost.
    3. Klepněte na tlačítko Sdílené doplněk, zadejte název do na Název pole a pak klepněte na tlačítko OK.
    4. Postupujte podle pokynů v Průvodci doplňku Sdílené a Vytvořte doplněk aplikace Microsoft Word.
  3. Vytvořte projekt. Chcete-li to provést, postupujte takto:
    1. V Projekt nabídky, klepněte na tlačítko YourProjectNameVlastnosti.
    2. V YourProjectName karta, klepněte na tlačítko Sestavenía klepněte na tlačítko Uvolnění v Konfigurace seznam.
    3. V Sestavení nabídky, klepněte na tlačítko Sestavení Řešení.
  4. V Soubor nabídky, klepněte na tlačítkoKonec Ukončete aplikaci Visual Studio.
  5. Zavést doplněk. Chcete-li to provést, postupujte takto:
    1. Klepněte na tlačítko Spustita klepněte na tlačítko Moje Dokumenty.
    2. Otevřete následující složku:
      Visual Studio 2005\Projects\YourProjectName\YourProjectNameSetup\Debug
      Ve výchozím nastavení je projekt, který jste vytvořili v kroku 3 uložena Složka aplikace Visual Studio 2005.
    3. Zkopírujte následující soubory na plochu na druhý počítač:
      • Soubor Setup.exe
      • YourProjectNameSetup.msi
    4. Poklepejte Soubor Setup.exe soubor, a Potvrďte výchozí nastavení.
  6. Spusťte aplikaci Microsoft Word.
  7. V Nástroje nabídky, klepněte na tlačítko Šablony a doplňky.
  8. Klepněte na tlačítko Přidat. Zobrazí chybová zpráva v do Doplňky modelu COM Dialogové okno.

Odkazy

Další informace získáte klepnutím na tlačítko naleznete v následujících článcích znalostní báze společnosti Microsoft:
907417Popis aktualizace pro sadu Office 2003: 8. listopadu 2005
Poznámka: Aktualizace, která je popsána v článku znalostní báze Microsoft Knowledge Base 907417 umožňuje koncovým uživatelům sady Office 2003, opravit pouze Otkloadr.dll problém. V článku neřeší problém Extensibility.dll nebo verze sady Office, která se liší od sady Office 2003.

Další informace získáte klepnutím na tlačítko naleznete v následujících článcích znalostní báze společnosti Microsoft:
908003Oprava: Office 2003 dojde při pokusu o zavření dokumentu aplikace Word nebo tabulky aplikace Excel z ovládacího prvku WinForm v aplikaci Visual Studio Tools pro řešení systému Office verze 2003
908004 Oprava: Nelze spustit vlastní nastavení, která byla vytvořena v sada Microsoft Visual Studio Tools for the Microsoft Office System verze 2003

Vlastnosti

ID článku: 908002 - Poslední aktualizace: 22. května 2011 - Revize: 6.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft .NET Framework 2.0
  • Microsoft Visual Studio 2005 Tools for the Microsoft Office System
  • Microsoft Visual Studio 2005 Standard Edition
  • Microsoft Visual Studio 2005 Professional Edition
  • Microsoft Office 97 Standard Edition
  • Microsoft Office Professional 2007
  • Microsoft Office Standard 2007
Klíčová slova: 
kbnofix kbbug kbtshoot kbmt KB908002 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:908002

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com