Internet Explorer 6 no puede utilizar el protocolo de autenticación Kerberos para conectarse a un sitio Web que utiliza un puerto no estándar en Windows XP y en Windows Server 2003

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Id. de artículo: 908209 - Ver los productos a los que se aplica este artículo
Importante Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de que hacer una copia de seguridad del registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows
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Síntomas

Tenga en cuenta la situación siguiente:
  • El equipo está ejecutando uno de los sistemas operativos siguientes:
    • Windows XP
    • Windows Server 2003
  • El equipo tiene instalados los servicios de Internet Information Server (IIS).
  • Tiene dos sitios Web que tienen diferentes puertos y las identidades. Estos dos sitios Web están en ejecución en el mismo equipo. Por ejemplo, sitio Web 1 se ejecuta en el puerto 80 con identidad "id1" y 2 de sitio Web se ejecuta en el puerto 81 bajo la identidad "id2 ?.
  • Tanto los sitios Web utilizan Kerberos versión 5 del protocolo de autenticación.
  • Utilice la utilidad Setspn para declarar el nombre principal de servicio (SPN) para el sitio Web 2.
  • Utilizar el mismo nombre de host para conectar al sitio Web 1 y al sitio Web 2. Utilice Windows Internet Explorer 6 o una versión posterior para realizar esta conexión.

    Por ejemplo, utilizar http://examplewebserver para conectarse al sitio Web 1 y http://examplewebserver:81 para conectarse al sitio Web 2. En este ejemplo, utilice el mismo nombre de host examplewebserver para conectarse a ambos sitios Web.
En esta situación, Internet Explorer puede utilizar el protocolo Kerberos para conectarse al sitio Web 1. Sin embargo, Internet Explorer no puede utilizar el protocolo Kerberos para conectarse al sitio Web de 2.

Causa

Este problema se produce porque el archivo Wininet.dll no pasa el número de puerto del sitio Web de destino cuando llama a la función InitializeSecurityContext para generar el vale Kerberos. Esto impide que Internet Explorer 6 utilizando el protocolo Kerberos para conectarse a varios sitios Web que se ejecutan en distintos puertos bajo identidades diferentes.

Solución

Nota Si estás utilizando Windows Internet Explorer 7 o Windows Internet Explorer 8, todavía puede encontrarse con este problema. Sin embargo, para resolver el problema, no es necesario instalar una actualización de software. En su lugar, siga las instrucciones que aparecen en la "sección de para agregar una clave del registro.

Internet Explorer 6 en Windows XP

Información de revisiones

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Esta revisión sólo se aplican a los sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con los servicios de cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no reúnan las condiciones necesarias para esta revisión en cuestión. Para obtener una lista completa de números de teléfono de Microsoft servicios de soporte técnico y de asistencia al cliente o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
No hay requisitos previos.
Información del registro
Para aplicar este hotfix, debe crear una clave del registro. Para ello, vaya a la sección "Post-hotfix installation instructions".
Requisito de reinicio
Una vez aplicado este hotfix, debe reiniciar el equipo.
Información acerca de la sustitución de la revisión
Este hotfix no sustituye a otros hotfix.
Información de archivo
La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Wininet.dll6.0.2900.2905664,06410 De mayo de 200614: 35x 86

Internet Explorer 6 en Windows Server 2003

Información de Service Pack

Para resolver este problema, obtenga el service pack más reciente para Windows Server 2003. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
889100Cómo obtener la versión más reciente del Service Pack para Windows Server 2003

Información de revisiones

Requisitos previos
No hay requisitos previos.
Información del registro
Para aplicar este hotfix, debe crear una clave del registro. Para ello, vaya a la sección "Post-hotfix installation instructions".
Requisito de reinicio
Una vez aplicado este hotfix, debe reiniciar el equipo.
Información acerca de la sustitución de la revisión
Este hotfix no sustituye a otros hotfix.
Información de archivo
La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en el elemento fecha y hora en el panel de control.
Windows Server 2003, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Wininet.dll6.0.3790.26991,703,93610 De mayo de 200605: 48IA-64SP1SP1QFE
Wwininet.dll6.0.3790.2699665,60010 De mayo de 200605: 48x 86SP1¡ VAYA
Windows Server 2003, versiones de 64 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Wininet.dll6.0.3790.26991,189,88810 De mayo de 200605: 48x 64SP1SP1QFE
Wwininet.dll6.0.3790.2699665,60010 De mayo de 200605: 48x 86SP1¡ VAYA
Windows Server 2003, versiones basadas en 86 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Wininet.dll6.0.3790.2699665,60010 De mayo de 200607: 41x 86

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o mediante cualquier otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Instrucciones de instalación de hotfix posterior

Nota Estos pasos deben ser aplicados en el equipo cliente en el que intenta abrir la página Web.

Después de instalar la revisión, debe agregar la clave del registro de
FEATURE_INCLUDE_PORT_IN_SPN_KB908209
y, a continuación, establezca su valor DWORD para iexplore.exe. Para ello, siga estos pasos.

Para los equipos de 32 bits

  1. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit y, a continuación, haga clic en Aceptar.
  2. En el panel izquierdo, busque y haga clic en la siguiente subclave del registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. En el menú Edición, seleccione nuevo y, a continuación, haga clic en clave.
  4. Escriba FEATURE_INCLUDE_PORT_IN_SPN_KB908209 y, a continuación, presione ENTRAR.
  5. En el menú Edición, seleccione nuevo y, a continuación, haga clic en Valor DWORD.
  6. Escriba iexplore.exe y, a continuación, presione ENTRAR.
  7. En el menú Edición, haga clic en Modificar.
  8. Escriba 1 en el cuadro información del valor y, a continuación, haga clic en Aceptar.
  9. Salir del Editor del registro.

Para los equipos de 64 bits

  1. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit y, a continuación, haga clic en Aceptar.
  2. En el panel izquierdo, busque y haga clic en la siguiente subclave del registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Internet Explorer\Main\FeatureControl
  3. En el menú Edición, seleccione nuevo y, a continuación, haga clic en clave.
  4. Escriba FEATURE_INCLUDE_PORT_IN_SPN_KB908209 y, a continuación, presione ENTRAR.
  5. En el menú Edición, seleccione nuevo y, a continuación, haga clic en Valor DWORD.
  6. Escriba iexplore.exe y, a continuación, presione ENTRAR.
  7. En el menú Edición, haga clic en Modificar.
  8. Escriba 1 en el cuadro información del valor y, a continuación, haga clic en Aceptar.
  9. Salir del Editor del registro.
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 908209 - Última revisión: miércoles, 10 de febrero de 2010 - Versión: 5.0
La información de este artículo se refiere a:
  • Microsoft Internet Explorer 6.0 sobre las siguientes plataformas
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Web Edition
  • Windows Internet Explorer 7
  • Windows Internet Explorer 8
Palabras clave: 
kbmt kbautohotfix kbwinserv2003sp2fix kbwinxpsp3fix kbwinxppresp3fix kbwinserv2003presp2fix kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB908209 KbMtes
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IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 908209

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