Puede recibir un mensaje de error "Detener 0x0000000A" cuando un procesador se reanuda desde un estado de inactividad C1

En este artículo se proporciona una solución alternativa para el mensaje de error "Detener 0x0000000A" cuando un procesador se reanuda desde un estado de inactividad C1.

Se aplica a: Windows Server 2003
Número de KB original: 908369

Síntomas

Cuando un procesador de un equipo basado en Microsoft Windows Server 2003 se reanuda desde un estado de inactividad C1, el equipo puede dejar de responder. Además, puede experimentar uno o varios de los síntomas siguientes:

  • El equipo se reinicia automáticamente.

  • Después de iniciar sesión, recibirá el siguiente mensaje de error:

    Microsoft Windows
    El sistema se ha recuperado de un error grave.
    Se ha creado un registro de este error.
    Informe a Microsoft sobre este problema.
    Hemos creado un informe de errores que puede enviar para ayudarnos a mejorar Microsoft Windows. Trataremos este informe como confidencial y anónimo.
    Para ver qué datos contiene este informe de errores, haga clic aquí.

    Si el mensaje de error sigue apareciendo y desea ver los datos que contiene el informe de errores, haga clic en el vínculo Haga clic aquí en la parte inferior del cuadro de mensaje. A continuación, verá información de firma de error similar a la siguiente:

    BCCode : 0000000A BCP1 : 0f6ff8c0 BCP2 : 000000ff BCP3 : 00000000 BCP4 : 8074867e OSVer : 5_2_3718 SP : 0_0 Producto : 272_3

  • Recibirá el siguiente mensaje de error "Detener" en una pantalla azul:

    Se ha detectado un problema y Windows se ha apagado para evitar daños en el equipo.
    Información técnica:
    STOP: 0x0000000A (0x0f6ff8c0, 0x000000ff, 0x00000000, 0x8074867e)
    IRQL_Not_Less_Or_Equal

  • Se registra un mensaje de error similar al siguiente en el registro de eventos del sistema:

    Fecha: fecha
    Origen: System ErrorTime: time
    Categoría: (102)
    Escriba: Error
    Id. de evento: 1003
    Usuario: N/A
    Equipo: equipo
    Descripción: código de error 0000000A, parameter1 0f6ff8c0, parameter2 000000ff, parameter3 00000000, parameter4 8074867e. Para obtener más información, vea Centro de ayuda y soporte técnico al https://support.microsoft.com.Data:0000: 53 79 73 74 65 6d 20 45 System E0008: 72 72 6f 72 20 20 45 72 rror Er0010: 72 6f 72 20 63 6f 64 65 ror code0018: 20 30 30 30 30 30 30 35 00000 0A0020: 30 20 20 50 61 72 61 6d 0 Param0028: 65 74 65 72 73 20 66 66 eters ff0030: 66 66 66 66 64 31 2c

Nota:

  • Los síntomas de un error "Detener" varían según las opciones de error del sistema del equipo. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base: 307973 Configuración de las opciones de error y recuperación del sistema en Windows.
  • Los cuatro parámetros que se incluyen en la información de firma de error varían según la configuración del equipo.
  • No todos los errores de "Detener 0x0000000A" se deben al problema que describe este artículo.

Causa

Este problema se produce debido a un error de procesador en algunas CPU.

Los bytes de instrucciones se leen en la memoria caché de instrucciones en bloques de tamaño fijo (líneas de caché). Cuando los bytes que componen una instrucción cruzan un límite de línea de caché, los bytes de instrucción ocupan varias líneas de caché adyacentes. Si se produce un error específico del procesador, el procesador puede leer en la segunda parte de la instrucción de la línea de caché incorrecta para su ejecución. Este comportamiento provoca una instrucción incorrecta.

El archivo Ntkrnlmp.exe que se incluye en la revisión 840987 incluye una secuencia de instrucciones que revelan este error.

Nota:

Este problema solo se produce cuando el procesador controla una interrupción entre procesadores (IPI) que hace que el procesador se reanude desde el estado de inactividad C1.

Solución alternativa

Importante

Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. En consecuencia, asegúrese de seguir estos pasos cuidadosamente. Para mayor protección, cree una copia de seguridad del registro antes de modificarlo. Después, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Hacer una copia de seguridad del Registro y restaurarlo en Windows

Para solucionar este problema, evite que el procesador entre en el estado de inactividad C1. Para ello, siga estos pasos:

  1. Inicie el Editor del Registro. Para ello, haga clic en Inicio, en Ejecutar, escriba regedt32y, a continuación, haga clic en Aceptar.

  2. Busque la siguiente subclave del Registro y haga clic en ella: HKEY_LOCAL_MACHINE\System\CurrentControlset\Control\Session Manager\Power

  3. Haga clic en Editar, seleccione Nuevo, haga clic en Valor DWORD y, a continuación, escriba IdleFrom0IdlePercent.

  4. Haga clic con el botón derecho en IdleFrom0IdlePercenty, a continuación, haga clic en Modificar. En el cuadro de diálogo Editar valor DWORD , escriba un número superior a 100 en el cuadro Datos de valor , haga clic en Decimal en Basey, a continuación, haga clic en Aceptar.

    Nota:

    Las dos subclaves del Registro siguientes controlan cuando Windows hace que el procesador escriba un estado de inactividad C1: HKEY_LOCAL_MACHINE\System\CurrentControlset\Control\Session Manager\Power\IdleFrom0DelayHKEY_LOCAL_MACHINE\System\CurrentControlset\Control\Session Manager\Power\IdleFrom0IdlePercent
    Por ejemplo, suponga que ha establecido el valor IdleFrom0IdlePercent en 10 y el valor IdleFrom0Delay en 5. En este caso, el sistema debe estar 10 por ciento inactivo durante un período de 5 microsegundos antes de que la CPU entre en el estado de inactividad C1. Por lo tanto, si establece el valor IdleFrom0IdlePercent en un número superior a 100, la CPU nunca entrará en el estado de inactividad C1.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "Se aplica a".