Artigo: 908370 - Última revisão: segunda-feira, 3 de Dezembro de 2007 - Revisão: 3.4

Um controlador de domínio com o Microsoft Windows Server 2003 poderá deixar de responder durante 2 a 15 minutos várias vezes por dia

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

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controlador de domínio A do que está a executar o Microsoft Windows Server 2003 poderá deixar de responder durante 2 a 15 minutos várias vezes por dia.

Poderá ser responder uma sessão SMB (Server Message Block) quando o utilizador de um computador cliente tenta procurar ficheiros ou abrir ficheiros numa rede. O problema afecta todos os computadores clientes ao mesmo tempo. O problema também poderá ocorrer quando tenta procurar ficheiros no servidor utilizando um caminho de convenção de nomenclatura universal (UNC, Universal Naming Convention).

Quando este problema ocorre, pode ver numa localização partilhada na rede utilizando uma janela da linha de comandos. O servidor utiliza não existem recursos mais do que o habitual.

Sintomas

Num domínio baseado no Windows Server 2003, detecta um ou mais dos seguintes problemas num computador cliente com o Microsoft Windows Server 2003, Microsoft Windows XP ou Microsoft Windows 2000:
  • Não é possível iniciar sessão ou mapear unidades de rede para o servidor. Se tiver iniciado com êxito, não poderá aceder itens partilhados na rede utilizando o Explorador do Windows.
  • Os programas no computador cliente são responder. Por exemplo, folhas de cálculo do Excel podem demorar mais do que é habitual de 2 minutos a responder através da rede.
  • Quando tenta ligar ao servidor, receberá uma das seguintes mensagens de erro.

    mensagem 1
    Erro de sistema 53: Não foi encontrado o caminho de rede. (ERROR_BAD_NETPATH)
    mensagem 2
    Erro de sistema 64: O nome de rede especificado já está disponível. (ERROR_NETNAME_DELETED)
    mensagem 3
    Erro de sistema 67: Não é possível encontrar o nome de rede. (ERROR_BAD_NET_NAME)
  • O servidor deixa de responder várias vezes por dia. O sistema não pode processar qualquer pedido de rede baseadas em SMB. No entanto, o problema é temporariamente resolvido quando o servidor é reiniciado.
  • Quando tenta aceder a recursos (DFS) partilhada no servidor, o serviço de DFS deixa de responder.
  • O servidor deixa de responder até é reiniciado o serviço de DFS. Quando este problema ocorre, ficheiros abertos no computador cliente também parar a responder.
O recurso partilhado não tem de ser um recurso partilhadas de DFS para estes problemas ocorram.

Quando este problema ocorre, os computadores que executem o Windows XP Professional ou Windows Server 2003 poderão registar entradas semelhantes à seguinte no registo de aplicações. No entanto, poderão ser registadas sem entradas.

mensagem 1

Tipo de evento: erro
Origem do evento: Userenv
ID do evento: 1058
Descrição:
Não é possível ao Windows aceder ao ficheiro gpt.ini do GPO CN = {31B2F340-D-11 D 2-945F-00C04FB984F9}, CN = Policies, CN = System, DC = <DomainName>, DC = <TopLevelDomain>. O ficheiro tem de estar presente na localização <\\DomainName.com\sysvol\DomainName.com\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\gpt.ini>. (Informações de configuração não foi possível ler a partir do controlador de domínio, ou porque o computador não está disponível ou o acesso foi negado.). Política de grupo processamento abortado.

mensagem 2

Tipo de evento: erro
Origem do evento: Userenv
Categoria do evento: nenhum
ID do evento: 1030
Descrição:
Windows não consegue consultar a lista de objectos de política de grupo. Uma mensagem que descreve o motivo foi previamente registada pelo motor de política.

Normalmente, computadores clientes e servidores membro registar estes eventos no arranque se a condição de erro já existe.

Causa

Estes problemas ocorrem devido a um problema com o proxy H.323/Lightweight Directory Access Protocol (LDAP). Este problema ocorre quando (network address translation) impede que pedidos LDAP atingir serviços no servidor de domínio.

Resolução

Para resolver este problema, siga estes passos:
  1. Se o Windows Server 2003 tem placa de rede equipas de software instalado, desinstale o software de equipas de placas de rede e, em seguida, actualize o controlador da placa de rede para a versão mais recente. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    843156  (http://support.microsoft.com/kb/843156/ ) Recebe um "sistema 67 erro. Mensagem de erro não é possível encontrar o nome de rede"no Windows Server 2003
  2. Instale o Microsoft Windows Server 2003 Service Pack 1 (SP1) no controlador de domínio. Se não é possível aplicar o Service Pack 1, siga os passos na secção "Como contornar".
notas
  • Estes passos poderão não resolver o problema mencionado na secção "Sintomas" Se não instalarem o Windows Server 2003 SP1 antes de instalar e configurar o serviço Encaminhamento e acesso remoto e o serviço de tradução (NAT, Network Address TRANSLATION) de endereço de rede no controlador de domínio. Se instalar o Windows Server 2003 SP1 depois do serviço Encaminhamento e acesso remoto e o serviço NAT, siga os passos na secção "Como contornar".
  • Poderá ocorrer um problema semelhante em que o serviço de DFS num servidor baseado no Windows Server 2003 deixa de responder durante aproximadamente 10 minutos. Quando este problema ocorre, o DFS partilhado parar recursos responder aos pedidos de utilizador. Se o servidor DFS for membro de um domínio baseado no Microsoft Windows NT 4.0, siga os passos do artigo da base de dados de conhecimento da 810418 para resolver o problema. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    810418  (http://support.microsoft.com/kb/810418/ ) Desactivar o reconhecimento de site para o Windows Server 2003 ou para DFS do Windows 2000 num domínio do Windows NT 4.0

Como contornar

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar uma cópia de segurança e restaurar o registo no Windows


Para contornar este problema, utilize um dos seguintes métodos.

Nota Estes métodos pressupõem as seguintes condições:
  • O controlador de domínio com o Windows Server 2003.
  • O controlador de domínio está a funcionar como um servidor de ficheiros e como um servidor de impressão.
  • O controlador de domínio não tem o Windows Server 2003 Service Pack 1 instalado.
  • O controlador de domínio está a executar um ou mais dos seguintes procedimentos:
    • Firewall de ligação À Internet (ICF) / partilha de ligação À Internet (ICS)
    • Encaminhamento e acesso remoto (RRAS, Routing and Remote)

Método 1: Reiniciar o serviço de DFS

Reinicie o serviço de sistema de ficheiros distribuído (DFS). Para o fazer, siga estes passos:
  1. Clique em Iniciar , clique em Executar , escreva cmd e, em seguida, clique em OK .
  2. Escreva net stop DFS e, em seguida, prima ENTER.
  3. Escreva net start DFS e, em seguida, prima ENTER.
Nota O Active Directory requer o serviço DFS para que os clientes podem localizar o recurso SYSVOL partilhado. Por conseguinte, o serviço de DFS tem que executar em cada controlador de domínio. Num ambiente com mais do que um controlador de domínio, não pare o serviço de DFS sem reiniciar o serviço.

Método 2: Parar Firewall de ligação À Internet, a partilha de ligação À Internet e o encaminhamento e acesso remoto

Pare os seguintes serviços:
  • Firewall de ligação À Internet (ICF) / partilha de ligação À Internet (ICS)
  • Encaminhamento e acesso remoto (RRAS, Routing and Remote)
Nota Se estes serviços não estão desactivados por predefinição, utilize o método 5.

Método 3: Desactivar o controlador IP NAT

Se tradução de endereços de rede (NAT) não está correctamente configurada, poderá conseguir contornar este problema desactivando o controlador IP NAT. Para o fazer, siga estes passos:
  1. Clique em Iniciar , clique com o botão direito do rato em meu computador e, em seguida, clique em Propriedades .
  2. Clique no separador hardware , clique em Gestor de dispositivos e, em seguida, clique em Mostrar dispositivos ocultos no menu Ver .
  3. Faça duplo clique controladores não Plug and Play e, em seguida, faça duplo clique sobre Tradução de endereços de rede IP .
  4. Clique no separador controlador , clique em Parar e, em seguida, clique em OK .
  5. Reinicie o computador.
Para obter mais informações sobre como utilize o registo para desactivar o controlador IP NAT, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
816071  (http://support.microsoft.com/kb/816071/ ) Como desactivar temporariamente o controlador de filtro de modo kernel do Windows

Método 4: Desactivar NAT/Firewall básico

  1. Clique em Iniciar , aponte para Todos os programas , aponte para Ferramentas administrativas e, em seguida, clique em Encaminhamento e acesso remoto .
  2. Faça duplo clique em Server name, faça duplo clique em Encaminhamento IP e, em seguida, clique em NAT/Firewall básico .
  3. No painel da direita, clique com o botão direito do rato no nome de interface do interface privada ligada a interface de rede privada, ou clique com o botão direito do rato a interface pública que está ligada à interface da Internet e, em seguida, clique em Eliminar .
  4. Repita o passo 3 para todas as interfaces onde uma interface privada está ligada a uma interface de rede privada ou onde a interface pública está ligada à interface da Internet.
  5. Reinicie o serviço Encaminhamento e acesso remoto.
Se um servidor de encaminhamento e acesso remoto separa a rede de cliente e um router de DSL (Digital Subscriber Line), poderá ter de efectuar mais passos para que os computadores cliente mantém a ligação à Internet. Tem de configurar também correctamente a encaminhamento entre o Windows Small Business Server e o router DSL. Para efectuar este procedimento, certifique-se que o router DSL tem uma rota estática à rede do cliente.Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
837453  (http://support.microsoft.com/kb/837453/ ) Como utilizar o encaminhamento do Windows Server 2003 e serviço de acesso remoto ou o ISA Server 2004 com um router DSL para acesso à Internet

Método 5: Desactivar o proxy H.323/LDAP

Se necessitar de activar NAT, Network Address TRANSLATION uma vez que actua como uma bridge de rede entre o adaptador de rede rede local e um adaptador de rede da Internet, desactive proxy H.323/LDAP definindo a subchave do registo
EnableH323Proxy
como 0 (zero). Para o fazer, siga estes passos:
  1. Se a actualização de 835732 segurança não está instalada, instale esta actualização de segurança. Para obter mais informações sobre a actualização de 835732 segurança, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    835732  (http://support.microsoft.com/kb/835732/ ) MS04-011: Actualização de segurança para Microsoft Windows
  2. Siga estes passos para adicionar a subchave do registo
    EnableH323Proxy
    ao registo:
    1. Localize e com o botão direito do rato na seguinte subchave do registo:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters
    2. Aponte para Novo , clique em Valor DWORD (DWORD Value) e, em seguida, escreva EnableH323Proxy .
    3. Clique com o botão direito do rato EnableH323Proxy , clique em Modificar e, em seguida, escreva 0 na caixa dados do valor .
  3. Reinicie o computador.
  4. Active o firewall do Windows.
Nota No Windows Server 2003 com Service Pack 1, o proxy H.323/LDAP foi removido do Firewall de ligação À Internet, partilha de ligação À Internet e o encaminhamento e acesso remoto.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

O "Internet ligação firewall (ICF) / Internet ligação à partilha de serviço (ICS)" (Service_Name: SharedAccess) fornece os seguintes serviços para uma rede de escritório doméstico ou uma rede de pequeno escritório:
  • Tradução de endereços de rede
  • Endereçamento
  • Resolução de nomes
  • Prevenção de intrusões
Para fins de diagnóstico, pode activar o registo expandido de LDAP. Quando este problema ocorre, poderá ser registado 1216 evento se as seguintes condições forem verdadeiras:
  • O sistema está configurado para utilizar o registo expandido de NTDS (NTDS Settings).
  • O nível de registo de eventos da interface LDAP é definido como um valor de 4 utilizando a seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Diagnostics
Quando é registado o evento 1216, poderá ver uma entrada semelhante à seguinte no Visualizador de eventos:

Tipo de evento: aviso
Origem do evento: LDAP de NTDS (NTDS Settings)
Categoria do evento: Interface LDAP
ID do evento: 1216
Descrição:
Evento interno: ligação de cliente de LDAP foi fechada devido a um erro.
ID do cliente: 11387

Dados adicionais
Erro valor: 995 E/s A operação foi cancelada devido a uma saída de thread ou a um pedido de aplicação.
ID interno: c0602ec

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
816071  (http://support.microsoft.com/kb/816071/ ) Como desactivar temporariamente o controlador de filtro de modo kernel do Windows

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows 2000 Professional Edition
Palavras-chave: 
kbmt kbtshoot kbprb KB908370 KbMtpt
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