ID do artigo: 908370 - Última revisão: segunda-feira, 3 de dezembro de 2007 - Revisão: 3.4

Um controlador de domínio que está executando o Microsoft Windows Server 2003 pode parar de responder por 2 a 15 minutos várias vezes ao dia

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

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controlador de domínio A da que está executando o Microsoft Windows Server 2003 pode parar de responder por 2 a 15 minutos várias vezes ao dia.

Uma sessão SMB (Server Message Block) pode ficar sem resposta quando o usuário de um computador cliente tenta para procurar arquivos ou para abrir arquivos em uma rede. O problema afeta todos os computadores cliente ao mesmo tempo. O problema também pode ocorrer quando você tenta procurar arquivos no servidor usando um caminho UNC (convenção de nomenclatura universal).

Quando esse problema ocorre, você pode exibir um local compartilhado na rede usando uma janela do prompt de comando. O servidor usa não mais recursos que o normal.

Sintomas

Em um domínio baseado no Windows Server 2003, você enfrentar um ou mais dos seguintes problemas em um computador cliente que esteja executando o Microsoft Windows Server 2003, Microsoft Windows XP ou Microsoft Windows 2000:
  • Não é possível fazer logon ou mapear unidades de rede para o servidor. Se você tenha efetuado com êxito, você não poderá acessar itens compartilhados na rede usando o Windows Explorer.
  • Os programas no computador cliente são responder. Por exemplo, planilhas do Excel podem levar 2 minutos mais comum para responder através da rede.
  • Quando você tenta se conectar ao servidor, você receber uma das seguintes mensagens de erro.

    mensagem 1
    Erro de sistema 53: O caminho da rede não foi encontrado. (ERROR_BAD_NETPATH)
    mensagem 2
    Erro do sistema 64: O nome de rede especificado não está mais disponível. (ERROR_NETNAME_DELETED)
    mensagem 3
    Erro do sistema 67: O nome de rede não encontrado. (ERROR_BAD_NET_NAME)
  • O servidor responder várias vezes ao dia. O sistema não pode processar qualquer solicitação de rede baseada em SMB. No entanto, o problema é resolvido temporariamente quando o servidor for reiniciado.
  • Quando você tentar acessar recursos de arquivo sistema distribuídos (DFS) compartilhada no servidor, o serviço DFS pára de responder.
  • O servidor pára de responder até que o serviço DFS seja reiniciado. Quando esse problema ocorre, arquivos abertos no computador cliente também parar de responder.
O recurso compartilhado não precisa ser um recurso compartilhado de DFS para esses problemas ocorram.

Quando esse problema ocorre, os computadores que executam o Windows XP Professional ou Windows Server 2003 podem fazer entradas semelhantes à seguinte no log do aplicativo. No entanto, nenhuma entrada pode ser registrada.

mensagem 1

Tipo de evento: erro
Origem do evento: Userenv
IDENTIFICAÇÃO de evento: 1058
Descrição:
Windows não pode acessar o arquivo gpt.ini para GPO CN = {31B2F340-D-11 D 2-945F-00C04FB984F9}, CN = Policies, CN = System, DC = <DomainName>, DC = <TopLevelDomain>. O arquivo deve estar presente no local <\\DomainName.com\sysvol\DomainName.com\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\gpt.ini>. (Informações de configuração não puderam ser lidas do controlador de domínio, porque o computador não está disponível ou o acesso foi negado.). Diretiva de grupo processamento anulado.

mensagem 2

Tipo de evento: erro
Origem do evento: Userenv
Categoria do evento: nenhum
IDENTIFICAÇÃO de evento: 1030
Descrição:
O Windows não pode consultar a lista de objetos de diretiva de grupo. Uma mensagem que descreve o motivo para isso foi registrada anteriormente pelo mecanismo de diretiva.

Normalmente, computadores clientes e servidores membro fazer esses eventos na inicialização se a condição de erro já existe.

Causa

Esses problemas ocorrem devido a um problema com o proxy de LDAP (H.323/Lightweight Directory Access Protocol). Esse problema ocorre quando (network address translation) impede que solicitações LDAP alcance serviços no servidor do domínio.

Resolução

Para resolver esse problema, execute essas etapas:
  1. Se Windows Server 2003 tem adaptador de rede agrupamento software instalado, desinstale o software de agrupamento de adaptador de rede e, em seguida, atualizar o driver do adaptador de rede para a versão mais recente. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    843156  (http://support.microsoft.com/kb/843156/ ) Você receberá um "67 erro de sistema. Mensagem de erro o nome da rede não pode ser encontrado"no Windows Server 2003
  2. Instale o Microsoft Windows Server 2003 Service Pack 1 (SP1) no controlador de domínio. Se você não pode aplicar o Service Pack 1, execute as etapas na seção "Solução".
anotações
  • Essas etapas não podem resolver o problema mencionado na seção "Sintomas" Se você não instalar o Windows Server 2003 SP1 antes de você instala e configurar o serviço Roteamento e acesso remoto e o serviço NAT (conversão) do endereço de rede no controlador de domínio. Se você instalar o Windows Server 2003 SP1 após o serviço Roteamento e acesso remoto e o serviço NAT, siga as etapas na seção "Solução".
  • Pode ocorrer um problema semelhante no qual o serviço DFS em um servidor baseado no Windows Server 2003 pára de responder por aproximadamente 10 minutos. Quando esse problema ocorre, o DFS compartilhada parada recursos responder às solicitações do usuário. Se o servidor DFS é um membro de um domínio baseado no Microsoft Windows NT 4.0, execute as etapas no artigo do Knowledge Base 810418 para resolver o problema. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    810418  (http://support.microsoft.com/kb/810418/ ) Desativar o reconhecimento de site para Windows Server 2003 ou Windows 2000 DFS em um domínio do Windows NT 4.0

Como Contornar

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows


Para contornar este problema, use um dos seguintes métodos.

Observação Esses métodos presumem que as seguintes condições:
  • O controlador de domínio está executando o Windows Server 2003.
  • O controlador de domínio está operando como um servidor de arquivos e como um servidor de impressão.
  • O controlador de domínio não tem o Windows Server 2003 1 instalado.
  • O controlador de domínio é executando um ou mais das seguintes opções:
    • Firewall de conexão com a Internet (ICF) /compartilhamento (ICS) de conexão com a Internet
    • Roteamento e acesso remoto (RRAS)

Método 1: Reiniciar o serviço DFS

Reinicie o serviço de sistema de arquivos distribuídos (DFS). Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar , clique em Executar , digite cmd e, em seguida, clique em OK .
  2. Digite net stop DFS e, em seguida, pressione ENTER.
  3. Digite net start DFS e, em seguida, pressione ENTER.
Observação O Active Directory requer o serviço DFS para que os clientes possam localizar o recurso compartilhado SYSVOL. Portanto, o serviço DFS deve ser executado em cada controlador de domínio. Em um ambiente com mais de um controlador de domínio, não pare o serviço DFS sem reiniciar o serviço.

Método 2: Parar firewall de conexão com a Internet, compartilhamento de conexão com a Internet e roteamento e acesso remoto

Pare os serviços a seguir:
  • Firewall de conexão com a Internet (ICF) /compartilhamento (ICS) de conexão com a Internet
  • Roteamento e acesso remoto (RRAS)
Observação Se esses serviços não são desativados por padrão, use o método 5.

Método 3: Desativar o driver de IP NAT

Se a conversão de endereços de rede (NAT) não está configurado corretamente, você poderá solucionar esse problema desativando o driver de IP NAT. Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar , clique com o botão direito em Meu computador e, em seguida, clique em Propriedades .
  2. Clique na guia hardware , clique em Gerenciador de dispositivos e, em seguida, clique em Mostrar dispositivos ocultos , no menu Exibir .
  3. Clique duas vezes em drivers não Plug and Play e clique duas vezes em Conversor de endereços de rede IP .
  4. Clique na guia driver , clique em Parar e, em seguida, clique em OK .
  5. Reinicie o computador.
Para obter mais informações sobre como use o registro para desativar o driver de IP NAT, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
816071  (http://support.microsoft.com/kb/816071/ ) Como desativar temporariamente o driver de filtro do modo kernel no Windows

Método 4: Desativar NAT/Firewall básico

  1. Clique em Iniciar , aponte para Todos os programas , aponte para Ferramentas administrativas e, em seguida, clique em roteamento e acesso remoto .
  2. Clique duas vezes em Server name, clique duas vezes em Roteamento IP e, em seguida, clique em NAT/Firewall básico .
  3. No painel direito, clique com o botão direito do mouse o nome de interface da interface privada conectada à interface de rede privada, ou clique com o botão direito do mouse a interface pública que é conectada à interface da Internet e em seguida, clique em Excluir .
  4. Repita a etapa 3 para todas as interfaces em que uma interface privada está conectada a uma interface de rede privada ou em que a interface pública está conectada à interface da Internet.
  5. Reinicie o serviço Roteamento e acesso remoto.
Se um servidor de roteamento e acesso remoto separa a rede de cliente e um roteador DSL (linha de assinante digital), talvez seja necessário executar etapas mais para que os clientes mantenham conectividade com a Internet. Você deve configurar também corretamente o roteamento entre o Windows Small Business Server e um roteador DSL. Para fazer isso, verifique se o roteador DSL tem uma rota estática à rede do cliente.Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
837453  (http://support.microsoft.com/kb/837453/ ) Como usar o roteamento do Windows Server 2003 e RAS ou ISA Server 2004 com um roteador DSL para acesso à Internet

Método 5: Desativar o proxy H.323/LDAP

Se o NAT deve ser ativado porque ele atua como uma ponte de rede entre o adaptador de rede LAN e um adaptador de rede da Internet, desative o proxy H.323/LDAP, definindo a subchave de registro
EnableH323Proxy
como 0 (zero). Para fazer isso, execute as seguintes etapas:
  1. Se a atualização de 835732 segurança não é instalada, instale esta atualização de segurança. Para obter mais informações sobre a atualização de 835732 segurança, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    835732  (http://support.microsoft.com/kb/835732/ ) MS04-011: Actualização de segurança para Microsoft Windows
  2. Siga estas etapas para adicionar a subchave de registro
    EnableH323Proxy
    ao registro:
    1. Localize e com o botão direito do mouse na seguinte subchave do Registro:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters
    2. Aponte para novo , clique em Valor DWORD e, em seguida, digite EnableH323Proxy .
    3. Clique com o botão direito do mouse EnableH323Proxy , clique em Modificar e, em seguida, digite 0 na caixa dados do valor .
  3. Reinicie o computador.
  4. Habilite o firewall do Windows.
Observação No Windows Server 2003 com Service Pack 1, o proxy H.323/LDAP foi removido do firewall, compartilhamento de conexão com a Internet e roteamento e acesso remoto.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

O "Internet Connection Firewall (ICF) / Internet conexão compartilhamento serviço (ICS)" (Service_Name: SharedAccess) fornece os seguintes serviços para uma rede doméstica ou de uma rede de pequena empresa:
  • Conversão de endereços de rede
  • Endereçamento
  • Resolução de nomes
  • Prevenção de invasão
Para fins de diagnóstico, você pode ativar o log estendido de LDAP. Quando esse problema ocorre, o evento 1216 pode ser registrado se as seguintes condições forem verdadeiras:
  • O sistema está configurado para usar o log estendido do NTDS.
  • O nível de log de eventos de interface LDAP é definido como um valor de 4 usando a seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Diagnostics
Quando o evento 1216 estiver conectado, você pode ver uma entrada semelhante à seguinte no Visualizador de eventos:

Tipo de evento: aviso
Origem do evento: NTDS LDAP
Categoria do evento: Interface LDAP
IDENTIFICAÇÃO de evento: 1216
Descrição:
Evento interno: uma cliente conexão LDAP foi fechada devido a um erro.
Identificação do cliente: 11387

Dados adicionais
Erro valor: 995 operação de A E/s foi anulada devido a uma saída de segmento ou a uma requisição de aplicativo.
IDENTIFICAÇÃO interna: c0602ec

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
816071  (http://support.microsoft.com/kb/816071/ ) Como desativar temporariamente o driver de filtro do modo kernel no Windows

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Professional Edition
Palavras-chave: 
kbmt kbtshoot kbprb KB908370 KbMtpt
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