Artigo: 908478 - Última revisão: sexta-feira, 27 de Outubro de 2006 - Revisão: 1.3

Um ou mais objectos de site poderão estar em falta depois de expandir um nó de hierarquia de site numa remoto sistema Management Server 2003 Administrator Console

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante Este artigo contém informações sobre como modificar o registo. Certifique-se de que cópia de segurança do registo antes de o modificar. Certifique-se que sabe como restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança, restaurar e modificar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registo do Microsoft Windows

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Sintomas

Considere o seguinte cenário:
  • Expanda o nó de hierarquia de site numa consola de administrador remoto do Microsoft Systems Management Server (SMS) 2003.
  • O local de consola estiver ligado a um site cujo SMS Windows Management Instrumentation (WMI) fornecedor é instalado num computador baseado no Microsoft Windows Server 2003.
Neste cenário, o nó da hierarquia de site poderá estar em falta para um ou mais objectos de site. Este problema também poderá ocorrer depois de actualizar o nó de hierarquia de sites.

Causa

Durante o pedido inicial de cliente para preencher o nó da hierarquia de site, o servidor responde com a porta de chamada (RPC, Remote Procedure Call) incorrecto de procedimento remoto. Assim, os dados nunca são recebidos pelo cliente e o nó de hierarquia de sites está vazio. O problema ocorre quando a restrição de porta RPC está activada utilizando a seguinte subchave do registo:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\Internet
Para obter mais informações sobre como configurar restrições de porta RPC, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
154596  (http://support.microsoft.com/kb/154596/ ) Como configurar a atribuição dinâmica de portas RPC para trabalhar com firewalls

Resolução

Para resolver este problema, obtenha o service pack mais recente para o Microsoft Windows Server 2003. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente do Windows Server 2003

Instruções de instalação

O service pack tem de ser instalado no servidor em que o fornecedor WMI do SMS (Smsprov.dll) está instalado. Para determinar qual o servidor que hospeda o fornecedor WMI do SMS, examine o valor de localização do fornecedor de registo na seguinte subchave do registo no servidor de site SMS:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Setup

Como contornar

aviso Podem ocorrer problemas graves se modificar o registo incorrectamente utilizando o Editor de registo ou utilizando outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. Microsoft não garante que estes problemas podem ser resolvidos. Modificar o registo por sua conta e risco.

Para trabalhar resolver este problema, siga estes passos:
  1. No computador remoto com a consola de administrador do SMS, clique em Iniciar , clique em Executar , escreva regedit e, em seguida, prima ENTER.
  2. Localize e, em seguida, com o botão direito do rato na seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\Internet
  3. Clique em Eliminar para eliminar a chave da Internet e para remover as restrições de porta RPC.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a". Este problema foi corrigido pela primeira vez no Microsoft Windows Server 2003 Service Pack Service Pack 1.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Systems Management Server 2003 Enterprise Edition
Palavras-chave: 
kbmt kbsmsadmin kbsmsremote tools kbbug kbtshoot kbprb KB908478 KbMtpt
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Clique aqui para ver a versão em Inglês deste artigo: 908478  (http://support.microsoft.com/kb/908478/en-us/ )