ID do artigo: 908478 - Última revisão: sexta-feira, 27 de outubro de 2006 - Revisão: 1.3

Um ou mais objetos de site podem estar faltando após a expansão um nó de hierarquia do site em um remoto System Management Server 2003 Administrator Console

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante Este artigo contém informações sobre como modificar o registro. Certifique-se de fazer backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registro do Microsoft Windows

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Sintomas

Considere o seguinte cenário:
  • Você expanda o nó de hierarquia de site em um console de administrador remoto do Microsoft Systems Management Server (SMS) 2003.
  • O site do console está conectado a um site cujo SMS Windows Management Instrumentation (WMI) provedor é instalado em um computador com Microsoft Windows Server 2003.
Nesse cenário, o nó de hierarquia do site pode estar faltando para um ou mais objetos de site. Esse problema também pode ocorrer depois de atualizar o nó de hierarquia do site.

Causa

Durante a solicitação de cliente inicial para preencher o nó de hierarquia do site, o servidor responde com a porta RPC (chamada) incorreta de procedimento remoto. Portanto, os dados nunca é recebidos pelo cliente e o nó da hierarquia de site está vazio. O problema ocorre quando a restrição de porta RPC estiver ativada, usando a seguinte subchave do Registro:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\Internet
Para obter mais informações sobre como configurar restrições de porta RPC, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
154596  (http://support.microsoft.com/kb/154596/ ) Como configurar a alocação de porta dinâmica da RPC para funcionar com os firewalls

Resolução

Para resolver esse problema, obtenha o service pack mais recente para o Microsoft Windows Server 2003. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente para o Windows Server 2003

Instruções de instalação

O service pack deve ser instalado no servidor em que o provedor WMI do SMS (Smsprov.dll) está instalado. Para determinar qual servidor hospeda o provedor WMI do SMS, examine o valor do Registro local do provedor na seguinte subchave do registro no servidor do site do SMS:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Setup

Como Contornar

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstale seu sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

Para trabalhar em torno esse problema, segue estas etapas:
  1. No computador remoto que esteja executando o console SMS Administrator, clique em Iniciar , clique em Executar , digite regedit e pressione ENTER.
  2. Localize e, em seguida, com o botão direito do rato na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\Internet
  3. Clique em Excluir para excluir a chave Internet e para remover as restrições de porta RPC.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a". Esse problema foi corrigido primeiro no Microsoft Windows Server 2003 Service Pack Service Pack 1.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Systems Management Server 2003 Enterprise Edition
Palavras-chave: 
kbmt kbsmsadmin kbsmsremote tools kbbug kbtshoot kbprb KB908478 KbMtpt
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