Artigo: 909005 - Última revisão: quinta-feira, 25 de Outubro de 2007 - Revisão: 1.2

No Exchange Server 2003 ou no Exchange 2000 Server, o Exchange Server filas são preenchidas com muitos relatórios de falha de entrega da conta de postmaster devido a uma inversa de entrega relatório ataque

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Num servidor que está a executar o Microsoft Exchange Server 2003 ou Microsoft Exchange 2000 Server, detecta um ou mais dos seguintes sintomas:
  • As filas do Microsoft Exchange Server contêm muitas mensagens enviar que aguardam a serem entregues endereços externos. Neste cenário, cada uma destas mensagens de correio electrónico tem postmaster name@name of your e-mail domain .com no campo.
  • Fornecedor de serviços Internet (ISP) notifica o servidor do Exchange server está a entregar correio electrónico comercial não solicitado (UCE, Unsolicited Commercial E-Mail). UCE, Unsolicited Commercial E-Mail também é conhecido por spam.
  • Quando visita da Internet do servidor do Exchange Server ou de um computador na rede de área local (LAN), acesso à Internet é muito lento.
  • O processo Store.exe e o processo Inetinfo.exe utilizam muito tempo da CPU e muita memória disponível.
  • Se parar o serviço de SMTP (Simple Mail Transfer Protocol), horas de acesso de Internet são mais rapidamente. Além disso, o processo Store.exe e o processo Inetinfo.exe devolver os respectivos níveis normal de utilização da CPU e utilização de memória.
  • A unidade que contém a pasta BadMail fica sem espaço. Por predefinição, a pasta BadMail está localizada na seguinte pasta.

    para o Exchange Server 2003
    C:\InetPub\Mailroot\
    para o Exchange 2000 Server
    C:\Programas\Microsoft Files\Exchsrvr\Mailroot\vsi 1

Causa

Este problema ocorre se o servidor é o destino de um ataque inversa de entrega relatório de falha de (NDR Report).

Resolução

Para resolver este problema, crie um filtro destinatário para impedir que o Exchange Server aceite as mensagens enviadas para os destinatários que não existem. Para o fazer, siga estes passos.

Passo 1: Determinar se as mensagens nas filas são mensagens NDR

  1. Inicie o Exchange System Manager.
  2. Expanda Servers , expanda o servidor do Exchange server e, em seguida, clique em filas .
  3. No painel da direita, faça clique sobre uma fila que contém o número de mensagens, clique em Localizar mensagens e, em seguida, clique em Localizar agora .
  4. Visualize o campo remetente dos produtos devolvidos. Se o remetente da mensagem postmaster name@name of your e-mail domain .com, a mensagem é uma mensagem NDR. Faça duplo clique a mensagem para ver o destinatário externo desta mensagem.
Siga os passos 3 a 4 para visualizar as mensagens nas outras filas SMTP. Se a maioria das mensagens de postmaster name@name of your e-mail domain .com, poderá tratar um ataque NDR inverso. Se a maior parte destas mensagens não sejam de postmaster name@name of your e-mail domain .com, o computador pode ser configurado como um transmissor aberto de SMTP. Ou, o computador poderá ser o destino de um ataque de comutação autenticado. Para obter mais informações sobre como resolver este problema, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
895853  (http://support.microsoft.com/kb/895853/ ) Como resolver problemas de transmissão de correio problemas no Exchange Server 2003 e no Exchange 2000 Server
Se o computador está configurado como um transmissor aberto de SMTP ou se o computador é alvo de um ataque de comutação autenticado, não é necessário que continuar para o "passo 2: configurar a filtragem de destinatários no Exchange Server 2003" secção. No entanto, se o computador for o destino de um ataque NDR inverso, crie um filtro para impedir o servidor do Exchange Server 2003 de aceitar mensagens enviadas para os destinatários que não existem destinatário. Para efectuar este procedimento, avance para o "passo 2: configurar a filtragem de destinatários no Exchange Server 2003" secção.

Passo 2: Configurar a filtragem de destinatários no Exchange Server 2003

Na configuração predefinida do Exchange Server, correio electrónico enviado para o name of your e-mail domain .com é aceite como local independentemente do alias de correio electrónico para que a mensagem é endereçada. O alias de correio electrónico é a parte do endereço de correio electrónico que está no lado esquerdo do @ (arroba). Se uma mensagem de correio electrónico é enviada para um alias que não é válido, o serviço SMTP recebe a mensagem completa. Em seguida, o serviço SMTP consulta o serviço de directório do Active Directory para um grupo de utilizador ou distribuição que tenha um alias de correio electrónico correspondente. Por exemplo, se uma mensagem de correio electrónico é enviada para invalid user name@name of your e-mail domain .com, o serviço SMTP consultará do Active Directory um grupo de utilizador ou distribuição que tenha o alias de .com invalid user name@name of your e-mail domain. No entanto, se o alias de correio electrónico não existir, Exchange Server tenta enviar um NDR ao remetente de mensagem de correio electrónico original. Isto pode causar várias mensagens, filas ou ambos aparecer no Exchange System Manager.

Depois de activar a filtragem de destinatários, o Exchange Server valida o endereço de correio electrónico antes do Exchange Server aceita a mensagem de correio electrónico. Neste cenário, se for apresentada nenhuma correspondência para este alias de correio electrónico no Active Directory, um NDR ainda é gerado. No entanto, neste cenário, é da responsabilidade do servidor de SMTP de envio em vez do servidor do Exchange Server para gerar e entregar o NDR.

Nota Filtragem de destinatários só estão disponível no Exchange Server 2003.
  1. Inicie o Exchange System Manager.
  2. Expanda Definições globais , clique com o botão direito do rato Entrega de mensagens e, em seguida, clique em Propriedades .
  3. Clique no separador Filtragem de destinatários , clique para seleccionar a caixa de verificação filtrar os destinatários que constam não o directório e, em seguida, clique em OK .
  4. Quando receber a seguinte mensagem, clique em OK :
    Ligação, o destinatário e Sender Filtering tem de ser activada manualmente em atribuições de endereços IP servidor virtual de SMTP específicas como não estão activados por predefinição. Para mais informações sobre como activar um ou mais dos seguintes tipos de filtragem, leia a respectiva ajuda associada.
  5. Expanda Servers , expanda o servidor do Exchange Server, expanda Protocols , expanda SMTP , clique com o botão direito do rato em Servidor Virtual de SMTP predefinido e, em seguida, clique em Propriedades .
  6. No separador Geral , clique em Avançadas .
  7. Clique em Editar , clique para seleccionar a caixa de verificação Aplicar filtro de destinatário e, em seguida, clique em OK três vezes.
Nota Se com o Exchange Server num ambiente front-end/back-end, filtragem de destinatários tem de ser activado no servidor bridgehead de SMTP ou servidores.

Depois de activar a filtragem de destinatários, pode ser utilizada uma técnica de determinados contra o servidor de Exchange Server, para recolher informações sobre as endereços de correio electrónico válido na organização. Esta técnica é conhecida como um Directory Harvest Attack. Para obter mais informações sobre como ajudar a impedir este tipo de ataque, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
842851  (http://support.microsoft.com/kb/842851/ ) Funcionalidade de "tar pit" de SMTP do Microsoft Windows Server 2003

Passo 3: Limpar as filas do Exchange Server

Remova o UCE, Unsolicited Commercial E-Mail das filas SMTP no computador. Para o fazer, siga estes passos.

aviso Durante este processo, serão eliminadas todas as mensagens são destinadas a destinatários externos de SMTP. Mensagens de correio electrónico interno e receber mensagens de correio electrónico da Internet não são afectadas. Estas definições são temporárias. O fluxo de correio normal é restaurado depois das filas de SMTP do Exchange Server são limpas.

  1. Inicie a ferramenta de gestão do servidor.
  2. Expanda gestão avançada, expanda a organização do Exchange e, em seguida, clique em conexões.

    Nota Este procedimento requer um conector SMTP.
  3. Utilize um dos seguintes métodos:
    • Se o servidor do Exchange server não tiver um conector SMTP, tem de criar um. Para criar um conector SMTP, siga estes passos:
      1. Clique com o botão direito do rato em Connectors , aponte para Novo e, em seguida, clique em Conector SMTP .
      2. Na caixa nome , escreva temporário conector smtp .
      3. Clique em Adicionar , clique no servidor do Exchange Server na lista de servidor e, em seguida, clique em OK .
      4. Clique no separador Espaço de endereço e, em seguida, clique em Adicionar .
      5. Clique em SMTP , clique em OK , deixar o asterisco na caixa domínio de correio electrónico e, em seguida, clique em OK .
      6. Clique no separador Geral .
    • Se o servidor do Exchange Server tem um conector SMTP, tem de modificar a conexão. Para modificar este conector, siga estes passos:
      1. Clique com o botão direito do rato esta conexão e, em seguida, clique em Propriedades .

        Nota Se tiver mais do que um conector SMTP, trabalha com aquela que contém um asterisco no espaço de endereços SMTP no separador Espaço de endereços .
      2. Clique no separador Geral e anote todas as definições que estão listadas neste separador. Tem de restaurar estas definições depois de limpar as filas do Exchange Server.
  4. Clique em Forward all mail through this connector to the following smart hosts , escreva um endereço IP que não é válido e, em seguida, coloque-parêntesis rectos. Por exemplo, escreva [99.99.99.99] .
  5. Clique no separador Opções de entrega e, em seguida, clique em especificar quando são enviadas mensagens through this connector .
  6. Na lista tempo de ligação , clique em executar diariamente às 11: 00 e, em seguida, clique em OK .
  7. No painel esquerdo da ferramenta de gestão do servidor, expanda Servers , expanda o servidor do Exchange Server, expanda Protocols , expanda SMTP , clique com o botão direito do rato em Servidor Virtual de SMTP predefinido e, em seguida, clique em Parar .
  8. Quando o servidor virtual de SMTP predefinido foi parado com êxito, clique com o botão direito do rato em Default SMTP Virtual Server e, em seguida, clique em Iniciar .
  9. Depois do servidor virtual de SMTP predefinido foi iniciado com êxito, aguarde cerca de 10 minutos.

    Nota Quando reinicia o servidor virtual de SMTP predefinido, enumera novamente as mensagens de correio electrónico e coloca-os numa única fila para o conector SMTP que configurou.
  10. No painel da esquerda da ferramenta de gestão do servidor, expanda Servers , expanda o servidor do Exchange Server e, em seguida, clique em filas .
  11. Anote o número total de mensagens que aparecem ao lado do conector SMTP que configurou. Este número de mensagens tem estabilizar para que possa remover todas as mensagens de correio electrónico ao mesmo tempo.
  12. Cada 15 minutos, clique com o botão direito do rato em filas e, em seguida, clique em Actualizar .
  13. Repita o passo 12 até que o número de mensagens em fila de conector SMTP permanece constante.
  14. No painel da direita, clique com o botão direito do rato a fila SMTP e, em seguida, clique em Localizar mensagens .
  15. Na lista a número de mensagens sejam listados na procura , clique num número adequado para o informar de remover todas as mensagens ao mesmo tempo. Por exemplo, se tiver de 900 mensagens que pretende remover, clique em 1000 na lista a número de mensagens sejam listados na procura .
  16. Clique em Localizar agora .
  17. Na lista de Resultados da procura , seleccione todas as mensagens. Para o fazer, clique numa mensagem e, em seguida, prima SHIFT + PAGE DOWN.
  18. Clique com o botão direito do rato as mensagens seleccionadas e, em seguida, clique em Eliminar (no NDR) .
  19. Quando receber a seguinte mensagem, clique em Sim :
    Tem a certeza de que pretende eliminar mensagens na fila?


    Nota Se estiver a remover várias mensagens, o processo de remoção poderá demorar algum tempo.
  20. Depois das mensagens forem removidas com êxito, feche a caixa de diálogo Localizar mensagens connector name.
  21. Clique com o botão direito do rato em filas e, em seguida, clique em Actualizar .
  22. Anote o número total de mensagens que aparecem ao lado do conector SMTP que configurou. Este número de mensagens tem de ser zero.
  23. Repita os passos 21 e 22 sobre cada 5 minutos para se certificar de que a fila SMTP permanece no zero mensagens. Se o número de mensagens na fila SMTP aumenta, Exchange Server ainda está a processar mensagens para entrega externa. Neste cenário, continue a actualizar o ecrã até que o número de mensagens na fila SMTP stabilizes.
  24. Repita os passos 14 a 23 até o número de mensagens na fila SMTP permanece no zero. Neste cenário, as filas de SMTP do Exchange Server tenham sido limpos de todos os UCE.
Depois de ter limpa as filas de SMTP do Exchange Server, restaure a configuração do conector SMTP para as definições originais. Se tiver criado um conector SMTP temporário, remova. Para o fazer, siga estes passos:
  1. No painel da esquerda da ferramenta de gestão do servidor, expanda Connectors , clique com o botão direito do rato conector smtp temporário e, em seguida, clique em Eliminar .
  2. Quando receber a seguinte mensagem, clique em Sim :
    Tem a certeza de que pretende eliminar 'Conector smtp temporária'?
Nota Depois de modificar ou remover o conector SMTP, tem de reiniciar o servidor virtual de SMTP. Para obter mais informações sobre como resolver este problema, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
895853  (http://support.microsoft.com/kb/895853/ ) Como resolver problemas de transmissão de correio problemas no Exchange Server 2003 e no Exchange 2000 Server

Mais Informação

As pessoas que enviam UCE, Unsolicited Commercial E-Mail para destinatários de correio electrónico tem descobriu um método para resolver os filtros de correio electrónico que estão incorporados nos vários sistemas de mensagens de correio electrónico. Neste cenário, as pessoas que enviam UCE, Unsolicited Commercial E-Mail tentam tirar partido da funcionalidade de notificação de estado de entrega do servidor de correio electrónico. Num sistema de mensagens de correio electrónico normal, uma mensagem de notificação do estado de entrega NDR é gerada quando não é possível entregar uma mensagem de correio electrónico. Além disso, esta mensagem NDR normalmente contém o conteúdo da mensagem não entregue. Este comportamento segue Request for Comments (RFC) padrões. Por conseguinte, sistemas de mensagens mais comportam-se desta forma.

A pessoa que envia UCE, Unsolicited Commercial E-Mail utiliza esta mensagem NDR para entregar UCE, Unsolicited Commercial E-Mail. Este tipo de entrega UCE, Unsolicited Commercial E-Mail é conhecido como um ataque NDR inverso. Este tipo de entrega UCE, Unsolicited Commercial E-Mail funciona da seguinte forma:
  1. Correio electrónico comercial não solicitado é criado utilizando o endereço de correio electrónico do destinatário destino no campo remetente da mensagem correio electrónico.
  2. Um nome de utilizador fictícios, juntamente com o nome de domínio é adicionado como o destinatário da mensagem de correio electrónico.
  3. Esta mensagem de correio electrónico comercial não solicitado é enviada para o domínio.
  4. O servidor de correio electrónico aceita esta mensagem porque a mensagem é enviada para o domínio.
  5. O servidor de correio electrónico não consegue entregar esta mensagem porque o destinatário não existe.
  6. O servidor de correio electrónico envia um NDR para a pessoa que aparece como o remetente desta mensagem. Neste cenário, a pessoa que aparece como remetente da mensagem é o destinatário externo que recebe o NDR da conta de postmaster. A pessoa que envia o UCE, Unsolicited Commercial E-Mail coloca o destinatário do UCE, Unsolicited Commercial E-Mail no campo ' remetente ' da mensagem. Por conseguinte, o destinatário recebe o NDR da conta de postmaster no seu domínio de correio electrónico.
  7. O NDR é enviado para o endereço de correio electrónico externo do endereço postmaster do domínio. Este NDR pode conter a mensagem original do UCE, Unsolicited Commercial E-Mail.
  8. O utilizador são pode ler este NDR juntamente com a mensagem UCE, Unsolicited Commercial E-Mail. Por conseguinte, a UCE, Unsolicited Commercial E-Mail mensagem foi entregue com êxito ao destinatário externo que é apresentado no campo remetente da mensagem de correio electrónico original.
Para obter mais informações sobre tópicos relacionados, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
823866  (http://support.microsoft.com/kb/823866/ ) Como configurar a ligação de filtragem para utilizar listas de bloco de tempo real (RBLs) e como configurar a filtragem de destinatários no Exchange 2003

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange 2000 Server Standard Edition
Palavras-chave: 
kbmt KB909005 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 909005  (http://support.microsoft.com/kb/909005/en-us/ )