ID do artigo: 909005 - Última revisão: quinta-feira, 25 de outubro de 2007 - Revisão: 1.2

No Exchange Server 2003 ou no Exchange 2000, o Exchange Server filas são preenchidas com muitos non-delivery reports da conta de postmaster devido a um inversa non-delivery relatório ataque

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

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Sintomas

Em um servidor que está executando o Microsoft Exchange Server 2003 ou Microsoft Exchange 2000 Server, você enfrentar um ou mais dos seguintes sintomas:
  • As filas do Microsoft Exchange Server contêm muitas mensagens de saída que estão aguardando para ser entregue a endereços externos. Nesse cenário, cada um dessas mensagens de email tem .com postmaster name@name of your e-mail domain no campo.
  • Provedor de serviço de Internet (ISP) o notifica de que o servidor do Exchange é entregar email comercial não solicitado (UCE). SPAM também é conhecido como spam.
  • Quando você visita a Internet o servidor do Exchange ou de um computador que esteja na rede local (LAN), acesso à Internet está muito lento.
  • O processo Store.exe e o processo Inetinfo.exe usar muita tempo de CPU e muita memória disponível.
  • Se você parar o serviço SMTP (Simple Mail Transfer Protocol), horários de acesso da Internet são mais rápidos. Além disso, o processo Store.exe e o processo Inetinfo.exe retornam para os níveis típicos de uso da CPU e uso de memória.
  • A unidade que contém a pasta BadMail executado fora do espaço. Por padrão, a pasta BadMail está localizada na seguinte pasta.

    para o Exchange Server 2003
    C:\InetPub\Mailroot\
    para o Exchange 2000 Server
    C:\Arquivos Files\Exchsrvr\Mailroot\vsi 1

Causa

Esse problema ocorre se o servidor é o destino de um ataque inversa non-delivery report (NDR).

Resolução

Para resolver esse problema, crie um filtro de destinatário para impedir que o Exchange Server aceitar mensagens enviadas para destinatários que não existem. Para fazer isso, siga estas etapas.

Etapa 1: Determinar se as mensagens nas filas são mensagens NDR

  1. Inicie o Exchange System Manager.
  2. Expanda Servers , expanda o servidor do Exchange e, em seguida, clique em filas .
  3. No painel à direita, clique em uma fila que contém muitas mensagens, clique em Localizar mensagens e em seguida, clique em Localizar agora .
  4. Exiba o campo remetente de itens devolvidos. Se o remetente da mensagem for .com postmaster name@name of your e-mail domain, a mensagem é uma mensagem do NDR. Clique duas vezes na mensagem para exibir o destinatário externo desta mensagem.
Siga as etapas 3 a 4 para exibir as mensagens em outras filas do SMTP. Se a maioria das mensagens de .com postmaster name@name of your e-mail domain, talvez haja um ataque NDR inverso. Se a maioria dessas mensagens não são de .com postmaster name@name of your e-mail domain, o computador pode estar configurado como um retransmissor de SMTP aberto. Ou, o computador pode ser o destino de um ataque de retransmissão autenticada. Para obter mais informações sobre como resolver esse problema, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
895853  (http://support.microsoft.com/kb/895853/ ) Como solucionar problemas de retransmissão de email problemas no Exchange Server 2003 e no Exchange 2000 Server
Se o computador está configurado como um retransmissor de SMTP aberto ou se o computador é o destino de um ataque retransmissão autenticada, não é necessário que continuar a "etapa 2: configurar a filtragem de destinatários no Exchange Server 2003" seção. No entanto, se o computador é o destino de um ataque NDR inverso, crie um filtro de destinatário para impedir que o servidor do Exchange Server 2003 aceitar mensagens enviadas para destinatários que não existem. Para fazer isso, continue a "etapa 2: configurar a filtragem de destinatários no Exchange Server 2003" seção.

Etapa 2: Configurar a filtragem no Exchange Server 2003 de destinatário

Na configuração padrão do Exchange Server, o email é enviado para .com do name of your e-mail domain será aceito como local independentemente do alias de email ao qual a mensagem está endereçada. O alias de email é a parte do endereço de email que está no lado esquerdo do @ (arroba). Se uma mensagem de email é enviada para um alias que não é válido, o serviço SMTP recebe a mensagem inteira. Em seguida, o serviço SMTP consulta um grupo de distribuição ou de usuário que tenha um alias de email correspondente no serviço de diretório do Active Directory. Por exemplo, se uma mensagem de email é enviada para .com invalid user name@name of your e-mail domain, o serviço SMTP consultará Active Directory um grupo de distribuição ou de usuário que tenha o alias de .com invalid user name@name of your e-mail domain. No entanto, se o alias de email não existir, Exchange Server tenta enviar um NDR ao remetente de mensagem de email original. Isso pode causar muitas mensagens, filas ou ambos aparecem no Exchange System Manager.

Após ativar a filtragem de destinatários, o Exchange Server valida o endereço de email antes de Exchange Server aceita a mensagem de email. Nesse cenário, se nenhuma correspondência para este alias de email é exibido no Active Directory, um NDR ainda será gerado. No entanto, nesse cenário, é responsabilidade do servidor de envio SMTP em vez do servidor do Exchange para gerar e para entregar o NDR.

Observação Filtragem de destinatário só está disponível no Exchange Server 2003.
  1. Inicie o Exchange System Manager.
  2. Expanda Global Settings , clique Entrega de mensagem com o botão direito do mouse e, em seguida, clique em Propriedades .
  3. Clique na guia Recipient Filtering , clique para selecionar a caixa de seleção Filtrar destinatários que são não no diretório e, em seguida, clique em OK .
  4. Quando você receber a seguinte mensagem, clique em OK :
    Conexão, destinatário e filtragem por remetente devem ser habilitada manualmente em atribuições de endereço IP do servidor virtual SMTP como eles não são ativados por padrão. Para obter mais informações sobre como habilitar qualquer um ou mais desses tipos de filtragem, leia sua ajuda associada.
  5. Expanda Servers , expanda o servidor do Exchange, expanda Protocols , expanda SMTP , clique com o botão direito do mouse em Default SMTP Virtual Server e em seguida, clique em Propriedades .
  6. Na guia Geral , clique em Avançado .
  7. Clique em Editar , clique para selecionar a caixa de seleção Aplicar filtro de destinatário e, em seguida, clique em OK três vezes.
Observação Se você estiver executando o Exchange Server em um ambiente de front-end/back-end, filtragem de destinatário deve ser ativado no servidor de ponte SMTP ou servidores.

Após ativar a filtragem de destinatários, uma técnica de determinados pode ser usada contra o servidor Exchange Server para reunir informações sobre endereços de email válido de sua empresa. Essa técnica é conhecida como um ataque de coleta de diretório. Para obter mais informações sobre como ajudar a evitar esse tipo de ataque, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
842851  (http://support.microsoft.com/kb/842851/ ) Recurso de tar pit SMTP para o Microsoft Windows Server 2003

Etapa 3: Limpar as filas do Exchange Server

Remove o UCE filas do SMTP no computador. Para fazer isso, siga estas etapas.

Aviso Durante esse processo, todas as mensagens que são destinadas a destinatários SMTP externos são excluídas. Mensagens de email interno e emails de entrada da Internet não são afetados. Essas configurações são temporárias. O fluxo de email típica é restaurado após as filas SMTP do Exchange Server são limpos.

  1. Inicie a ferramenta de gerenciamento de servidor.
  2. Expanda Gerenciamento Avançado, expanda a organização do Exchange e, em seguida, clique em conectores.

    Observação Este procedimento requer um conector SMTP.
  3. Use um dos seguintes métodos:
    • Se o servidor do Exchange não tiver um conector SMTP, você deve criar um. Para criar um conector SMTP, execute essas etapas:
      1. Clique com o botão direito do mouse em Connectors , aponte para novo e, em seguida, clique em SMTP Connector .
      2. Na caixa nome , digite o conector smtp temporário .
      3. Clique em Adicionar , clique no servidor do Exchange na lista servidor e, em seguida, clique em OK .
      4. Clique na guia Address Space e, em seguida, clique em Adicionar .
      5. Clique em SMTP , clique em OK , deixe o asterisco na caixa de domínio de email e, em seguida, clique em OK .
      6. Clique na guia Geral .
    • Se o servidor do Exchange Server tem um conector SMTP, você deve modificar o conector. Para modificar esse conector, execute essas etapas:
      1. Clique esse conector com o botão direito do mouse e, em seguida, clique em Propriedades .

        Observação Se você tiver mais de um conector SMTP, trabalhe com aquele que contém um asterisco no espaço de endereço SMTP na guia Espaço de endereço .
      2. Clique na guia Geral e, em seguida, observe todas as configurações que estão listadas nessa guia. Você deve restaurar essas configurações depois de você limpar as filas do Exchange Server.
  4. Clique em Forward all mail through this connector to the following smart hosts , digite um endereço IP que não é válido e coloque-o entre colchetes. Por exemplo, digite [99.99.99.99] .
  5. Clique na guia Delivery Options e em seguida, clique em especificar quando as mensagens são enviadas por meio desse conector .
  6. Na lista Connection time , clique em Executar diariamente às 11: 00 e, em seguida, clique em OK .
  7. No painel esquerdo da ferramenta Gerenciamento do servidor, expanda Servers , expanda o servidor do Exchange, expanda Protocols , expanda SMTP , clique com o botão direito do mouse em Default SMTP Virtual Server e, em seguida, clique em Parar .
  8. Quando o servidor SMTP virtual padrão foi interrompido com êxito, clique com o botão direito do mouse em Default SMTP Virtual Server e, em seguida, clique em Iniciar .
  9. Após o servidor SMTP virtual padrão foi iniciado com êxito, espere para cerca de 10 minutos.

    Observação Quando você reiniciar o servidor SMTP virtual padrão, ele enumera novamente as mensagens de email e os coloca em uma fila única para o conector SMTP que você configurou.
  10. No painel esquerdo da ferramenta Gerenciamento do servidor, expanda Servers , expanda o servidor do Exchange e, em seguida, clique em filas .
  11. Observe o número total de mensagens que aparecem ao lado para o conector SMTP que você configurou. Esse número de mensagens deve estabilizar para que você possa remover todas as mensagens de email ao mesmo tempo.
  12. A cada 15 minutos, clique com o botão direito do mouse em filas e clique em Atualizar .
  13. Repita a etapa 12 até que o número de mensagens na fila do conector de SMTP permanece constante.
  14. No painel à direita, clique fila SMTP com o botão direito do mouse e, em seguida, clique em Localizar mensagens .
  15. Na lista número de mensagens para ser listadas na pesquisa , clique em um número apropriado para permitir que você remover todas as mensagens ao mesmo tempo. Por exemplo, se você tiver 900 mensagens que você deseja remover, clique em 1000 na lista número de mensagens para ser listadas na pesquisa .
  16. Clique em Localizar agora .
  17. Na lista Resultados da pesquisa , selecione todas as mensagens. Para fazer isso, clique em uma mensagem e, em seguida, pressione SHIFT + PAGE DOWN.
  18. Clique as mensagens selecionadas com o botão direito do mouse e, em seguida, clique em Excluir (NDR) .
  19. Quando você receber a seguinte mensagem, clique em Sim :
    Tem certeza de que deseja excluir as mensagens na fila?


    Observação Se você estiver removendo várias mensagens, o processo de remoção pode levar muito tempo.
  20. Depois que as mensagens forem removidas com êxito, feche a caixa de diálogo Localizar mensagens connector name.
  21. Clique com o botão direito do mouse em filas e, em seguida, clique em Atualizar .
  22. Observe o número total de mensagens que aparecem ao lado para o conector SMTP que você configurou. Esse número de mensagens deve ser zero.
  23. Repita as etapas 21 e 22 sobre cada 5 minutos para garantir que a fila SMTP permanece em mensagens de zero. Se o número de mensagens na fila SMTP aumenta, o Exchange Server ainda está processando mensagens para entrega externa. Nesse cenário, continue a atualizar a exibição até que o número de mensagens na fila SMTP stabilizes.
  24. Repita as etapas 14 a 23 até que o número de mensagens na fila SMTP permaneça no zero. Nesse cenário, as filas SMTP do Exchange Server foram limpos de todos os o UCE.
Depois que tiver limpado as filas SMTP do Exchange Server, restaurar a configuração do conector SMTP para suas definições originais. Se você tiver criado um conector SMTP temporário, remova-o. Para fazer isso, execute as seguintes etapas:
  1. No painel esquerdo da ferramenta Gerenciamento do servidor, expanda conectores , clique conector smtp temporário com o botão direito do mouse e, em seguida, clique em Excluir .
  2. Quando você receber a seguinte mensagem, clique em Sim :
    Tem certeza de que deseja excluir 'conector smtp temporário'?
Observação Depois de modificar ou remover o conector SMTP, reinicie o servidor virtual SMTP. Para obter mais informações sobre como resolver esse problema, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
895853  (http://support.microsoft.com/kb/895853/ ) Como solucionar problemas de retransmissão de email problemas no Exchange Server 2003 e no Exchange 2000 Server

Mais Informações

Pessoas que enviam emails comerciais não SOLICITADOS para destinatários de email descobriu um método como solução alternativa para os filtros de email que integram vários sistemas de mensagens de email. Nesse cenário, as pessoas que enviam spam tentam tirar proveito da funcionalidade de notificação de status de entrega no servidor de email. Um sistema de mensagens de email típico, uma mensagem de notificação de status de entrega NDR é gerada quando uma mensagem de email não pode ser entregue. Além disso, esta mensagem do NDR normalmente contém o conteúdo da mensagem não entregue. Esse comportamento segue a solicitação para padrões de comentários (RFC). Portanto, sistemas de mensagens mais se comportam dessa maneira.

A pessoa que envia emails comerciais não SOLICITADOS usa esta mensagem do NDR para entregar emails comerciais não SOLICITADOS. Esse tipo de entrega de emails comerciais não SOLICITADOS é conhecido como um ataque NDR inverso. Esse tipo de entrega de emails comerciais não SOLICITADOS funciona da seguinte maneira:
  1. Emails comerciais não solicitados é criada usando o endereço de email do destinatário de destino no campo remetente dessa mensagem de email.
  2. Um nome de usuário fictício junto com seu nome de domínio é adicionado como o destinatário dessa mensagem de email.
  3. Essa mensagem de email comercial não solicitado é enviada ao seu domínio.
  4. O servidor de email aceita esta mensagem porque a mensagem é enviada para seu domínio.
  5. O servidor de email não é possível entregar esta mensagem porque o destinatário não existe.
  6. O servidor de email envia um NDR para a pessoa que aparece como o remetente desta mensagem. Nesse cenário, a pessoa que aparece como o remetente da mensagem é o destinatário externo que recebe o NDR da conta de postmaster. A pessoa que envia o UCE coloca o destinatário do UCE no campo remetente da mensagem. Portanto, o destinatário recebe o NDR da conta postmaster no seu domínio de email.
  7. O NDR é enviado para o endereço de email externo do endereço do postmaster do seu domínio. Este NDR pode conter a mensagem não solicitada original.
  8. O usuário desavisado pode ler este NDR junto com a mensagem de spam. Portanto, a mensagem de spam foi entregue com êxito para o destinatário externo que é listado no campo remetente da mensagem de email original.
Para obter mais informações sobre tópicos relacionados, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
823866  (http://support.microsoft.com/kb/823866/ ) Como configurar a conexão de filtragem para usar listas de bloqueios em tempo real (RBLs) e como configurar a filtragem de destinatários no Exchange 2003

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange 2000 Server Standard Edition
Palavras-chave: 
kbmt KB909005 KbMtpt
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