Artikel-ID: 909096 - Geändert am: Dienstag, 24. Juli 2007 - Version: 1.10

Der Prozess Mshta.exe schließt nicht beim Beenden einer HTML-Anwendung, die veröffentlicht wird auf einem Terminalserver, auf denen Windows Server 2003 ausgeführt wird

Hotfix Download is availableHotfix-Download ist verfügbar
Hotfix downloaden und installieren
SystemtippDieser Artikel bezieht sich auf ein anderes Betriebssystem als das von Ihnen verwendete. Für Sie möglicherweise nicht relevante Artikelinhalte wurden deaktiviert.

Auf dieser Seite

Alles erweitern | Alles schließen

Problembeschreibung

Eine Remotedesktopsitzung beenden Sie eine Microsoft HTML-Anwendung (HTA), die als ein Programm auf einem Terminal Server veröffentlicht wird. Der Terminal Server wird Microsoft Windows Server 2003 ausgeführt. Nachdem Sie die HTA-Anwendung beenden, scheint es zu schließen. Mshta.exe Prozesses, der das HTA-Programm wird ausgeführt, wird jedoch nicht geschlossen, obwohl der Prozess nicht mehr reagiert.

Ursache

Dieses Problem, da die Mshtml.DLL-Datei nicht die richtige Windows-Nachricht zu schließen empfangen. Dieses Problem tritt, wenn eine HTA als veröffentlichte Programm in einer Terminaldienste-Umgebung ausgeführt wird.

Lösung

Informationen zu Service Packs

Installieren Sie das neueste Servicepack für Windows Server 2003, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) So erhalten Sie das neueste Servicepack für Windows Server 2003

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Es gelten keine Voraussetzungen.

Neustartanforderung

Sie müssen neu Terminaldienste auf dem Windows Server 2003-basierten Computer starten, nachdem Sie diesen Hotfix anwenden.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools ? Datum und Uhrzeit in der Systemsteuerung.
Windows Server 2003 x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Mshtml.dll6.0.3790.4432,934,27212-Nov 200502: 49X 86
Windows Server 2003, Itanium-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformServicebereich
Mshtml.dll6.0.3790.4438,241,66411-Nov 200513: 16IA-64RTMQFE
Wmshtml.dll6.0.3790.4432,934,27211-Nov 200513: 19X 86WOW

Weitere Informationen

Schritte zum Reproduzieren des Problems

Zum Reproduzieren des Problems speichern Sie den folgenden Code in eine Datei mit dem Namen Test.hta. Nachdem Sie dies tun, verwenden Sie eine remote desktop Terminaldienste-Sitzung zu Host die Test.hta-Datei als eine veröffentlichte Programm unter dem Prozess Mshta.exe.
<HTML>
<HEAD>
<title>System2 UAT</title>
<HTA:Application
 Border = Thin
 BorderStyle = Complex
 ShowInTaskBar = Yes
 MaximizeButton = No
 MinimizeButton = Yes
 Scroll = No
 BorderStyle = Static
 Selection = No
 Caption = Yes
 Navigable = Yes
>
</HEAD>
<Script Language ="VBScript">
 
Sub window_OnLoad
 Window.ResizeTo 500,500
 document.all.FrameArea.innerHTML = "<iFrame ID=Test width=500 height=100 src=""c:\shortcuts""></iFrame>"
 ' document.all.test.src = "file:///c:\shortcuts"
End Sub
 
Sub window_onunload
 MsgBox "Thank you for using the System today!",vbOkOnly+vbInformation,"Goodbye!"
End Sub
 

Function LogOff()
 document.all.FrameArea.innerHTML = "Bye Now"
 window.close
End Function
 
</Script>
 
<BODY>
 <input type=BUTTON value="Log Off Now" ID="Exit" onClick="Logoff()">
 <BR><BR>
 <HR>
 <DIV ID="FrameArea">
 
</DIV>
</BODY>
</HTML>
Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbmt kbautohotfix kbqfe kbhotfixserver kbwinserv2003presp1fix kbbug kbfix kbpubtypekc KB909096 KbMtde
Maschinell übersetzter ArtikelMaschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 909096  (http://support.microsoft.com/kb/909096/en-us/ )
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.