REVISIÓN: Puede recibir un mensaje de error cuando intenta ejecutar una aplicación que se integra en el marco ATL en Windows 2000 o en una versión anterior

Seleccione idioma Seleccione idioma
Id. de artículo: 909141 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando intenta ejecutar una aplicación que se basa en el marco de ATL (Active Template Library) en Microsoft Windows 2000 o en una versión anterior, no se ejecuta la aplicación. Es posible que reciba un mensaje de error parecido al siguiente:
El FreeAddrInfoW de punto de entrada de procedimiento no se encuentra en la biblioteca de vínculos dinámicos Ws2_32.dll.
Este problema se produce cuando se cumplen las condiciones siguientes:
  • La aplicación utiliza la clase CSocketAddr .
  • La aplicación escrita utilizando Visual C++ .NET 2003.

Causa

Este problema se produce porque la implementación de Unicode del marco de trabajo ATL utiliza la función de Windows Sockets FreeAddrInfoW en la clase CSocketAddr . Sin embargo, esta API sólo se implementa en Microsoft Windows XP y en versiones posteriores.

Nota La función de Windows Sockets FreeAddrInfoW se introdujo en Microsoft Windows XP y en Microsoft Windows Server 2003. Los sockets de Windows FreeAddrInfoW función agrega compatibilidad para el protocolo de Internet versión 6 (IPv6) pila.

Solución

Información de revisiones

Ahora es disponible en Microsoft un hotfix compatible, pero sólo se diseñó para corregir el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.

Para resolver el problema, póngase en contacto con los Servicios de soporte técnico de Microsoft con el fin de obtener el hotfix. Para obtener una lista completa de los números de teléfono de los servicios de soporte técnico de Microsoft e información acerca de los costos de soporte, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota en casos especiales, los costos derivados normalmente de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoTamaño del archivoFechaTiempo
Atlsocket.h3.53822-Sep-200521: 34
Atlsocket.inl3,21022-Sep-200523: 30

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 909141 - Última revisión: miércoles, 26 de julio de 2006 - Versión: 2.3
La información de este artículo se refiere a:
  • Microsoft Visual Studio .NET 2003 Professional
  • Microsoft Visual Studio .NET 2003 Enterprise Architect
  • Microsoft Visual Studio .NET 2003 Enterprise Developer
  • Microsoft Visual Studio .NET 2003 Academic Edition
  • Microsoft Visual C++ .NET 2003 Standard
Palabras clave: 
kbmt kbqfe kbfix kbbug kbpubtypekc kbhotfixserver KB909141 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 909141

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com