COM+ ve MS DTC için Microsoft Güvenlik Bülteni MS05-051'i yükledikten sonra çeşitli sorunlarla karşılaşabilirsiniz

Makale çevirileri Makale çevirileri
Makale numarası: 909444 - Bu makalenin geçerli olduğu ürünleri görün.
Hepsini aç | Hepsini kapa

Bu Sayfada

Belirtiler

Microsoft Windows XP, Microsoft Windows 2000 veya Windows Server 2003 çalıştıran bir bilgisayarda, Microsoft Güvenlik Bülteni MS05-051'de açıklanan kritik güncelleştirme yüklendikten sonra bir veya daha fazla sorun oluşabilir. Bu sorunlar şunlardır:
  • Windows Installer hizmeti başlatılamayabilir.
  • Windows Güvenlik Duvarı Hizmeti başlatılamayabilir.
  • Ağ Bağlantıları klasörü boştur.
  • Windows Update Web sitesi hatalı şekilde Microsoft Internet Explorer'daki Userdata persistence ayarını değiştirmenizi önerebilir.
  • Microsoft Internet Information Services (IIS) üzerinde çalışan Active Server Pages (ASP) sayfaları bir “HTTP 500 – İç Sunucu Hatası” hata iletisi döndürebilir.
  • Microsoft COM+ EventSystem hizmeti başlatılmaz.
  • COM+ uygulamaları başlatılmaz.
  • Microsoft Bileşen Hizmetleri Microsoft Yönetim Konsolu (MMC) ağacındaki bilgisayarlar düğümü genişletilemez.
  • Kullanıcılar Ekim Güvenlik Güncelleştirmeleri'ni uyguladıktan sonra, kimliği doğrulanmış kullanıcılar oturum açamaz ve boş bir ekran görüntülenir.
  • Sunucu kümesi yapılandırmasında, küme hizmeti başlatılamayabilir. Küme günlük dosyasına aşağıdaki olay kaydedilir:

    HATA [SAYI] Ağ Bağlantısı Yöneticisi ile bağlantı noktası oluşturulamadı, durum 80070005. UYARI [SAYI] Ağ Bağlantısı Yöneticisi öneri havuzu başlatılamadı, durum 80070005 HATA [SAYI] Başlatma başarısız oldu -2147024891

  • Sistem günlüğüne aşağıdakine benzer bir olay kaydedilir:

    Olay Kimliği: 512
    Kaynak: CryptSvc
    Açıklama:
    Şifreleme Hizmetleri hizmeti VSS yedek "Sistem Writer" nesnesini başlatamadı.

    Ayrıntılar:
    Sistem Yazıcısı nesnesi VSS'ye abone olamadı.

    Sistem Hatası:
    Geri dönülemez hata

  • Bir komut dosyası, WBEMTest.exe yardımcı programı veya başka bir yardımcı program kullanarak Windows Yönetim Araçları'na (WMI) bağlanmaya çalıştığınızda bir erişim reddedildi hatası oluşabilir. %windir%\system32\wbem\logs\wbemprox.log dosyası sorun oluştuğu sırada aşağıdakine benzer hatalar içerir:
    ConnectViaDCOM, CoCreateInstanceEx resulted in hr = 0x80070005
  • Boş bir COM+ uygulaması oluşturduğunuzda aşağıdaki COM+ 1.0 katalog hata iletisini alabilirsiniz:
    XACT_E_RECOVERYINPROGRESS (0x8004d082)

Neden

Bu sorun, hiçbir COM veya COM+ uygulaması COM+ katalog dosyalarına erişemezse oluşabilir. Uygulama, COM+ katalog dizini ve dosyalarındaki varsayılan izinler değiştirildiğinden COM+ katalog dosyalarına erişemez. Microsoft Güvenlik Bülteni MS05-051 öncesinde, COM+ kataloguna açıkça atanmış izinler gerekmiyordu. COM+ katalog dosyaları .clb dosyalarıdır ve %windir%\registration klasöründe bulunur. Varsayılan olarak, COM+ katalog dizini ve dosyaları aşağıdaki izinlere sahiptir:
Bu tabloyu kapaBu tabloyu aç
Administrators (Yöneticiler)System (Sistem)Everyone (Herkes)Authenticated Users (Kimliği Doğrulanmış Kullanıcılar)Server Operators (Sunucu İşletmenleri)
Windows 2000 Etki Alanı Denetleyicisi OlmayanlarTam DenetimTam DenetimOkuma
Windows 2000 Etki Alanı DenetleyicisiTam DenetimTam DenetimDeğiştirmeOkuma ve Yürütme
Windows Server 2003 Etki Alanı Denetleyicisi OlmayanlarTam DenetimTam DenetimOkuma
Windows Server 2003 Etki Alanı DenetleyicisiTam DenetimTam DenetimOkuma ve Yürütme

Çözüm

MS05-051'de uygulanan güvenlik değişikliklerine bağlı olarak, %windir%\registration klasörü için Okuma düzeyinde NTFS dosya sistemi izni gerekir. Varsayılan izinler, Everyone grubu için Okuma erişimi iznini içerir. Bu yapılandırma değiştirilirse, uygulamalar ve hizmetler beklenmeyen davranışlar gösterebilir. Daha kısıtlayıcı NTFS güvenlik izinlerinin kullanıldığı kuruluşlarda, COM işlevselliğine erişmesi gereken kullanıcılar, uygulamalar ve hizmetler için grup üyeliği aracılığıyla Okuma düzeyinde izinler verilmelidir. Uygulama uyumluluğunun sağlanması amacıyla, klasör için varsayılan ayarların kullanılmasını öneririz. Varsayılanların dışında ayarlar kullanmak isteyen yöneticilerin kapsamlı uygulama uyumluluğu sınaması gerçekleştirmesi önerilir. Sistem klasörlerinin izinleri değiştirildiğinde oluşabilecek sorunlar hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
885409 Güvenlik yapılandırma kılavuzu desteği
NTFS izinlerinin yanı sıra Çapraz Geçişi Atlama izni de gerekir. Varsayılan olarak, bu izin Everyone grubuna verilir. NFTS izinlerinde belirtildiği gibi, bu izin kullanıcılara, uygulamalara ve hizmetlere grup üyeliği aracılığıyla verilmelidir. Çapraz Geçişi Atlama kullanıcı hakkı hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
823659 Güvenlik ayarlarını ve kullanıcı hakları atamalarını değiştirdiğinizde oluşabilecek istemci, hizmet ve program uyumsuzlukları
Bu sorunu gidermek için, COM+ katalogu için varsayılan izinleri geri yükleyin.

Windows 2000 veya Windows Server 2003 çalıştıran ve etki alanı denetleyicisi olmayan bir bilgisayar için aşağıdaki adımları izleyin:
  1. %windir%/registration klasöründe, Everyone grubunun Okuma izinleri olduğunu doğrulayın.
  2. %windir%/registration klasöründe, SYSTEM hesabının Tam Denetim izinleri olduğunu doğrulayın.
  3. %windir%/registration klasöründe, Administrators grubunun Tam Denetim izinleri olduğunu doğrulayın.
  4. %windir%/registration klasöründeki .clb dosyalarının gelişmiş güvenlik özelliklerinde, Üst nesneden alınabilir denetim girişlerinin bu nesneye ve tüm bağımlı nesnelere yayılmasına izin ver. Bunları açıkça burada tanımlananlara ekle seçeneğinin işaretli olduğundan emin olun.
  5. Everyone grubuna aşağıdaki izinlerin atanmış olduğundan emin olun:
    • %systemdrive%, %windir% ve %windir%\registration da dahil tüm üst düzey dizinlerde Çapraz Geçiş izinleri (“Klasör İçeriğini Listele”)
    • Çapraz denetlemeyi geç kullanıcı hakkı
    Everyone grubuna Çapraz denetlemeyi geç kullanıcı hakkını atamak için şu adımları izleyin:
    1. Başlat'ı tıklatın, Çalıştır'ı tıklatın, gpedit.msc yazın ve Tamam'ı tıklatın.
    2. Sırasıyla Bilgisayar Yapılandırması'nı, Windows Ayarları'nı, Güvenlik Ayarları'nı, Yerel İlkeler'i ve sonra da Kullanıcı Hakları Ataması'nı genişletin.
    3. Çapraz denetlemeyi geç'i sağ tıklatın ve sonra da Özellikler'i tıklatın.
    4. Kullanıcı veya Grup Ekle'yi tıklatın.
    5. Everyone yazın ve Tamam'ı tıklatın.

      Not "Users" adlı bir nesnenin bulunamadığını bildiren bir ileti alırsanız, Nesne Türleri'ni tıklatın, Gruplar onay kutusunu tıklatıp seçin ve sonra da iki kez Tamam'ı tıklatın.
Windows 2000 çalıştıran bir etki alanı denetleyicisi için aşağıdaki adımları izleyin:
  1. %windir%/registration klasöründe, Authenticated Users grubunun Okuma ve Yürütme izinleri olduğunu doğrulayın.
  2. %windir%/registration klasöründe, Server Operators grubunun Değiştirme izinleri olduğunu doğrulayın.
  3. %windir%/registration klasöründe, SYSTEM hesabının Tam Denetim izinleri olduğunu doğrulayın.
  4. %windir%/registration klasöründe, Administrators grubunun Tam Denetim izinleri olduğunu doğrulayın.
  5. %windir%/registration klasöründeki .clb dosyalarının gelişmiş güvenlik özelliklerinde, Üst öğeden devralınabilen izinlerin bu nesneye yayılmasına izin ver seçeneğinin işaretli olduğunu doğrulayın.
Windows Server 2003 çalıştıran bir etki alanı denetleyicisi için aşağıdaki adımları izleyin:
  1. %windir%/registration klasöründe, Everyone grubunun Okuma ve Yürütme izinleri olduğunu doğrulayın.
  2. %windir%/registration klasöründe, SYSTEM hesabının Tam Denetim izinleri olduğunu doğrulayın.
  3. %windir%/registration klasöründe, Administrators grubunun Tam Denetim izinleri olduğunu doğrulayın.
  4. %windir%/registration klasöründeki .clb dosyalarının gelişmiş güvenlik özelliklerinde, Üst nesneden alınabilir denetim girişlerinin bu nesneye ve tüm bağımlı nesnelere yayılmasına izin ver. Burada açıkça tanımlanmış olan girişleri de ekle seçeneğinin işaretli olduğunu doğrulayın.
  5. Everyone grubuna aşağıdaki izinlerden birinin verildiğinden emin olun:
    • %systemdrive%, %windir% ve %windir%\registration dahil olmak üzere tüm üst dizinlerin çapraz geçiş izinleri (“Klasör İçeriğini Listele”)
    • Çapraz denetlemeyi geç kullanıcı hakkı
    Everyone grubuna Çapraz denetlemeyi geç kullanıcı hakkını atamak için şu adımları izleyin:
    1. Başlat'ı tıklatın, Çalıştır'ı tıklatın, gpedit.msc yazın ve Tamam'ı tıklatın.
    2. Sırasıyla Bilgisayar Yapılandırması'nı, Windows Ayarları'nı, Güvenlik Ayarları'nı, Yerel İlkeler'i ve sonra da Kullanıcı Hakları Ataması'nı genişletin.
    3. Çapraz denetlemeyi geç'i sağ tıklatın ve sonra da Özellikler'i tıklatın.
    4. Kullanıcı veya Grup Ekle'yi tıklatın.
    5. Everyone yazın ve Tamam'ı tıklatın.

      Not "Users" adlı bir nesnenin bulunamadığını bildiren bir ileti alırsanız, Nesne Türleri'ni tıklatın, Gruplar onay kutusunu tıklatıp seçin ve sonra da iki kez Tamam'ı tıklatın.
Not Sistem daha sonra %windir%/registration klasöründe ek .clb dosyaları oluşturabilir. Yeni .clb dosyalarına uygun izinler atanmış olduğundan emin olmak için, Okuma izinlerini o sırada varolan .clb dosyalarına doğrudan atamak yerine tüm dizine atayın. Etkilenen bilgisayarda bu izin değişikliklerini otomatikleştirmek veya değişiklikleri birden çok bilgisayara kolayca geçirmek için Cacls.exe dosyasını kullanabilirsiniz.

Windows 2000 veya Windows Server 2003 çalıştıran ve etki alanı denetleyicisi olmayan bir bilgisayar için aşağıdaki komutları kullanın:
echo y| cacls %windir%\registration /G everyone:R system:F administrators:F
echo y| cacls %windir%\registration\*.clb /G everyone:R system:F administrators:F
Windows 2000 çalıştıran bir etki alanı denetleyicisi için aşağıdaki komutları kullanın:
echo y| cacls %windir%\registration /G "Authenticated Users":R "Server Operators":R system:F administrators:F
Windows 2003 çalıştıran bir etki alanı denetleyicisi için aşağıdaki komutları kullanın:
echo y| cacls %windir%\registration /G everyone:R system:F administrators:F
echo y| cacls %windir%\registration\*.clb /G everyone:R system:F administrators:F
Not y karakteri ile dik çizgi (|) karakteri arasında boşluk olmadığından emin olun. Bu karakterler arasında boşluk olursa, komutlar doğru yürütülmez.

Daha fazla bilgi

Bu sorun oluştuğunda, olay günlüğünde aşağıdaki olaylardan biri veya daha fazlasıyla karşılaşabilirsiniz:
  • Ağ Hizmeti hesabının doğru izinleri yoksa olay günlüğüne aşağıdaki EventSystem olayı kaydedilebilir:

    Olay Türü: Hata
    Olay Kaynağı: EventSystem
    Olay Kategorisi: (50)
    Olay Kimliği: 4609
    Tarih: <Tarih>
    Saat: <Saat>
    Kullanıcı: Yok
    Bilgisayar: Sunucu
    Açıklama: COM+ Olay Sistemi iç işlemi sırasında bozuk bir döndürme kodu algıladı. xx/ d:\qxp_slp\com\com1x\src\events\tier1\eventsystemobj.cpp satırından, HRESULT: 80070005. Lütfen, bu hatayı bildirmek için Microsoft Ürün Destek Hizmeti'ne başvurun.

  • Ağ Hizmeti hesabının doğru izinleri yoksa, olay günlüğüne aşağıdaki COM+ olayı kaydedilebilir:

    Olay Türü: Bilgi
    Olay Kaynağı: COM+
    Olay Kategorisi: (117)
    Olay Kimliği: 778
    Tarih: <Tarih>
    Saat: <Saat>
    Kullanıcı: Yok
    Bilgisayar: Sunucu
    Açıklama: Uygulama görüntü dökümü başarısız oldu.
    Sunucu Uygulama Kimliği: <GUID>
    Sunucu Uygulama Örneği Kimliği: <GUID>
    Sunucu Uygulama Adı: COM+ Explorer
    Hata Kodu = 0x80004005 : Belirlenemeyen hata
    COM+ Hizmetleri İç Bilgileri: Dosya: d:\qxp_slp\com\com1x\src\shared\util\svcerr.cpp, Satır: 1259 Comsvcs.dll dosya sürümü: TRK 2001.12.4414.308 shp
    Daha fazla bilgi için, http://support.microsoft.com adresindeki Yardım ve Destek Merkezi'ne bakın.

  • Ağ Hizmeti hesabının doğru izinleri yoksa olay günlüğüne aşağıdaki COM+ olayı kaydedilebilir:

    Olay Türü: Hata
    Olay Kaynağı: COM+
    Olay Kategorisi: Bilinmiyor
    Olay Kimliği: 4689
    Tarih: <Tarih>
    Saat: <Saat>
    Kullanıcı: Yok
    Bilgisayar: Sunucu
    Açıklama: Çalışma zamanı ortamı iç durumunda bir tutarsızlık algıladı. Bu, CIM+ uygulamasında çalışan özel bileşenler, kullandıkları bileşenler ve diğer etkenler nedeniyle işlemde oluşan olası bir kararsızlığı gösterir. d:\qxp_slp\com\com1x\src\comsvcs\package\cpackage.cpp(1184), hr = 80070005 konumunda bir hata oluştu: InitEventCollector başarısız oldu
    Daha fazla bilgi için, http://support.microsoft.com adresindeki Yardım ve Destek Merkezi'ne bakın.

  • IIS hizmetinde çalışan bir ASP sayfasına gözatmaya çalışırsanız ve Internet Explorer'da Açıklayıcı HTTP hata iletileri göster seçeneği işaretliyse, aşağıdaki hata iletisini alabilirsiniz:
    Sunucu Uygulama Hatası.
    Sunucu isteğinizi işlediği sırada bir uygulamayı yüklerken bir hatayla karşılaştı. Daha ayrıntılı bilgi için olay günlüğüne başvurun. Yardım için sunucu yöneticisine başvurun.
    HTTP 500 - İç sunucu hatası Internet Explorer
    Olay günlüğüne aşağıdakine benzer bir olay da kaydedilebilir:

    Olay Türü: Hata
    Olay Kaynağı: DCOM
    Olay Kategorisi: Yok
    Olay Kimliği: 10010
    Tarih: <Tarih>
    Saat: <Saat>
    Kullanıcı: NT AUTHORITY\SYSTEM
    Bilgisayar: Sunucu
    Açıklama: Sunucu <GUID'si> gereken zaman aşımı içinde DCOM'a kayıt yaptıramadı.

  • Bileşen Hizmetleri'nde COM+ uygulamalarını el ile başlatmaya çalıştığınızda aşağıdaki hata iletisini alabilirsiniz:
    Katalog Hatası: Son işlem gerçekleştirilirken bir hata oluştu. Hata kodu 80080005 - Sunucunun yürütme işlemi başarısız oldu. Olay günlüğü ek sorun giderme bilgileri içerebilir.
    Olay günlüğüne aşağıdakine benzer bir olay da kaydedilebilir:

    Olay Türü: Hata
    Olay Kaynağı: DCOM
    Olay Kategorisi: Yok
    Olay Kimliği: 10010
    Tarih: <Tarih>
    Saat: <Saat>
    Kullanıcı: NT AUTHORITY\SYSTEM
    Bilgisayar: Sunucu
    Açıklama: <GUID> sunucusu belirtilen zaman aşımı süresi içinde DCOM'a kaydolamadı.
    Olay Türü: Uyarı
    Olay Kaynağı: W3SVC
    Olay Kategorisi: Yok
    Olay Kimliği: 36
    Tarih: <Tarih>
    Saat: <Saat>
    Kullanıcı: Yok
    Bilgisayar: Sunucu
    Açıklama: Sunucu '/LM/W3SVC/1/ROOT' uygulamasını yükleyemedi. Oluşan hata: 'Sunucunun yürütme işlemi başarısız oldu'.
    Bu iletiyle ilgili ek bilgi için, lütfen şu adresteki Microsoft Çevrimiçi Destek sitesini ziyaret edin: http://search.support.microsoft.com/search/?adv=1.

    Daha fazla bilgi için, http://support.microsoft.com adresindeki Yardım ve Destek Merkezi'ne bakın.

  • Bir uygulama yüklemeye veya Windows Installer hizmetini el ile başlatmaya çalıştığınızda aşağıdaki hata iletisini alabilirsiniz:
    Windows Installer hizmetine erişilemedi. Bu durum, Windows'u güvenli modda çalıştırıyorsanız veya Windows Installer düzgün yüklenmemişse oluşabilir. Yardım için destek personeline başvurun.
  • Windows Güvenlik Duvarı hizmeti aşağıdaki hata koduyla başlatılamaz:
    Hata Sonucu : 0x80070005 ( -2147024891 ) Kimlik Tanımı : E_ACCESSDENIED İleti Metni : Erişim reddedildi.

Sorunu yeniden oluşturma adımları

System hesabını ve Everyone hesabını *.clb dosya izinlerinden kaldırın. Bunu yapmak için şu adımları izleyin:
  1. Başlat'ı ve sonra Çalıştır'ı tıklatın, Explorer.exe c:\winnt\registration yazın ve Tamam'ı tıklatın.
  2. Windows Gezgini'nde, Özellikler'i sağ tıklatın ve sonra Güvenlik sekmesini tıklatın.
  3. Kayıt Özellikleri iletişim kutusunda, Grup ve Kullanıcı Adı altında Sistem'i ve sonra da Gelişmiş'i tıklatın.
  4. Kayıt için Gelişmiş Güvenlik Ayarları iletişim kutusunda, Kaldır'ı ve sonra da Tamam'ı tıklatın.
  5. Everyone hesabının .clb dosyalarına erişimini durdurmak için 3. ve 4. adımları yineleyin.

Özellikler

Makale numarası: 909444 - Last Review: 12 Ağustos 2008 Salı - Gözden geçirme: 15.2
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Service Pack 1
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Professional SP2
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional SP4
  • Microsoft Windows 2000 Server SP4
Anahtar Kelimeler: 
kbresolve kbtshoot kbprb KB909444

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com