Artikel-ID: 909509 - Geändert am: Dienstag, 3. April 2007 - Version: 1.3

Fehlermeldung "Reporting Services-Fehler" oder "Fehler bei der Berichtsverarbeitung" oder "Fehler bei der Anmeldung für den Benutzer '(Null)'" beim Ausführen eines Berichts in Microsoft Dynamics CRM

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Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
909509  (http://support.microsoft.com/kb/909509/EN-US/ ) Error message when you run a report in Microsoft Dynamics CRM: "Reporting Services Error" or "An Error has occurred during report processing" or "Login failed for user '(null)'"
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Problembeschreibung

Wenn Sie einen Bericht in Microsoft Dynamics CRM 3.0 ausführen, wird eine der folgenden Fehlermeldungen angezeigt:

Fehlermeldung 1
Reporting Services-Fehler.
Fehlermeldung 2
Fehler bei der Berichtsverarbeitung. Es kann keine Verbindung mit der CRM-Datenquelle hergestellt werden.
Fehlermeldung 3
Anmeldung für Benutzer '(Null)' fehlgeschlagen. Ursache: Keiner vertrauten SQL Server-Verbindung zugeordnet.
Dieses Problem tritt insbesondere nach der Aktualisierung des Betriebssystems von Microsoft Windows Server 2000 auf Microsoft Windows Server 2003 auf dem Server mit Microsoft Dynamics CRM oder Microsoft SQL Server auf.

Ursache

Dieses Problem hat seine Ursache darin, dass die Eigenschaft Computer für Delegierungszecke vertrauen für SQL Server nicht aktiviert ist.

Lösung

Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:
  1. Melden Sie sich bei dem Domänencontroller in der Microsoft Dynamics CRM-Domäne als Benutzer mit den Berechtigungen eines Domänenadministrators an.
  2. Klicken Sie auf Start, zeigen Sie auf Verwaltung, und klicken Sie anschließend auf Active Directory-Benutzer und -Computer.
  3. Erweitern Sie den Domänenknoten und dann die Gruppeneinheit oder Organisationseinheit, zu welcher der Computer gehört, auf dem sich die SQL Server-Datenbanken für Microsoft Dynamics CRM befinden.
  4. Klicken Sie mit der rechten Maustaste auf den Computer, auf dem sich die SQL Server-Datenbanken für Microsoft Dynamics CRM befinden, und klicken Sie dann auf Eigenschaften.
  5. Aktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Computer für Delegierungszwecke vertrauen.
  6. Starten Sie den SQL Server-Dienst neu.
    1. Melden Sie sich bei SQL Server an.
    2. Klicken Sie auf Start, zeigen Sie auf Verwaltung, und klicken Sie auf Dienste.
    3. Klicken Sie mit der rechten Maustaste auf MSSQLSERVER, und klicken Sie anschließend auf Neu starten.
    4. Klicken Sie im Dialogfeld Andere Dienste neu starten auf Ja.
  7. Starten Sie die Internet-Informationsdienste (IIS) auf dem Server neu, auf dem Microsoft Dynamics CRM ausgeführt wird.
    1. Melden Sie sich bei dem Server an, auf dem Microsoft Dynamics CRM ausgeführt wird.
    2. Klicken Sie auf Start und auf Ausführen, geben Sie iisreset ein, und klicken Sie auf OK.
  8. Führen Sie den Bericht erneut aus.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Dynamics CRM 3.0
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