ID do artigo: 909509 - Última revisão: quinta-feira, 29 de março de 2007 - Revisão: 1.4

Ao executar um relatório no Microsoft Dynamics CRM, a seguinte mensagem de erro é exibida: "Erro no Reporting Services", "Erro durante o processo do relatório" ou "Falha de logon do usuário (nulo)".

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Recolher tudo

Sintomas

Ao executar um relatório no Microsoft Dynamics CRM 3.0, as seguintes mensagens de erro podem ser exibidas.

Mensagem de erro 1
Erro no Reporting Services.
Mensagem de erro 2
Erro durante o processamento do relatório. Não é possível criar uma conexão com a fonte de dados do 'CRM'.
Mensagem de erro 3
Falha de logon do usuário '(nulo)'. Motivo: Não está associado a uma conexão confiável com o SQL Server.
Este problema ocorre após a atualização do sistema operacional de um servidor executando o Microsoft Dynamics CRM ou o Microsoft SQL Server. Principalmente, se o sistema operacional do Microsoft Windows Server 2000 for atualizado para o Microsoft Windows Server 2003.

Causa

O problema ocorre porque a propriedade Trust computer for delegation não está habilitada no SQL Server.

Resolução

Para resolver este problema, execute as seguintes etapas:
  1. Faça logon no controlador de domínio, no domínio do Microsoft Dynamics CRM, como sendo um usuário com a função de administrador de domínio.
  2. Clique em Iniciar, aponte para Ferramentas administrativas e clique em Usuários e computadores do Active Directory.
  3. Expanda o nó do domínio e a unidade de grupo ou a unidade da organização que tem o computador com os bancos de dados do SQL Server para o Microsoft Dynamics CRM.
  4. Clique com o botão direito do mouse no computador com os bancos de dados do SQL Server para o Microsoft Dynamics CRM e clique em Propriedades.
  5. Na guia Geral, marque a caixa de seleção Confiar no computador para delegação.
  6. Reinicie o serviço do SQL Server.
    1. Faça logon no SQL Server.
    2. Clique em Iniciar, aponte para Ferramentas administrativas e clique em Serviços.
    3. Clique com o botão direito do mouse em MSSQLSERVER e clique em Reiniciar.
    4. Na caixa de diálogo Reiniciar outros serviços, clique em Sim.
  7. Reinicie o IIS (Serviços de informações da Internet) no servidor que está executando o Microsoft Dynamics CRM.
    1. Faça logon no servidor que está executando o Microsoft Dynamics CRM.
    2. Clique em Iniciar, em Executar, digite iisreset e clique em OK.
  8. Execute o relatório novamente.

A informação contida neste artigo aplica-se a:
  • Microsoft Dynamics CRM 3.0
Palavras-chave: 
kberrmsg kbtshoot kbprb kbmbsmigrate kbmbsreports kbmbscrm40no KB909509