文章編號: 909509 - 上次校閱: 2007年7月9日 - 版次: 3.1

當您在 [Microsoft 動態 CRM 執行報表時,出現錯誤訊息: 報告服務錯誤 」 或 「 報表處理時,發生一個錯誤 」 或 」 登入失敗的使用者 '(空值)'"

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徵狀

當您執行報表 Microsoft 動態 CRM 3.0 中時, 您會收到下列的錯誤訊息之一。

錯誤訊息 1
報告服務時發生錯誤。
錯誤訊息 2
報表處理時,發生錯誤。 無法建立資料來源 'CRM' 的連線。
錯誤訊息 3
登入的使用者 '(空值)' 失敗。 受信任的 SQL Server 連線不相關原因:。

發生的原因

原因 1

正在執行 Microsoft 動態 CRM 的伺服器或 Microsoft SQL Server 的作業系統升級後,就會發生這個問題。 特別,您將作業系統升級從 Microsoft Windows Server 2000 至 Microsoft Windows Server 2003。信任電腦以便進行委派] 屬性未啟用 SQL Server,就會發生此問題。升級的伺服器,正在執行 Microsoft 動態 CRM 或執行 Microsoft SQL Server 的作業系統之後,可能就會發生這個問題。特別,將作業系統從 Microsoft Windows Server 2000 升級 Microsoft Windows Server 2003 之後,可能就會發生這個問題。

原因 2

可能發生此問題,因為下列其中一項不會加入至 PrivUserGroup 群組:
  • 正在執行 CRMAppPool 應用程式集區帳戶
  • 報表服務執行的應用程式集區
  • 正在執行 SQL Server 報表服務服務帳戶

解決方案

解決方式 1

如果要解決這個問題,請依照下列步驟執行:
  1. 擁有網域系統管理員角色的使用者身份登入 Microsoft 動態 CRM 網域中的網域控制站。
  2. 按一下 [開始],指向 [系統管理工具],然後再按一下 [Active Directory 使用者和電腦
  3. 展開 [網域] 節點,然後再展開 [群組單位或已包含 SQL Server 資料庫的 Microsoft 動態 CRM 電腦組織單位。
  4. 對於 Microsoft 動態 CRM 包含 SQL Server 資料庫的電腦上按一下滑鼠右鍵,然後按一下 [內容]。
  5. 在 [一般] 索引標籤上選取 [信任電腦以便進行委派] 核取方塊]。
  6. 重新啟動 SQL Server 服務。
    1. 登入 SQL Server。
    2. 按一下 [開始],並指向 [系統管理工具],然後按一下 [服務]。
    3. MSSQLSERVER,] 上按一下滑鼠右鍵,然後按一下 [重新啟動
    4. 在 [重新啟動其他服務] 對話方塊中,按一下 [是]
  7. 重新啟動正在執行 Microsoft 動態 CRM 伺服器上之網際網路資訊服務 (IIS)。
    1. 登入正在執行 Microsoft 動態 CRM 的伺服器。
    2. 按一下 [開始]、 按一下 [執行]、 輸入 iisreset,然後按一下 [確定]]。
  8. 再次執行報告。

解析度 2

確認哪些使用者正在執行 CRMAppPool 應用程式集區,或確認使用報表服務的應用程式集區

若要確認哪些使用者正在執行 CRMAppPool 應用程式集區或來驗證使用報表服務的應用程式集區請依照下列步驟執行:
  1. Microsoft 動態 CRM 伺服器上] 或 [報表服務伺服器上中,按一下 [開始],按一下 [系統管理工具],然後再按一下 [網際網路資訊服務 (IIS) 管理員
  2. 展開 [伺服器] 名稱,然後再展開 [應用程式集區
  3. 以滑鼠右鍵按一下 CRMAppPool,或使用報告服務在應用程式集區上按一下滑鼠右鍵。然後,按一下 [內容]。
  4. 按一下 [若要查看何種使用者帳戶設定為 [身分識別] 索引標籤。如果該帳戶設為 [網路服務] 或 [本機系統,使用 [本文稍後的 < PrivUserGroup 群組,將新增使用者或伺服器 > 一節中的 [伺服器名稱]。

檢查報表服務帳戶

檢查報表服務帳戶,請依照下列步驟執行:
  1. 按一下 [開始]、 按一下 [執行]、 鍵入 services.msc,然後按一下 [執行]。
  2. 在服務清單中找到 「 SQL Server 報告服務 」 服務。SQL Server 報表服務的服務上按一下滑鼠右鍵,然後按一下 [內容]
  3. 按一下以查看哪些帳戶正在執行服務之 登入] 索引標籤。如果該帳戶設為 [網路服務] 或 [本機系統,使用 [本文稍後的 < PrivUserGroup 群組,將新增使用者或伺服器 > 一節中的 [伺服器名稱]。

將使用者或伺服器新增至 PrivUserGroup 群組

如果要將使用者或伺服器新增至 Active Directory 目錄服務中 PrivUserGroup 群組,請依照下列步驟執行:
  1. 啟動 Active Directory 使用者和電腦。要執行這項操作、 按一下 [開始]、 指向 [程式集]、 [系統管理工具,然後按一下 Active Directory 使用者和電腦
  2. 展開樹狀目錄,然後按一下 [Microsoft 動態 CRM 組織單位。
  3. 在右邊面板 PrivUserGroup,] 上按一下滑鼠右鍵,然後按一下 [內容],以開啟 [PrivUserGroup 屬性] 視窗。
  4. 按一下 [成員] 索引標籤。
  5. 若要開啟 [選取使用者、 連絡人、 電腦或群組] 視窗,按一下 [新增]。
  6. 此文件中先前的程序中尋找使用者或您識別電腦,然後按一下 [新增]。
  7. 按一下 [確定] 關閉 [選取使用者、 連絡人、 電腦或群組] 視窗。
  8. 按一下 [確定] 關閉 PrivUserGroup 屬性] 視窗。
  9. 關閉 Active Directory 使用者和電腦。
附註如果您使用 Microsoft 動態 CRM 使用者帳戶執行應用程式集區或執行報表服務作為,請確定使用者表單上的 [受限制的存取模式] 核取方塊已清除。如果選取 [受限制的存取模式] 核取方塊],使用者的動作都限制不論指派給該使用者的角色。在 Microsoft 動態 CRM 中找到這項設定,按一下 [設定]、 指向 [商業單位設定、 按一下 [使用者,然後開啟來目標使用者的使用者表單。

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