El registro de seguimiento de registro global puede crecer y agotar todo el espacio de disco en un equipo

Seleccione idioma Seleccione idioma
Id. de artículo: 909547 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Compruebe que ha hecho una copia de seguridad del Registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
Expandir todo | Contraer todo

En esta página

Síntomas

Para habilitar la sesión de seguimiento de registro global en un equipo basado en Microsoft Windows XP para capturar la actividad del núcleo de Windows, controladores y otros proveedores de seguimiento durante el proceso de inicio de Windows. Sin embargo, el registro de seguimiento de registro global puede crecer y agotar todo el espacio de disco en el equipo.

Causa

Este problema se produce porque no hay ninguna opción para limitar el tamaño del registro de seguimiento de seguimiento de eventos para Windows (ETW). El programa que permite el registro global debe detener mediante programación el registro.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Ntkrnlmp.exe5.1.2600.17631,900,54419-Oct-200523: 41x 86SP1SP1QFE
Ntkrnlpa.exe5.1.2600.17631,955,84019-Oct-200523: 41x 86SP1SP1QFE
Ntkrpamp.exe5.1.2600.17631,928,70419-Oct-200523: 41x 86SP1SP1QFE
Ntoskrnl.exe5.1.2600.17632,040,83220-Oct-200514: 00x 86SP1SP1QFE
Ntkrnlmp.exe5.1.2600.27802,136,06420-Oct-200500: 04x 86SP2SP2QFE
Ntkrnlpa.exe5.1.2600.27802,057,34419-Oct-200511: 05x 86SP2SP2QFE
Ntkrpamp.exe5.1.2600.27802,015,23219-Oct-200523: 35x 86SP2SP2QFE
Ntoskrnl.exe5.1.2600.27802,180,09620-Oct-200500: 06x 86SP2SP2QFE

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Este hotfix incluye una opción para especificar el tamaño máximo del registro de seguimiento estableciendo un valor de registro MaxFileSize. Si el programa no detiene mediante programación el seguimiento de ETW, el registro de seguimiento crece el tamaño especificado por el valor de MaxFileSize del registro. Cuando el tamaño de registro de seguimiento ETW alcanza el tamaño que se especifica mediante el valor MaxFileSize, ETW seguimiento detiene automáticamente. El valor MaxFileSize se especifica en megabytes (MB).

Después de aplicar la revisión, especifique el tamaño máximo del registro de seguimiento estableciendo un valor de registro MaxFileSize. Para ello, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WMI\GlobalLogger
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  4. Escriba MaxFileSize y, a continuación, presione ENTRAR.
  5. Haga doble clic en MaxFileSize , escriba el tamaño del registro de seguimiento que desee en el cuadro datos del valor y, a continuación, haga clic en Aceptar .
  6. Salga del Editor del Registro.
Para obtener más información sobre cómo iniciar en el registro global sesión, visite el siguiente sitio Web de Microsoft:
http://msdn2.microsoft.com/en-us/library/ms797174.aspx
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 909547 - Última revisión: miércoles, 29 de agosto de 2007 - Versión: 2.2
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Palabras clave: 
kbmt kbautohotfix kbqfe kbhotfixserver kbwinxpsp3fix kbwinxppresp3fix kbfix kbbug kbpubtypekc KB909547 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 909547

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com