A network adaptor is not loaded on the client computer when you deploy Windows PE from a Windows Server 2003-based RIS server

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Article ID: 909666 - View products that this article applies to.
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SYMPTOMS

When you deploy the Microsoft Windows Preinstallation Environment (Windows PE) from a Remote Installation Services (RIS) server that is running Microsoft Windows Server 2003, a network adaptor is not loaded on the Windows PE client. You may receive an error message on the Windows PE client.

CAUSE

This problem occurs because a string in the AddReg section of the setup information (.inf) file for the network adaptor is more than 128 characters.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.Note Because this hotfix replaces the Windows kernel (Ntkrnlmp.exe), this hotfix may override previous Windows kernel replacements.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer.

Note x64-based versions of Windows Server 2003 do not require this service pack.

Restart requirement

There is no restart requirement.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions
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File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.25682,454,52811-Nov-200502:27Not ApplicableSP1SP1QFE
Ntkrnlpa.exe5.2.3790.25682,268,67211-Nov-200502:04x86SP1SP1QFE
Ntkrpamp.exe5.2.3790.25682,308,09611-Nov-200502:04Not ApplicableSP1SP1QFE
Ntoskrnl.exe5.2.3790.25682,416,64011-Nov-200502:27x86SP1SP1QFE

Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntkrnlmp.exe5.2.3790.25686,487,04011-Nov-200520:29IA-64

Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.25684,420,09611-Nov-200520:29x64SP1SP1QFE
Ntoskrnl.exe5.2.3790.25684,446,72011-Nov-200520:29x64SP1SP1QFE

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

MORE INFORMATION

How to install this hotfix into a flattened operating system image

To install this hotfix into a flattened operating system image, unpack the hotfix files, and then put the updated kernel into a flat operating system image to be installed by RIS.

To expand the hotfix files, follow these steps:
  1. Click Start, click Run, type cmd, and then press ENTER.
  2. At the command prompt, type cd directory, and then press ENTER.

    Note directory is the location of the download hotfix file.
  3. Type WindowsServer2003-KB909666-platform-LANG.exe /x, and then press ENTER.
Put the updated kernel from this hotfix into the directory of the flat operating system image file. For example, put the kernel in the following directory:
C:\RemoteInstall\Setup\English\images\Operating_System\Architecture
Note Operating_System and Architecture represent the names of the operating system and system architecture that you are updating.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site:
http://www.microsoft.com/windowsxp/64bit/default.mspx
For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:
http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx

Properties

Article ID: 909666 - Last Review: October 11, 2007 - Revision: 3.7
APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Keywords: 
kbautohotfix kbwinserv2003sp2fix kbexpertiseadvanced kbqfe kbhotfixserver KB909666

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