Possibile riduzione delle prestazioni di gioco in un computer basato su Windows XP con processore dual-core

Traduzione articoli Traduzione articoli
Identificativo articolo: 909944 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di eseguire un gioco in un computer basato su Microsoft Windows XP con processore dual-core, è possibile che le prestazioni del gioco risultino ridotte. È possibile, ad esempio, che si verifichi uno dei seguenti sintomi:
  • Il gioco si blocca durante l'esecuzione.
  • Il gioco si blocca durante il processo di rendering.
  • Le prestazioni del gioco risultano rallentate.

Cause

Questi problemi relativi alle prestazioni possono a volte verificarsi se il gioco non è stato progettato per essere utilizzato su computer con processore dual-core. Tali problemi sono causati dall'incapacità del gioco di acquisire in modo corretto le informazioni sugli intervalli.

Risoluzione

Per risolvere il problema, attenersi alla seguente procedura, secondo l'esigenza:
  1. Installare l'aggiornamento più recente per il gioco in uso. Visitare la pagina Web di supporto del fornitore del gioco per verificare se è disponibile un aggiornamento. Se si tratta di un prodotto Microsoft, visitare il seguente sito Web Microsoft:
    http://support.microsoft.com/?pr=gms
  2. È possibile che la combinazione per il risparmio di energia Gestione min. risparmio energia causi problemi per alcuni giochi in alcuni sistemi. Potrebbe quindi essere possibile risolvere il problema utilizzando una diversa combinazione per il risparmio di energia. Fare clic sul pulsante Start, scegliere Esegui, digitare powercfg.cpl, quindi scegliere OK. Nella casella Combinazioni risparmio energia selezionare una combinazione per il risparmio di energia diversa da Gestione min. risparmio energia.
  3. Se il problema persiste, installare il driver più recente per il processore in uso. Per contattare AMD al fine di ottenere informazioni sul driver, visitare il seguente sito Web AMD:
    http://www.amd.com/it-it
    Per contattare Intel, visitare il seguente sito Web Intel:
    http://www.intel.com/cd/corporate/europe/emea/ita/index.htm
    Microsoft fornisce informazioni sui recapiti di altri produttori allo scopo di facilitare l'individuazione del supporto tecnico. Tali informazioni sono soggette a modifiche senza preavviso. Microsoft non si assume alcuna responsabilità sull'accuratezza delle informazioni relative al contatto con altri produttori.
  4. Se il problema persiste, installare il driver più recente per la scheda madre in uso.
  5. Se il problema persiste, aggiornare il BIOS del computer. Per informazioni su come aggiornare il BIOS, contattare la casa produttrice della scheda madre del computer.

    Attenzione L'errato aggiornamento del BIOS potrebbe rendere inutilizzabile il computer.
Se il problema persiste dopo avere completato questa procedura, visitare la pagina Web di supporto del fornitore del gioco per richiedere assistenza.

Informazioni

Per gli sviluppatori che utilizzano l'istruzione RDTSC (Real Time Stamp Counter) per il calcolo degli intervalli, visitare il seguente sito Web Microsoft Developer Network (MSDN) per informazioni sulla funzione QueryPerformanceCounter (informazioni in lingua inglese):
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/winui/winui/windowsuserinterface/windowing/timers/timerreference/timerfunctions/queryperformancecounter.asp

Supporto tecnico per le versioni x64 di Microsoft Windows

La casa produttrice dell'hardware offre supporto tecnico e assistenza per le versioni x64 di Microsoft Windows, in quanto tale software è fornito dal produttore stesso. Il produttore dell'hardware potrebbe infatti avere personalizzato l'installazione di Windows con particolari componenti, quali specifici driver di periferica o impostazioni facoltative volte a ottimizzare le prestazioni dell'hardware. Microsoft fornirà assistenza solo in termini di "ragionevole sforzo" in caso di problemi con la versione x64 di Windows, ma potrebbe essere necessario contattare direttamente la casa produttrice dell'hardware, in quanto soggetto più qualificato per fornire supporto per il software preinstallato sull'hardware.

Per ulteriori informazioni su Microsoft Windows XP Professional x64 Edition, visitare il seguente sito Web Microsoft:
http://www.microsoft.com/italy/windowsxp/64bit/default.mspx
Per ulteriori informazioni sulle versioni x64 di Microsoft Windows Server 2003, visitare il seguente sito Web Microsoft:
http://www.microsoft.com/italy/windowsserver2003/64bit/default.mspx

Proprietà

Identificativo articolo: 909944 - Ultima modifica: venerdì 20 gennaio 2006 - Revisione: 2.0
Le informazioni in questo articolo si applicano a
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Professional x64 Edition
Chiavi: 
kbexpertisebeginner kbtshoot KB909944
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com