เกิดข้อผิดพลาดเมื่อคุณพยายามเปิดบริษัท ในบัญชี Professional บัญชี Express หรือ ในปี 2549 บัญชีธุรกิจขนาดเล็ก: "SQL Server ไม่มีอยู่ หยุดการบริการ หรือเข้าถึงถูกปฏิเสธ"

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 910012 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

คุณอาจได้รับข้อความแสดงข้อผิดพลาดเมื่อคุณพยายามเปิดบริษัทในโปรแกรมต่อไปนี้:
  • Microsoft Office Professional การลงบัญชี
  • Microsoft Office บัญชี Express
  • ขนาดเล็กของ Microsoft Office ธุรกิจที่บัญชี 2006
คุณได้รับข้อความแสดงข้อความแสดงข้อผิดพลาดต่อไปนี้เมื่อคุณพยายามเปิดบริษัท:
sql Server ไม่มีอยู่ หยุดการบริการ หรือเข้าถึงถูกปฏิเสธ

สาเหตุ

ปัญหานี้อาจเกิดขึ้นเมื่อเงื่อนไขใด ๆ ต่อไปนี้เป็นจริง:
  • ผู้ใช้ไม่ล็อกออนเป็นผู้ดูแลระบบ ดูวิธีแก้ไขความ 1 ในส่วน "การแก้ปัญหา"
  • ใน Small Business บัญชี 2006 บริการ MICROSOFTSMLBIZ $ MSSQL ถูกหยุด หรือ หยุดการบริการ MSSMLBIZ $ MSSQL ใน Professional บัญชี และบัญชี Express ดูวิธีแก้ไขที่ 2 ในส่วน "การแก้ปัญหา"
  • TCP/IP และ pipes ที่มีชื่อไม่เปิดใช้งาน ดูวิธีแก้ไข 3 ในส่วน "การแก้ปัญหา"
  • คุณต้องการเปิดใช้งานพอร์ตบนคอมพิวเตอร์ไคลเอนต์ ดูวิธีแก้ไข 4 ในส่วน "การแก้ปัญหา"
  • อินสแตนซ์อื่นนอกเหนือจากอินสแตนซ์ MSSMLBIZ สำหรับบัญชี Professional หรือ สำหรับบัญชี Express มีการติดตั้งบนคอมพิวเตอร์ Professional บัญชีหรือบัญชี Express ไม่ได้เชื่อมต่อกับอินสแตนซ์นี้ ดูวิธีแก้ไข 5 ในส่วน "การแก้ปัญหา"

การแก้ไข

เมื่อต้องการแก้ไขปัญหา ให้ใช้วิธีการอย่างใดอย่างหนึ่งต่อไปนี้

ความละเอียดที่ 1: ระบบในฐานะผู้ดูแล

  1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:%SystemRoot%\system32\compmgmt.msc /sแล้ว คลิกตกลง.
  2. ในการการจัดการคอมพิวเตอร์หน้าต่าง ขยายผู้ใช้และกลุ่มภายในแล้ว คลิกผู้ใช้.
  3. ตรวจสอบว่า มีบัญชีผู้ใช้ที่สร้างขึ้นสำหรับคุณ และบัญชีเป็นสมาชิกของกลุ่มผู้ดูแล
  4. คลิกเริ่มการทำงานคลิกปิดการเข้าสู่ระบบแล้ว ล็อกอิน ด้วยบัญชีผู้ใช้ที่เป็นสมาชิกของกลุ่มผู้ดูแลระบบ

ความละเอียดที่ 2: เริ่มบริการที่เหมาะสม

อินสแตนซ์ MICROSOFTSMLBIZ มีอินสแตนซ์ของ Microsoft SQL Server Desktop Engine (MSDE) ที่มีการติดตั้งกับบัญชีธุรกิจขนาดเล็ก อินสแตนซ์ MSSMLBIZ $ MSSQL มีอินสแตนซ์ของ Microsoft SQL Server 2005 Express ที่มีการติดตั้ง กับบัญชี Professional และ มีบัญชี Express เมื่อต้องการเริ่มบริการ ดำเนินการดังต่อไปนี้:
  1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:services.mscแล้ว คลิกตกลง.
  2. ใช้วิธีการที่เหมาะสม:
    • สำหรับ Small Business บัญชี 2006 คลิกขวาmssql $ microsoftsmlbizในการบริการกล่องโต้ตอบ แล้วคลิกคุณสมบัติ.
    • สำหรับบัญชี Professional และบัญชี Express คลิกขวาmssql $ mssmlbizในการบริการกล่องโต้ตอบ แล้วคลิกคุณสมบัติ.
  3. ในการคุณสมบัติ MICROSOFTSMLBIZ $ MSSQLกล่องโต้ตอบ หรือในนั้นคุณสมบัติ MSSMLBIZ $ MSSQLกล่องโต้ตอบ คลิกการทั่วไปแท็บ
  4. ในการชนิดการเริ่มต้นฟิลด์ คลิกโดยอัตโนมัติ.
  5. คลิกเริ่มการทำงานเมื่อต้องการเริ่มบริการ MICROSOFTSMLBIZ $ MSSQL หรือบริการ MSSMLBIZ $ MSSQL

ความละเอียดที่ 3: เปิดใช้งาน TCP/IP และ pipes ที่มีชื่อ

  1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:svrnetcn.exeแล้ว คลิกตกลง.
  2. ในการโปรแกรมการเข้าถึงเครือข่ายของเซิร์ฟเวอร์ sqlกล่องโต้ตอบกล่อง คลิกการทั่วไปแท็บ
  3. ใช้วิธีการที่เหมาะสม:
    • สำหรับ Small Business บัญชี 2006 คลิกmicrosoftsmlbizในการinstance(s) บนเซิร์ฟเวอร์นี้เขตข้อมูล:
    • สำหรับบัญชี Professional และบัญชี Express คลิกmssql $ mssmlbizในการinstance(s) บนเซิร์ฟเวอร์นี้เขตข้อมูล:
  4. ในการโพรโทคอลที่ถูกปิดใช้งานกล่อง การเลือกเนมที่มีชื่อและtcp/ipแล้ว คลิกเปิดใช้งาน.
  5. คลิกtcp/ipแล้ว คลิกคุณสมบัติ.
  6. ใช้วิธีการที่เหมาะสม:
    • Small Business บัญชี 2006 พิมพ์56183ในการพอร์ตเริ่มต้นฟิลด์ คลิกตกลงแล้ว คลิกนำไปใช้.
    • สำหรับบัญชี Professional และบัญชี Express พิมพ์5356ในการพอร์ตเริ่มต้นฟิลด์ คลิกตกลงแล้ว คลิกนำไปใช้.
  7. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:services.mscแล้ว คลิกตกลง.
  8. คลิกขวาในหน้าต่างบริการmssql $ microsoftsmlbizหรือmssql $ mssmlbizแล้ว คลิกSTOP:.
  9. ในการบริการหน้าต่าง คลิกขวาmssql $ microsoftsmlbizหรือmssql $ mssmlbizแล้ว คลิกเริ่มการทำงาน.

ความละเอียดที่ 4: เปิดใช้งานพอร์ตบนคอมพิวเตอร์ไคลเอนต์

  1. คลิกเริ่มการทำงานคลิกแผงควบคุมแล้ว คลิกสองครั้งWindows Firewall:.
  2. ในการWindows Firewall:กล่องโต้ตอบ คลิกการข้อยกเว้นแท็บ และจากนั้น คลิกการพอร์ตปุ่ม
  3. ใช้วิธีการที่เหมาะสม:
    • Small Business บัญชี 2006 พิมพ์คำอธิบายของพอร์ตในนั้นเพิ่มพอร์ตกล่องโต้ตอบ ในการหมายเลขพอร์ตกล่อง ชนิด56183แล้ว คลิกตกลง.
    • สำหรับบัญชี Professional และบัญชี Express พิมพ์คำอธิบายของพอร์ตในนั้นเพิ่มพอร์ตกล่องโต้ตอบ ในการหมายเลขพอร์ตกล่อง ชนิด5356แล้ว คลิกตกลง.
  4. คลิกตกลงในการWindows Firewall:กล่องโต้ตอบ

ความละเอียด 5

  1. คลิกเริ่มการทำงานชี้ไปที่โปรแกรมทั้งหมดชี้ไปที่Microsoft Officeชี้ไปที่บัญชีของ Microsoft Office<year></year>เครื่องมือแล้ว คลิกเครื่องมือข้อมูล.
  2. ในการอรรถประโยชน์ข้อมูลบัญชีของ Microsoft Officeกล่องโต้ตอบ คลิกการการตั้งค่าแท็บ
  3. เปลี่ยนชื่ออินสแตนซ์ที่ชื่อที่ใช้ในการแก้ปัญหาที่ 2
  4. คลิกนำไปใช้แล้ว คลิกปิด.
  5. เริ่มการทำงาน Professional บัญชีหรือบัญชี Express แล้ว เปิดแฟ้มบริษัท

คุณสมบัติ

หมายเลขบทความ (Article ID): 910012 - รีวิวครั้งสุดท้าย: 16 มกราคม 2554 - Revision: 2.0
ใช้กับ
  • Microsoft Office Accounting Professional 2008
  • Microsoft Office Accounting Express 2008
  • Microsoft Office Accounting Professional 2007
  • Microsoft Office Accounting Express 2007
  • Microsoft Office Small Business Management Edition 2006
Keywords: 
kbtshoot kberrmsg kbmbsmigrate kbprb kbmt KB910012 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:910012

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com