Help and Support
 

powered byLive Search
Hotfix Download Available

FIX: The SQL Server 2005 Setup program may take a very long time to be completed

Article ID:910070
Last Review:August 8, 2008
Revision:5.0
Bug #: 20011453 (SQLBUDT)
On This Page

SUMMARY

This article describes the following about this hotfix release:
The issues that are fixed by this hotfix package
The prerequisites for installing the hotfix package
Whether you must restart your computer after you install the hotfix package
Whether you must make any registry changes

Back to the top

SYMPTOMS

The Microsoft SQL Server 2005 Setup program may take a very long time to be completed. Sometimes this time will be more than 24 hours.

You may see in the detailed SQL Server Windows Installer log that most of the execution time occurs in the Write_sqlXXX custom actions. These custom actions may include the following actions:
Write_sqlFileSDDL
Write_sqlRegSDDL
Write_sqlGroupMember
Note This symptom may occur when you install software that also installs SQL Server 2005, such as Microsoft System Center Data Protection Manager (DPM) 2007.

Back to the top

CAUSE

When the primary domain has many external trust relationships with other domains or many lookups are performed at the same time, the time that is required to look up domain group names may increase significantly. Therefore, the time that is required to install SQL Server 2005 may increase.

Back to the top

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Registry information

You do not have to change the registry after you apply this hotfix.

Installation information

You can start the slipstream hotfix installation of SQL Server 2005. The term "slipstream" means that SQL Server Setup first merges the hotfix files together with the setup files that come from the SQL Server 2005 installation media. Then, the Setup program starts an installation that avoids the problem. To start the slipstream hotfix installation, follow these steps:
1.Extract the hotfix package file in a folder.

You obtain some .exe files that resemble the following files:
AS2005-KB901530-x86-ENU.exe
SQL2005-KB901530-x86-ENU.exe
DTS2005-KB901530-x86-ENU.exe
NS2005-KB901530-x86-ENU.exe
RS2005-KB901530-x86-ENU.exe
SQLTools2005-KB901530-x86-ENU.exe
SQLSupport2005-KB901530-x86-ENU.exe
2.At a command prompt, run these .exe files by specifying the /X switch to extract these .exe files into different folders.

For example, run the following commands:
AS2005-KB901530-x86-ENU.exe /X:C:\QFE\AS
SQL2005-KB901530-x86-ENU.exe /X:C:\QFE\SQL
DTS2005-KB901530-x86-ENU.exe /X:C:\QFE\IS
NS2005-KB901530-x86-ENU.ex /X:C:\QFE\NS
RS2005-KB901530-x86-ENU.exe /X:C:\QFE\RS
SQLTools2005-KB901530-x86-ENU.exe /X:C:\QFE\Tools
SQLSupport2005-KB901530-x86-ENU.exe /X:C:\QFE\SqlSupport
After you extract these .exe files, the .msp files appear in the following folders:
C:\QFE\AS\hotfixas\files\sqlrun_as.msp
C:\QFE\SQL\hotfixsql\files\sqlrun_sql.msp
C:\QFE\IS\hotfixdts\files\sqlrun_dts.msp
C:\QFE\NS\hotfixns\files\sqlrun_ns.msp
C:\QFE\RS\hotfixrs\files\sqlrun_rs.msp
C:\QFE\Tools\hotfixtools\files\sqlrun_tools.msp
C:\QFE\SqlSupport\msp\sqlsupport.msp
3.Install SQL Server 2005 by running a command that resembles the following command:
<SQLInstall>\Servers\setup.exe SQLSUPPORTPATCH="C:\QFE\SqlSupport\msp\SqlSupport.msp" HOTFIXPATCH="C:\QFE\AS\hotfixas\files\sqlrun_as.msp;C:\QFE\SQL\hotfixsql\files\sqlrun_sql.msp;C:\QFE\IS\hotfixdts\files\sqlrun_dts.msp;C:\QFE\NS\hotfixns\files\sqlrun_ns.msp;C:\QFE\RS\hotfixrs\files\sqlrun_rs.msp;C:\QFE\Tools\hotfixtools\files\sqlrun_tools.msp" <OtherParameters>
Note In this command, <SQLInstall> is a placeholder for the folder of the SQL Server 2005 installation media. <OtherParameters> is a placeholder for the additional parameters that you specify.

Back to the top

WORKAROUND

To work around this issue, you can use one of the following methods:

Method 1
Temporarily disable the network on the computer on which the SQL Server 2005 Setup program is running. To do this, either disconnect the network cable or type the following command at a command prompt:
ipconfig /release
Note This workaround will not suceed when you are installing a SQL Server failover cluster.

Method 2
Follow the steps that are listed in the following Microsoft Knowledge base article to restrict the lookup of isolated names in external trusted domains:
818024 (http://support.microsoft.com/kb/818024/) How to restrict the lookup of isolated names in external trusted domains by using the LsaLookupRestrictIsolatedNameLevel registry entry

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top

MORE INFORMATION

This symptom may also occur when you install DPM 2007. When you install DPM 2007, it may take a very long time on an installation of SQL Server 2005. Because the DPM 2007 installer will install SQL Server 2005 from DPM 2007 DVD media, we do not recommend that you perform a slipstream installation of SQL Server 2005 by using this hotfix. Use Method 1 in the "Workaround" section when the DPM 2007 installer starts to install SQL Server 2005. For more information about the naming schema for SQL Server updates, click the following article number to view the article in the Microsoft Knowledge Base:
822499 (http://support.microsoft.com/kb/822499/) New naming schema for Microsoft SQL Server software update packages
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

Back to the top


APPLIES TO
Microsoft SQL Server 2005 Developer Edition
Microsoft SQL Server 2005 Enterprise Edition
Microsoft SQL Server 2005 Enterprise Edition for Itanium-based Systems
Microsoft SQL Server 2005 Enterprise X64 Edition
Microsoft SQL Server 2005 Express Edition
Microsoft SQL Server 2005 Standard Edition
Microsoft SQL Server 2005 Standard X64 Edition
Microsoft SQL Server 2005 Workgroup Edition
Microsoft SQL Server 2005 Standard Edition for Itanium-based Systems

Back to the top

Keywords: 
kbautohotfix kbsql2005sp1fix kbhotfixserver kbqfe kbsql2005setup kbtshoot kbprb KB910070

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.