Fehlermeldungen beim Versuch, in Microsoft CRM 3.0 E-Mail-Nachrichten zu senden oder heraufzustufen

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Artikel-ID: 910242 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Der Hotfix, der in diesem Artikel behandelt wird, ist für die chinesische Version von Microsoft Dynamics CRM und für die japanische Version von Microsoft Dynamics CRM nicht verfügbar.
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Problembeschreibung

Im Zusammenhang mit E-Mail-Nachrichten können in Microsoft Dynamics CRM 3.0 folgende Symptome auftreten:
  • Wenn Sie in Microsoft Outlook eine E-Mail-Nachricht senden, erhalten Sie folgende Fehlermeldung:
    Fehler. Wenden Sie sich an den Systemadministrator, um weitere Informationen zu erhalten. Möchten Sie die E-Mail senden?
  • Wenn Sie in Microsoft Outlook eine E-Mail-Nachricht heraufstufen, erhalten Sie folgende Fehlermeldung:
    Fehler. Wenden Sie sich an den Systemadministrator, um weitere Informationen zu erhalten.
  • Wenn Sie in Microsoft Outlook Web Access eine E-Mail-Nachricht senden, erhalten Sie eine ähnlich lautende Fehlermeldung:
    Details zu nicht behandeltem Fehler von Microsoft CRM: Serverfehler in Anwendung '/'.
  • Die E-Mail-Funktion von Microsoft Dynamics CRM ist komplett ausgefallen. Der für Microsoft Dynamics CRM zuständige Exchange-Router verarbeitet keine E-Mail-Nachrichten. Die E-Mail-Nachrichten werden in den Ordner für unzustellbare Mails (in der E-Mail-Senke) verschoben. Wenn der Plattformverfolgungsprozess aktiviert ist, werden die folgenden Fehlermeldungen in der Ablaufverfolgungsdatei protokolliert:

    Meldung 1
    SOAP Request failed:
    Url:http://hvcphsvr01:5555/mscrmservices/Email.asmx
    MethodName:CheckIncoming
    Response:
    <?xml version="1.0" encoding="utf-8"?>
    <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <soap:Body>
    <soap:Fault>
    <faultcode>soap:Server</faultcode>
    <faultstring>System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.NullReferenceException: Object reference not set to an instance of an object.
    at Microsoft.Crm.NativeInteropProxy.CRMInteropEmailClass.CheckIncoming(CUserAuth& Caller, String MessageId, String Subject, String From, String To, String CC, String BCC, Int32& ReasonCode)
    at Microsoft.Crm.ObjectModel.EmailService.CheckIncoming(String messageId, String subject, String from, String to, String cc, String bcc, Int32& reasonCode)
    at Microsoft.Crm.WebServices.EmailWebService.CheckIncoming(String messageId, String subject, String from, String to, String cc, String bcc, Int32& reasonCode)
    --- End of inner exception stack trace ---</faultstring>
    <detail />
    </soap:Fault>
    </soap:Body>
    </soap:Envelope>
    Meldung 2
    CrmSoapExtension detected non-CrmException - report will be sent to Watson:
    System.Web.Services.Protocols.SoapException: Server was unable to process request. --->
    System.NullReferenceException: Object reference not set to an instance of an object.
    at Microsoft.Crm.NativeInteropProxy.CRMInteropEmailClass.CheckIncoming(CUserAuth& Caller, String MessageId, String Subject, String From, String To, String CC, String BCC, Int32& ReasonCode)
    at Microsoft.Crm.ObjectModel.EmailService.CheckIncoming(String messageId, String subject, String from, String to, String cc, String bcc, Int32& reasonCode)
    at Microsoft.Crm.WebServices.EmailWebService.CheckIncoming(String messageId, String subject, String from, String to, String cc, String bcc, Int32& reasonCode)
    Außerdem wird im Anwendungsprotokoll des Servers, der Microsoft Exchange Server ausführt, ein Ereignis ähnlich dem folgenden protokolliert:

    Event Type: Error
    Event Source: MSCRMExRouterService
    Event Category: None
    Event ID: 0
    Date: 11/10/2006
    Time: 4:47:18 PM
    User: N/A
    Computer: CRMServername
    Description: Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceException: Verifying before delivery message in mailbox: crmmail failed (System.Web.Services.Protocols.SoapException: Server was unable to process request.

  • Wenn der Protokollierungsprozess für die Verfolgung von Entwicklerfehlern während der Heraufstufung einer E-Mail-Nachricht aktiviert ist, erhalten Sie folgende Fehlermeldung:
    Error Description: An Unexpected error occurred. Error Number: 0x80040216 Source File: Not Available Line Number: Not Available Request URL: http://CRM/Activities/email/edit.aspx

Ursache

Das Problem kann auftreten, wenn der Präfixwert des Tokens für die E-Mail-Verfolgung im Fenster "Systemeinstellungen" auf Null festgelegt ist. Wenn Sie den Präfixwert zurücksetzen, wird die E-Mail-Funktion nicht wiederhergestellt.

Lösung

Microsoft Dynamics CRM 3.0

Informationen zum Updaterollup

Zur Lösung dieses Problems benötigen Sie das neueste Updaterollup für Microsoft Dynamics CRM 3.0. Weitere Informationen zum Updaterollup 1 für Microsoft Dynamics CRM 3.0 erhalten Sie, indem Sie auf die folgende Artikelnummer klicken. Der Artikel der Microsoft Knowledge Base wird angezeigt:
922815Updaterollup 1 für Microsoft Dynamics CRM 3.0 ist verfügbar

Das Updaterollup löst das Problem, das in diesem Artikel beschrieben ist. Darüber hinaus müssen Sie möglicherweise vorhandene Daten aus Microsoft Dynamics CRM reparieren.

Hinweis: Führen Sie die Anweisungen aus diesem Artikel erst dann aus, wenn sie eine vollständige Sicherungskopie der Datenbank erstellt haben. Falls ein Problem auftritt, können Sie die Datenbank aus der Sicherung wiederherstellen.
Um vorhandene Daten aus Microsoft Dynamics CRM wiederherzustellen, die den Präfixwert richtig festlegen, führen Sie das folgende Skript gegen die MSCRM-Datenbank aus.
update organizationbase set trackingprefix='<CRM>:;'
Hinweis: <CRM> ist der Platzhalter für das gewünschte Präfix.

Microsoft Dynamics CRM 3.0 Professional Edition für Dienstanbieter

Informationen zum Hotfix

Microsoft bietet nun einen unterstützten Hotfix an. Dieser behebt allerdings nur das Problem, das in diesem Artikel beschrieben wird. Wenden Sie den Hotfix nur auf Systeme an, bei denen dieses Problem genau mit den beschriebenen Symptomen auftritt. Es kann sein, dass der Hotfix noch weiteren Tests unterzogen wird. Wenn das Problem also keine schwerwiegenden Auswirkungen nach sich zieht, warten Sie am besten, bis das nächste Service Pack zu Microsoft Dynamics CRM 3.0 Professional Edition für Dienstanbieter erscheint. Der Hotfix ist darin enthalten.

Wenn das Problem sofort behoben werden muss, fordern Sie beim Kundensupport von Microsoft den Hotfix an. Eine vollständige Liste aller Telefonnummern des Microsoft-Kundensupports sowie Informationen über Supportkosten erhalten Sie auf folgender Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support/de
Hinweis: Normalerweise werden für Supportanfragen Gebühren erhoben. In Einzelfällen können die Gebühren entfallen, wenn ein Microsoft-Supportmitarbeiter feststellt, dass ein bestimmtes Update Ihr Problem behebt. Für zusätzliche Supportfragen und Probleme, die nicht mit dem spezifischen Problem in Zusammenhang stehen, werden die normalen Supportkosten in Rechnung gestellt.

Informationen zur Installation

Dieses Update ist zur Installation auf Computern vorgesehen, auf denen Microsoft Dynamics CRM 3.0 Professional Edition für Dienstanbieter ausgeführt wird.

Systemvoraussetzungen

Für diesen Hotfix sind keine besonderen Systemvoraussetzungen zu beachten.

Informationen zur Deinstallation

Um diesen Hotfix von einem Computer zu entfernen, auf dem Microsoft Windows 2000 oder Windows Server 2003 ausgeführt wird, klicken Sie in der Systemsteuerung auf Software.

Systemadministratoren können das Tool Spuninst.exe verwenden, wenn sie diesen Hotfix von einem Computer entfernen möchten, auf dem Microsoft Windows 2000 oder Windows Server 2003 ausgeführt wird.

Das Tool Spuninst.exe ist unter folgendem Ordner abgelegt: %Windir%\$NTUninstallKB910242$\Spuninst.

Weitere Informationen erhalten Sie, indem Sie auf die folgende Artikelnummer klicken. Der Artikel der Microsoft Knowledge Base wird angezeigt:
832475Beschreibung der neuen Funktionen in dem Paketinstallationsprogramm für Windows-Softwareupdates

Aufforderung zum Computerneustart

Wenn Sie den Hotfix installiert haben, starten Sie den Computer bei Aufforderung neu.

Informationen zur Datei

Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeit
Crmmsg.dll1.2.3297.12316.08807.09.200519:52
Microsoft.crm.application.pages.dll3.0.5300.1005965.38401.12.200518:47
Mscrmcustom.dll3.0.5300.101147.45628.10.200522:39
Systemsettings.aspx--/--33.17101.12.200520:09
Crmhotfix.cdf--/--2.57805-Dec-200523:54
Mscrmcustom.dll3.0.5300.101147.45628.10.200522:39
Updspapi.dll6.1.22.0371.93607.09.200519:53

Status

Microsoft Dynamics CRM 3.0

Microsoft hat bestätigt, dass das beschriebene Problem in einem Microsoft-Produkt auftritt, das in der Liste der betroffenen Anwendungen aufgeführt ist.
Das Problem wurde im Updaterollup 1 für Microsoft Dynamics CRM 3.0 behoben.

Microsoft Dynamics CRM 3.0 Professional Edition für Dienstanbieter

Microsoft hat bestätigt, dass das beschriebene Problem in einem Microsoft-Produkt auftritt, das in der Liste der betroffenen Anwendungen aufgeführt ist.

Weitere Informationen

Weitere Informationen zur Terminologie, mit der Microsoft-Softwareupdates beschrieben werden, erhalten Sie, indem Sie auf die folgenden Artikelnummern klicken. Der Artikel der Microsoft Knowledge Base wird angezeigt:
824684 Erläuterung von Standardbegriffen bei Microsoft Software Updates
887283 Benennungskonventionen für Softwarehotfixes und Updatepakete zu Microsoft Business Solutions CRM

Eigenschaften

Artikel-ID: 910242 - Geändert am: Mittwoch, 13. Juni 2007 - Version: 6.1
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Dynamics CRM 3.0
  • Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers
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