Foutberichten wanneer u probeert een e-mailbericht te verzenden of te promoveren in Microsoft CRM 3.0

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 910242 - Bekijk de producten waarop dit artikel van toepassing is.
De in dit artikel beschreven hotfix is niet beschikbaar voor de Chinese of Japanse versie van Microsoft Dynamics CRM.
Alles uitklappen | Alles samenvouwen

Op deze pagina

Symptomen

Wanneer u werkt met een e-mailbericht in Microsoft Dynamics CRM 3.0, treden de volgende symptomen op:
  • Wanneer u een e-mailbericht verzendt vanuit Microsoft Outlook, wordt het volgende foutbericht weergegeven:
    Er is een fout opgetreden. Neem voor meer informatie contact op met de systeembeheerder. Wilt u de e-mail verzenden?
  • Wanneer u een e-mailbericht promoveert in Microsoft Outlook, wordt het volgende foutbericht weergegeven:
    Er is een fout opgetreden. Neem voor meer informatie contact op met de systeembeheerder.
  • Wanneer u een e-mailbericht verzendt vanuit Microsoft Outlook Web Access, wordt het volgende foutbericht weergegeven:
    Microsoft CRM Unhandled Error Details: Server Error in '/' Application.
  • De e-mailfunctionaliteit in Microsoft Dynamics CRM werkt geheel niet. De Microsoft Dynamics CRM Exchange Router verwerkt geen e-mailberichten. E-mailberichten worden verplaatst naar de map met onbestelbare berichten in de sink-e-mailaccount. Daarnaast worden de volgende foutberichten vastgelegd in het traceerlogboekbestand als het Platform Tracing-proces is ingeschakeld.

    Bericht 1
    SOAP-aanvraag mislukt:
    Url:http://hvcphsvr01:5555/mscrmservices/Email.asmx
    MethodName:CheckIncoming
    Respons:
    <?xml version="1.0" encoding="utf-8"?>
    <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <soap:Body>
    <soap:Fault>
    <faultcode>soap:Server</faultcode>
    <faultstring>System.Web.Services.Protocols.SoapException: Server kan aanvraag niet verwerken. ---> System.NullReferenceException: Objectverwijzing niet ingesteld op een exemplaar van een object.
    at Microsoft.Crm.NativeInteropProxy.CRMInteropEmailClass.CheckIncoming(CUserAuth& Caller, String MessageId, String Subject, String From, String To, String CC, String BCC, Int32& ReasonCode)
    at Microsoft.Crm.ObjectModel.EmailService.CheckIncoming(String messageId, String subject, String from, String to, String cc, String bcc, Int32& reasonCode)
    at Microsoft.Crm.WebServices.EmailWebService.CheckIncoming(String messageId, String subject, String from, String to, String cc, String bcc, Int32& reasonCode)
    --- Einde van intern uitzonderingsstackpad ---</faultstring>
    <detail />
    </soap:Fault>
    <soap:Body>
    </soap:Envelope>
    Bericht 2
    CrmSoapExtension heeft niet-CrmException vastgesteld - rapport wordt verzonden naar Watson:
    System.Web.Services.Protocols.SoapException: Server kan aanvraag niet verwerken. --->
    System.NullReferenceException: Objectverwijzing niet ingesteld op een exemplaar van een object.
    at Microsoft.Crm.NativeInteropProxy.CRMInteropEmailClass.CheckIncoming(CUserAuth& Caller, String MessageId, String Subject, String From, String To, String CC, String BCC, Int32& ReasonCode)
    at Microsoft.Crm.ObjectModel.EmailService.CheckIncoming(String messageId, String subject, String from, String to, String cc, String bcc, Int32& reasonCode)
    at Microsoft.Crm.WebServices.EmailWebService.CheckIncoming(String messageId, String subject, String from, String to, String cc, String bcc, Int32& reasonCode)
    Daarnaast wordt een gebeurtenis van de volgende strekking vastgelegd in het toepassingslogboek op de server met Microsoft Exchange Server:

    Type: Fout
    Bron: MSCRMExRouterService
    Categorie: Geen
    Gebeurtenis-id: 0
    Datum: 11/10/2006
    Tijd: 4:47:18 PM
    Gebruiker: N.v.t.
    Computer: CRMServername
    Beschrijving: Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceException: Controle voor bezorging van bericht in postvak: crmmail mislukt (System.Web.Services.Protocols.SoapException: Server kan aanvraag niet verwerken.

  • Als het Dev Errors-proces voor foutregistratie is ingeschakeld wanneer u een e-mailbericht promoveert, wordt het volgende foutbericht weergegeven:
    Foutbeschrijving: Er is een onverwachte fout opgetreden. Foutnummer: 0x80040216 Bronbestand: Niet-beschikbaar regelnummer: Niet-beschikbare aanvraag-URL: http://CRM/Activities/email/edit.aspx

Oorzaak

Dit probleem treedt op als de waarde van het voorvoegsel voor het volgtoken voor e-mail is ingesteld op null in het venster Systeeminstellingen. Als u de waarde voor het voorvoegsel opnieuw instelt, wordt de e-mailfunctionaliteit niet hersteld.

Oplossing

Microsoft Dynamics CRM 3.0

Informatie over updatepakket

U kunt dit probleem oplossen met het laatste updatepakket voor Microsoft Dynamics CRM 3.0. Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over updatepakket 1 voor Microsoft Dynamics CRM 3.0:
922815 Updatepakket 1 voor Microsoft Dynamics CRM 3.0 is beschikbaar

Het updatepakket bevat een correctie voor het probleem dat in dit artikel wordt beschreven. Daarnaast moet u wellicht bestaande Microsoft Dynamics CRM-gegevens herstellen.

Opmerking Voordat u de instructies in dit artikel uitvoert, moet u ervoor zorgen dat u een volledige back-up van de database hebt gemaakt, die u in geval van problemen kunt herstellen.
Als u bestaande Microsoft Dynamics CRM-gegevens wilt herstellen waarmee de waarde van het voorvoegsel juist wordt ingesteld, voert u het volgende script uit in de MSCRM-database.
update organizationbase set trackingprefix='<CRM>:;'
Opmerking De tijdelijke aanduiding <CRM> geeft het voorvoegsel aan dat u wilt gebruiken.

Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers

Informatie over hotfixes

Een ondersteunde hotfix is nu beschikbaar bij Microsoft. Deze hotfix is echter alleen bedoeld als oplossing van het probleem dat in dit artikel wordt beschreven. Voer de hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet. Deze hotfix moet wellicht extra worden getest. Als u geen ernstige problemen ondervindt, is het daarom raadzaam te wachten op het volgende servicepack voor Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers waarin deze hotfix is opgenomen.

Als u dit probleem direct wilt verhelpen, kunt u contact opnemen met Microsoft Customer Support Services om de hotfix te verkrijgen. Een volledige lijst met telefoonnummers van Microsoft Customer Support Services en informatie over kosten van ondersteuning vindt u op de volgende Microsoft-website:
http://support.microsoft.com/contactus/?ws=support
Opmerking In speciale gevallen kunnen kosten die normaal verbonden zijn aan ondersteuningsoproepen, worden geannuleerd als een medewerker van Microsoft Product Support Services van mening is dat een specifieke update de oplossing van uw probleem is. De normale ondersteuningskosten blijven gelden voor extra ondersteuningsvragen die niet in aanmerking komen voor de specifieke update.

Informatie over de installatie

Installeer deze update op computers met Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers.

Voorwaarden

Er zijn geen vereisten voor het toepassen van deze hotfix.

Informatie over verwijderen

Gebruik het onderdeel Software in het Configuratiescherm om deze hotfix te verwijderen van een computer waarop Microsoft Windows 2000 of Windows Server 2003 wordt uitgevoerd:

Systeembeheerders kunnen het hulpprogramma Spuninst.exe gebruiken om deze hotfix te verwijderen van een computer met Windows 2000 of Windows Server 2003.

Het hulpprogramma Spuninst.exe bevindt zich in de map %Windir%\$NTUninstallKB910242$\Spuninst.

Klik voor meer informatie op het volgende artikelnummer in de Microsoft Knowledge Base:
832475 Overzicht van de nieuwe functies in de pakket-installer voor Windows-software-updates

Computer opnieuw opstarten

Start de computer na installatie van de hotfix opnieuw op als dit wordt gevraagd.

Bestandsinformatie

Deze tabel samenvouwenDeze tabel uitklappen
BestandsnaamBestandsversieBestandsgrootteDatumTijd
Crmmsg.dll1.2.3297.12316.08807-sep-200519:52
Microsoft.crm.application.pages.dll3.0.5300.1005965.38401-dec-200518:47
Mscrmcustom.dll3.0.5300.101147.45628-okt-200522:39
Systemsettings.aspxNiet van toepassing33.17101-dec-200520:09
Crmhotfix.cdfNiet van toepassing2.57805-dec-200523:54
Mscrmcustom.dll3.0.5300.101147.45628-okt-200522:39
Updspapi.dll6.1.22.0371.93607-sep-200519:53

Status

Microsoft Dynamics CRM 3.0

Microsoft heeft bevestigd dat dit probleem zich kan voordoen in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.
Dit probleem is opgelost in updatepakket 1 voor Microsoft Dynamics CRM 3.0.

Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers

Microsoft heeft bevestigd dat dit probleem zich kan voordoen in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.

Meer informatie

Voor meer informatie over de terminologie die wordt gebruikt om software-updates voor Microsoft te beschrijven, klikt u op de volgende artikelnummers in de Microsoft Knowledge Base:
824684 Beschrijving van de standaardterminologie die wordt gebruikt om software-updates van Microsoft te beschrijven
887283 Naamgevingsstandaarden voor hotfixes en updatepakketten voor Microsoft Business Solutions CRM-software

Eigenschappen

Artikel ID: 910242 - Laatste beoordeling: woensdag 13 juni 2007 - Wijziging: 6.1
De informatie in dit artikel is van toepassing op:
  • Microsoft Dynamics CRM 3.0
  • Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers
Trefwoorden: 
kbemail kberrmsg kbmbsemail kbmbsmigrate kbpubtypekc kbhotfixserver kbqfe KB910242

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com