Mensagens de erro são recebidas ao tentar enviar ou promover um email no Microsoft CRM 3.0

Traduções deste artigo Traduções deste artigo
ID do artigo: 910242 - Exibir os produtos aos quais esse artigo se aplica.
O hotfix discutido neste artigo não está disponível para a versão em chinês do Microsoft Dynamics CRM nem para a versão em japonês do Microsoft Dynamics CRM.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Ao trabalhar com um email no Microsoft Dynamics CRM 3.0, os seguintes sintomas podem ocorrer:
  • Ao enviar um email do Microsoft Outlook, você recebe a seguinte mensagem de erro:
    Erro. Para obter mais informações, contate o administrador do sistema. Deseja enviar o email?
  • Ao promover um email no Microsoft Outlook, você recebe a seguinte mensagem de erro:
    Erro. Para obter mais informações, contate o administrador do sistema.
  • Ao enviar um email do Microsoft Outlook Web Access, você recebe a seguinte mensagem de erro:
    Detalhes de Erro Não Tratado do Microsoft CRM: Erro de Servidor no Aplicativo '/'.
  • Nenhuma função de email do Microsoft Dynamics CRM funciona. O Microsoft Dynamics CRM Exchange Router não processa emails. Os emails são movidos para a pasta de mensagens que não podem ser entregues na conta coletora de emails. Além disso, se o processo de rastreamento de plataforma estiver habilitado, as seguintes mensagens de erro serão registradas no arquivo de log de rastreamento:

    Mensagem 1
    Falha de solicitação SOAP:
    Url:http://hvcphsvr01:5555/mscrmservices/Email.asmx
    MethodName:CheckIncoming
    Resposta:
    <?xml version="1.0" encoding="utf-8"?>
    <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <soap:Body>
    <soap:Fault>
    <faultcode>soap:Server</faultcode>
    <faultstring>System.Web.Services.Protocols.SoapException: O servidor não pôde processar a solicitação. ---> System.NullReferenceException: Referência de objeto não definida como uma instância de um objeto.
    em Microsoft.Crm.NativeInteropProxy.CRMInteropEmailClass.CheckIncoming(CUserAuth& Caller, String MessageId, String Subject, String From, String To, String CC, String BCC, Int32& ReasonCode)
    em Microsoft.Crm.ObjectModel.EmailService.CheckIncoming(String messageId, String subject, String from, String to, String cc, String bcc, Int32& reasonCode)
    em Microsoft.Crm.WebServices.EmailWebService.CheckIncoming(String messageId, String subject, String from, String to, String cc, String bcc, Int32& reasonCode)
    --- Fim do rastreamento da pilha de exceções internas ---</faultstring>
    <detail />
    <soap:Fault>
    <soap:Body>
    </soap:Envelope>
    Mensagem 2
    CrmSoapExtension detectou não-CrmException ? relatório será enviado ao Watson:
    System.Web.Services.Protocols.SoapException: O servidor não pôde processar a solicitação. --->
    System.NullReferenceException: Referência de objeto não definida como uma instância de um objeto.
    em Microsoft.Crm.NativeInteropProxy.CRMInteropEmailClass.CheckIncoming(CUserAuth& Caller, String MessageId, String Subject, String From, String To, String CC, String BCC, Int32& ReasonCode)
    em Microsoft.Crm.ObjectModel.EmailService.CheckIncoming(String messageId, String subject, String from, String to, String cc, String bcc, Int32& reasonCode)
    em Microsoft.Crm.WebServices.EmailWebService.CheckIncoming(String messageId, String subject, String from, String to, String cc, String bcc, Int32& reasonCode)
    Além disso, um evento semelhante ao seguinte é registrado no log de aplicativo no servidor que está executando o Microsoft Exchange Server:

    Tipo de Evento: Erro
    Origem do Evento: MSCRMExRouterService
    Categoria do Evento: Nenhuma
    ID do Evento: 0
    Data: 11/10/2006
    Hora: 16:47:18
    Usuário: N/A
    Computador: CRMServername
    Descrição: Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceException: Verificando antes da mensagem de entrega na caixa de correio: Falha de crmmail (System.Web.Services.Protocols.SoapException: O servidor não pôde processar a solicitação.

  • Se o processo de log de erros Dev Errors estiver habilitado ao promover um email, você recebe a seguinte mensagem de erro:
    Descrição do Erro: Erro inesperado. Número do Erro: 0x80040216 Arquivo de Origem: Número da Linha Não Disponível: URL da Solicitação Não Disponível: http://CRM/Activities/email/edit.aspx

Causa

Essa questão pode ocorrer quando o valor do prefixo do token de acompanhamento de email está definido como nulo na janela Configurações do Sistema. Se você redefinir o valor do prefixo, a funcionalidade de email não será restaurada.

Resolução

Microsoft Dynamics CRM 3.0

Informações do pacote cumulativo de atualizações

Para resolver esse problema, obtenha o pacote cumulativo de atualizações mais recente do Microsoft Dynamics CRM 3.0. Para obter mais informações sobre o Pacote Cumulativo de Atualizações do Microsoft Dynamics CRM 3.0, clique no número do artigo a seguir para exibir o artigo na Base de Dados de Conhecimento Microsoft:
922815 O Pacote Cumulativo de Atualizações 1 para o Microsoft Dynamics CRM 3.0 está disponível

O pacote cumulativo de atualizações resolve o problema descrito neste artigo. Além disso, pode ser necessário reparar dados existentes do Microsoft Dynamics CRM.

Observação: antes de seguir as instruções deste artigo, verifique se você possui uma cópia de backup completa do banco de dados que possa ser restaurada se ocorrer um problema.
Para reparar dados existentes do Microsoft Dynamics CRM que definirão corretamente o valor do prefixo, execute o seguinte script no banco de dados do MSCRM.
update organizationbase set trackingprefix='<CRM>:;'
Observação: o espaço reservado <CRM> representa o prefixo que você deseja utilizar.

Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers

Informações do hotfix

A Microsoft agora disponibilizou um hotfix com suporte. No entanto, o único objetivo do hotfix é corrigir o problema descrito neste artigo. Aplique-o somente nos sistemas que estiverem com este problema específico. Esse hotfix pode receber testes adicionais. Portanto, se você não tiver sido gravemente afetado por este problema, recomendamos que aguarde o próximo service pack do Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers que conterá esse hotfix.

Para resolver este problema imediatamente, contate o Atendimento Microsoft para obter o hotfix. Para obter uma lista completa de números de telefones do Atendimento Microsoft e informações sobre custos de suporte, visite o site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Observação: em casos especiais, cobranças que geralmente incorrem em chamadas de suporte poderão ser canceladas se um profissional do Atendimento Microsoft determinar que uma atualização específica resolverá o problema. Os custos de suporte em geral aplicam-se a questões e problemas de suporte adicionais que não se enquadrem na atualização específica em questão.

Informações de instalação

Instale esta atualização nos computadores que estão executando o Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers.

Pré-requisitos

Não há nenhum pré-requisito para aplicar esse hotfix.

Informações de remoção

Para remover esse hotfix de um computador que está executando o Microsoft Windows 2000 ou o Windows Server 2003, use a opção Adicionar ou Remover Programas no Painel de Controle.

Os administradores de sistema podem usar a ferramenta Spuninst.exe para remover esse hotfix de um computador que está executando o Windows 2000 ou o Windows Server 2003.

A ferramenta Spuninst.exe está localizada na pasta %Windir%\$NTUninstallKB910242$\Spuninst.

Para obter mais informações, clique no seguinte número de artigo para exibir o artigo na Base de Dados de Conhecimento Microsoft:
832475Descrição dos novos recursos do instalador de pacotes para atualizações de software do Windows

Requisito de reinicialização

Se solicitado, reinicie o computador após a instalação do hotfix.

Informações do arquivo

Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHora
Crmmsg.dll1.2.3297.12316.08807-Set-200519:52
Microsoft.crm.application.pages.dll3.0.5300.1005965.38401-Dez-200518:47
Mscrmcustom.dll3.0.5300.101147.45628-Out-200522:39
Systemsettings.aspxNão aplicável33.17101-Dez-200520:09
Crmhotfix.cdfNão aplicável2.57805-Dez-200523:54
Mscrmcustom.dll3.0.5300.101147.45628-Out-200522:39
Updspapi.dll6.1.22.0371.93607-Set-200519:53

Situação

Microsoft Dynamics CRM 3.0

A Microsoft confirmou que esse é um problema dos produtos da Microsoft listados na seção "Aplica-se a".
Este problema foi corrigido no Pacote Cumulativo de Atualizações 1 do Microsoft Dynamics CRM 3.0.

Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers

A Microsoft confirmou que esse é um problema dos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre a terminologia usada para descrever as atualizações de software da Microsoft, clique nos números dos artigos a seguir para exibir os artigos da Base de Dados de Conhecimento Microsoft:
824684 Descrição da terminologia padrão utilizada para descrever as atualizações de software da Microsoft
887283Padrões de nomenclatura do pacote de hotfix e atualização do software Microsoft Business Solutions CRM

Propriedades

ID do artigo: 910242 - Última revisão: quinta-feira, 14 de junho de 2007 - Revisão: 6.1
A informação contida neste artigo aplica-se a:
  • Microsoft Dynamics CRM 3.0
  • Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers
Palavras-chave: 
kbemail kberrmsg kbmbsemail kbmbsmigrate kbpubtypekc kbhotfixserver kbqfe KB910242

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com