You receive an error message when you try to open a document on a secured FTP server in Windows XP

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Article ID: 910274 - View products that this article applies to.
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows registry
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SYMPTOMS

When you try to open a document on a secured FTP server in Microsoft Windows XP, you receive an error message. The error message states that the document cannot be opened.

Note A secured FTP server does not accept anonymous requests. To access a file on a secured FTP server, the user name and password must be supplied as a part of the URL that is used to make the request. This URL uses the following format:
ftp://user_name:password@computer_name/path_to_resource
For more information about how to access a file on a secured FTP server, click the following article number to view the article in the Microsoft Knowledge Base:
159617 How to access a secured resource using the FTP Protocol

CAUSE

The problem occurs because the document is removed from the cache before the application can open the document. The document is removed because of special handling that is used when you access secured documents by using an authenticated FTP URL. The problem is known to occur when you use the .tif, .doc, or .xls document extensions. However, the problem may also occur when you use documents that have different extensions.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this problem, install the hotfix that is described in this article, and then add two DWORD entries to the following registry subkey:
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_PERMIT_CACHE_FOR_AUTHENTICATED_FTP_KB910274
The two DWORD entries are named IEXPLORE.EXE and IEXPLORE.EXE. Each entry requires a value of 1.

To add these registry entries, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. On the Edit menu, point to New, and then click Key.
  4. Type FEATURE_PERMIT_CACHE_FOR_AUTHENTICATED_FTP_KB910274 for the name of the subkey, and then press ENTER.
  5. Double-click the FEATURE_PERMIT_CACHE_FOR_AUTHENTICATED_FTP_KB910274 subkey.
  6. On the Edit menu, point to New, and then click DWORD Value.
  7. Type IEXPLORE.EXE for the name of the DWORD, and then press ENTER.
  8. Right-click IEXPLORE.EXE, and then click Modify.
  9. In the Value data box, type 1, and then click OK.
  10. On the Edit menu, point to New, and then click DWORD Value.
  11. Type EXPLORER.EXE for the name of the DWORD, and then press ENTER.
  12. Right-click EXPLORER.EXE, and then click Modify.
  13. In the Value data box, type 1, and then click OK.
  14. Quit Registry Editor.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Wininet.dll6.0.2900.2797662,01616-Nov-200502:39x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 910274 - Last Review: June 1, 2006 - Revision: 1.3
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbexpertiseinter KB910274

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